stepan@ra:~/svn/coreboot/src/southbridge/amd/sb700> ls chip.h Kconfig Makefile.inc sb700.c sb700_early_setup.c sb700_enable_usbdebug.c sb700.h sb700_hda.c sb700_ide.c sb700_lpc.c sb700_pci.c sb700_reset.c sb700_sata.c sb700_smbus.c sb700_smbus.h sb700_sm.c sb700_usb.c
The sb700_ prefix was introduced in the early v2 tree many years ago because our old build system "newconfig" could not handle two files with the same name in different paths like /path/to/usb.c and /another/path/to/usb.c correctly. Only one of the files would end up being compiled into the final image.
Since Kconfig (actually since shortly before we switched to Kconfig) we don't suffer from that problem anymore. So we could drop the sb700_ prefix from all those filenames (or, the <componentname>_ prefix in general)
- makes it easier to fork off a new chipset - makes it easier to diff against other chipsets - storing redundant information in filenames seems wrong
Signed-off-by: stepan@coresystems.de I'm not going to post a patch, as it can not properly reflect the file renames anyways.
What do you think?
Stefan
Am 04.12.2010 21:00, schrieb Stefan Reinauer:
Since Kconfig (actually since shortly before we switched to Kconfig) we don't suffer from that problem anymore. So we could drop the sb700_ prefix from all those filenames (or, the <componentname>_ prefix in general)
- makes it easier to fork off a new chipset
- makes it easier to diff against other chipsets
- storing redundant information in filenames seems wrong
Signed-off-by: stepan@coresystems.de I'm not going to post a patch, as it can not properly reflect the file renames anyways.
What do you think?
I really like that!
Once abuild-tested: Acked-by: Patrick Georgi patrick@georgi-clan.de
Thanks, Patrick
On Sat, Dec 4, 2010 at 3:32 PM, Patrick Georgi patrick@georgi-clan.de wrote:
Am 04.12.2010 21:00, schrieb Stefan Reinauer:
Since Kconfig (actually since shortly before we switched to Kconfig) we don't suffer from that problem anymore. So we could drop the sb700_ prefix from all those filenames (or, the <componentname>_ prefix in general)
- makes it easier to fork off a new chipset
- makes it easier to diff against other chipsets
- storing redundant information in filenames seems wrong
Signed-off-by: stepan@coresystems.de I'm not going to post a patch, as it can not properly reflect the file renames anyways.
What do you think?
I really like that!
Once abuild-tested: Acked-by: Patrick Georgi patrick@georgi-clan.de
Sounds good to me.
Marc
Stefan Reinauer wrote:
The sb700_ prefix was introduced in the early v2 tree many years ago because our old build system "newconfig" could not handle two files with the same name in different paths like /path/to/usb.c and /another/path/to/usb.c correctly. Only one of the files would end up being compiled into the final image.
Since Kconfig (actually since shortly before we switched to Kconfig) we don't suffer from that problem anymore. So we could drop the sb700_ prefix from all those filenames (or, the <componentname>_ prefix in general)
- makes it easier to fork off a new chipset
- makes it easier to diff against other chipsets
- storing redundant information in filenames seems wrong
Signed-off-by: stepan@coresystems.de
Acked-by: Peter Stuge peter@stuge.se
On Sat, Dec 04, 2010 at 12:00:08PM -0800, Stefan Reinauer wrote:
The sb700_ prefix was introduced in the early v2 tree many years ago because our old build system "newconfig" could not handle two files with the same name in different paths like /path/to/usb.c and /another/path/to/usb.c correctly. Only one of the files would end up being compiled into the final image.
Since Kconfig (actually since shortly before we switched to Kconfig) we don't suffer from that problem anymore. So we could drop the sb700_ prefix from all those filenames (or, the <componentname>_ prefix in general)
Yup, I like it. I'd do it in small steps though (one SB/NB/superio at a time) otherwise it's probably too much tedious work and will break lots of pending patches etc.
Uwe.