Hello
What is the difference betwen ROM_SIZE defined in src/mainboard/Kconfig and ROM_IMAGE_SIZE from src/arch/i386/Kconfig?
I modified one entry in src/arch/i386/Kconfig to make live easier when changing size of rom because rombase will adjust automatically, for me works perfectly, but i am not sure if ROM_IMAGE_SIZE should get similar automated defaults or not.
I will prepare a patch if its desired.
config ROMBASE hex default 0xffff0000 default 0xfffe0000 if COREBOOT_ROMSIZE_KB_128 default 0xfffc0000 if COREBOOT_ROMSIZE_KB_256 default 0xfff80000 if COREBOOT_ROMSIZE_KB_512 default 0xfff00000 if COREBOOT_ROMSIZE_KB_1024 default 0xffe00000 if COREBOOT_ROMSIZE_KB_2048 default 0xffc00000 if COREBOOT_ROMSIZE_KB_4096
best regards Maciej
On Fri, Nov 13, 2009 at 5:36 PM, Maciej Pijanka maciej.pijanka@gmail.com wrote:
Hello
What is the difference betwen ROM_SIZE defined in src/mainboard/Kconfig and ROM_IMAGE_SIZE from src/arch/i386/Kconfig?
ROM_SIZE is the size of the total image including boot block, coreboot_ram, payloads...
ROM_IMAGE_SIZE used to be the way you could tell fallback or normal how much space to take. I'm not sure exactly what it does right now.
Thanks, Myles
Am 14.11.2009 18:23, schrieb Myles Watson:
ROM_IMAGE_SIZE used to be the way you could tell fallback or normal how much space to take. I'm not sure exactly what it does right now.
It's the bootblock size, and must correspond with ROMBASE.
Patrick
Patrick Georgi wrote:
Am 14.11.2009 18:23, schrieb Myles Watson:
ROM_IMAGE_SIZE used to be the way you could tell fallback or normal how much space to take. I'm not sure exactly what it does right now.
It's the bootblock size, and must correspond with ROMBASE.
If it will still be the bootblock size for some time, I suggest changing the name to BOOTBLOCK_SIZE.
If it will become the size for bootblock+somethingelse then I think a different name would be better.
//Peter