* svn@coreboot.org svn@coreboot.org [080512 23:19]:
Author: hailfinger Date: 2008-05-12 23:19:53 +0200 (Mon, 12 May 2008) New Revision: 3300
Modified: trunk/util/flashrom/flash.h
--- trunk/util/flashrom/flash.h 2008-05-12 14:25:31 UTC (rev 3299) +++ trunk/util/flashrom/flash.h 2008-05-12 21:19:53 UTC (rev 3300) @@ -66,6 +66,7 @@ #define TEST_OK_READ (1<<1) #define TEST_OK_ERASE (1<<2) #define TEST_OK_WRITE (1<<3) +#define TEST_OK_PREW (TEST_OK_PROBE|TEST_OK_READ|TEST_OK_ERASE|TEST_OK_WRITE)
Can we call this TEST_OK_ALL or something? PREW is not exactly intuitive.
Stefan
On 13.05.2008 23:53, Stefan Reinauer wrote:
- svn@coreboot.org svn@coreboot.org [080512 23:19]:
Author: hailfinger Date: 2008-05-12 23:19:53 +0200 (Mon, 12 May 2008) New Revision: 3300
Modified: trunk/util/flashrom/flash.h
--- trunk/util/flashrom/flash.h 2008-05-12 14:25:31 UTC (rev 3299) +++ trunk/util/flashrom/flash.h 2008-05-12 21:19:53 UTC (rev 3300) @@ -66,6 +66,7 @@ #define TEST_OK_READ (1<<1) #define TEST_OK_ERASE (1<<2) #define TEST_OK_WRITE (1<<3) +#define TEST_OK_PREW (TEST_OK_PROBE|TEST_OK_READ|TEST_OK_ERASE|TEST_OK_WRITE)
Can we call this TEST_OK_ALL or something? PREW is not exactly intuitive.
ProbeReadEraseWrite is the best I could come up with. Once we support sector-based unlocking and sector-based erasing, we might add TEST_OK_UNLOCK and TEST_OK_SECTOR_ERASE. Having TEST_OK_ALL as alias would mean we assume any new functionality is supported on all chips. That would defeat the purpose of such support statements.
Regards, Carl-Daniel
Carl-Daniel Hailfinger wrote:
On 13.05.2008 23:53, Stefan Reinauer wrote:
- svn@coreboot.org svn@coreboot.org [080512 23:19]:
Author: hailfinger Date: 2008-05-12 23:19:53 +0200 (Mon, 12 May 2008) New Revision: 3300
Modified: trunk/util/flashrom/flash.h
--- trunk/util/flashrom/flash.h 2008-05-12 14:25:31 UTC (rev 3299) +++ trunk/util/flashrom/flash.h 2008-05-12 21:19:53 UTC (rev 3300) @@ -66,6 +66,7 @@ #define TEST_OK_READ (1<<1) #define TEST_OK_ERASE (1<<2) #define TEST_OK_WRITE (1<<3) +#define TEST_OK_PREW (TEST_OK_PROBE|TEST_OK_READ|TEST_OK_ERASE|TEST_OK_WRITE)
Can we call this TEST_OK_ALL or something? PREW is not exactly intuitive.
ProbeReadEraseWrite is the best I could come up with. Once we support sector-based unlocking and sector-based erasing, we might add TEST_OK_UNLOCK and TEST_OK_SECTOR_ERASE. Having TEST_OK_ALL as alias would mean we assume any new functionality is supported on all chips. That would defeat the purpose of such support statements.
Then let's not use PREW. Or we will have to end up providing all different kinds of combinations.
On 14.05.2008 00:08, Stefan Reinauer wrote:
Carl-Daniel Hailfinger wrote:
On 13.05.2008 23:53, Stefan Reinauer wrote:
- svn@coreboot.org svn@coreboot.org [080512 23:19]:
Author: hailfinger Date: 2008-05-12 23:19:53 +0200 (Mon, 12 May 2008) New Revision: 3300
Modified: trunk/util/flashrom/flash.h
--- trunk/util/flashrom/flash.h 2008-05-12 14:25:31 UTC (rev 3299) +++ trunk/util/flashrom/flash.h 2008-05-12 21:19:53 UTC (rev 3300) @@ -66,6 +66,7 @@ #define TEST_OK_READ (1<<1) #define TEST_OK_ERASE (1<<2) #define TEST_OK_WRITE (1<<3) +#define TEST_OK_PREW (TEST_OK_PROBE|TEST_OK_READ|TEST_OK_ERASE|TEST_OK_WRITE)
Can we call this TEST_OK_ALL or something? PREW is not exactly intuitive.
ProbeReadEraseWrite is the best I could come up with. Once we support sector-based unlocking and sector-based erasing, we might add TEST_OK_UNLOCK and TEST_OK_SECTOR_ERASE. Having TEST_OK_ALL as alias would mean we assume any new functionality is supported on all chips. That would defeat the purpose of such support statements.
Then let's not use PREW. Or we will have to end up providing all different kinds of combinations.
The only combinations I can think of are P, PR, PREW. It is very unlikely that someone will test erase and write without testing read and probe. It's also unlikely someone will test erase without write.
Regards, Carl-Daniel
On Wed, May 14, 2008 at 12:08:25AM +0200, Stefan Reinauer wrote:
Having TEST_OK_ALL as alias would mean we assume any new functionality is supported on all chips. That would defeat the purpose of such support statements.
Then let's not use PREW.
Please suggest better short names. I wanted to come up with something that would fit into the file without making lines insanely long.
//Peter