See patch.
Stefan Reinauer wrote:
- Set USBDEBUG_DEFAULT_PORT in all southbridges and use that value to unify calls to *_enable_usbdebug()
- rename *_enable_usbdebug() to enable_usbdebug()
- move enable_usbdebug() to generic romstage console init code and drop it from the individual romstage.c files.
Something similar should happen to the uart init:
- uart_init() can go into console.c right now
- superio init should go into a function local_uart_init() defined in romstage.c and be called from console_init, too.
Signed-off-by: Stefan Reinauer stefan.reinauer@coreboot.org
Acked-by: Peter Stuge peter@stuge.se