Hi,
I'd like to continue thinning out the mainboard specific code for the K8 mainboards, so it will be easier to keep all the mainboards on the same level if the infrastructure code around it changes. All code that is used by two or more motherboards should go to the northbridge or southbridge code (or elsewhere)
* failover.c this seems to be the same on all K8 boards. It contains code that is specific to the amd 8111 south bridge. I suggest splitting this in two pieces, one going to the cpu/k8 code, the other one going to the southbridge directory. Maybe this could even be used by x86 based non-K8 boards?
* chip.h What exactly is this good for? It seems to be unused by all K8 boards. Do we need it? Should it be merged with mainboard.c?
mainboard.c and auto.c will probably always stay. (Can we rename this to more speaking names, too? At least init.c or sth like that sounds a lot more descriptive)
irq_tables.c and mptable.c will hopefully become autogenerated from config some time, too.
This could reduce the amount of mainboard specific code to not more than four files, giving any hardware vendor a fair chance to jump on the boat...
Stefan
On Thu, 25 Mar 2004, Stefan Reinauer wrote:
- failover.c this seems to be the same on all K8 boards. It contains code that is specific to the amd 8111 south bridge. I suggest splitting this in two pieces, one going to the cpu/k8 code, the other one going to the southbridge directory. Maybe this could even be used by x86 based non-K8 boards?
sounds good.
- chip.h What exactly is this good for? It seems to be unused by all K8 boards. Do we need it? Should it be merged with mainboard.c?
the plan was to contain mainboard-specific stuff in here, generated by the config tool, just as in all other devices. If we are not going to use it it should go away. No one appears to be using it.
irq_tables.c and mptable.c will hopefully become autogenerated from config some time, too.
some day ...
I like it, reducing # files is good.
ron