* Uwe Hermann uwe@hermann-uwe.de [070706 02:05]:
Various spinlock-related cleanups:
- Revert back to spinlock_t (instead of struct spinlock). This is fine in this special case, as the contents of spinlock_t are not meant to ever be accessed directly (only by "accessor" functions).
NACK.
Why would that be required? The code in svn needs no fixing. Let's not invent typedefs without any need for them
- Drop the spin_lock_string and spin_unlock_string macros, they're pretty useless as they're only used in a single place and a macro doesn't make this code any more readable, IMO.
NACK.
They are not useless at all as they are _the_ (one and only) spinlock implementation on x86. The "only single place" is the declaration of the x86 specific spin_lock and spin_unlock functions.