+static int read_flash(struct flashchip *flash, uint8_t *buf, uint32_t offset, uint32_t length) +{
- int total_size = flash->total_size * 1024;
total_size should be unsigned.
Agreed, but found some inconsistencies for total_size : - "size_t" is used, like in map_flash_registers() - "int" is used, like in verify_flash() Anyway, the best would be to use "size_t", not "unsigned int" or "unsigned long".
Stephan.