Uwe Hermann wrote:
On Tue, May 15, 2007 at 03:58:40PM -0400, Corey Osgood wrote:
Hmm, why don't we just fix raminit.c and debug.c (and northbridge.c, if applicable) for those northbridges (vt8601, vt8623, 440bx) to just use smbus_read_byte instead of spd_read_byte? Eliminate any chance of a problem altogether?
spd_read_byte() is the correct name, so it should stay IMO. Is there a reason why all/most boards define this as a wrapper for smbus_read_byte()?
Could this be something else than smbus_read_byte() for some board? If no, maybe a #define is easier? Or move the wrapper to a central location?
okay, I guess this is the real question: is there ever any case where or reason why spd_read_byte doesn't just return smbus_read_byte? And if not, then why should we use a wrapper if it isn't necessary? I mean, it would be even easier just to change the south bridges from smbus_read_byte to spd_read_byte. This wrapper makes the code less readable, and evidently causes problems, so I can't understand why having it is a good thing, unless there's some other driving need for it.
-Corey