I remember that if changed that to unsigned, for four ways system it will not be compiled by ROMCC.
YH
-----Original Message----- From: linuxbios-bounces@openbios.org [mailto:linuxbios-bounces@openbios.org] On Behalf Of Jason Schildt Sent: Tuesday, September 06, 2005 7:18 AM To: Stefan Reinauer Cc: linuxbios@openbios.org Subject: Re: [LinuxBIOS] LNXI Merge: lnxi-patch-11/16
On Tue, Sep 06, 2005 at 12:08:50PM +0200, Stefan Reinauer wrote:
- jason schildt jschildt@lnxi.com [050903 00:03]:
+/* We can reduce the size of code generated by romcc by
- changing all of the fixed size types that live in registers
- into simple unsigned variables. (ie s/uint8_t/unsigned/g)
- */
Why is this? I would consider specifying an 8bit type to be more space-safing than using some generic untyped integer value. If not
this
should be fixed in romcc..
You're right in your thinking, but at this time ROMCC converts it to an unsigned anyway and winds up producing more code doing so. So in the end the space saving measure costs more in code size produced by ROMCC.
/* AMD K8 Unsupported 1Ghz? */ if (id == (PCI_VENDOR_ID_AMD | (0x1100 << 16))) {
if (is_cpu_pre_e0()) // CK804 support 1G?
device_t dev_2 = PCI_DEV(0,0x18,2);
if(pci_read_config32(dev_2,0x9c) < 0x20f00) {
The function call looks a lot more readable here. How much is the gain of manual inlining here?
Stefan
-- LinuxBIOS mailing list LinuxBIOS@openbios.org http://www.openbios.org/mailman/listinfo/linuxbios