Patrick Georgi wrote:
Index: src/southbridge/via/Makefile.inc
--- src/southbridge/via/Makefile.inc (Revision 4672) +++ src/southbridge/via/Makefile.inc (Arbeitskopie) @@ -1,5 +1,4 @@ -#subdirs-y += k8t890 -#subdirs-y += vt8231 -#subdirs-y += vt8235 +subdirs-$(CONFIG_SOUTHBRIDGE_VIA_K8T890) += k8t890 +subdirs-$(CONFIG_SOUTHBRIDGE_VIA_VT8231) += vt8231 +subdirs-$(CONFIG_SOUTHBRIDGE_VIA_VT8235) += vt8235 subdirs-$(CONFIG_SOUTHBRIDGE_VIA_VT8237R) += vt8237r
-#subdirs-y += vt82c686
This will still be required later I guess (?).
vt82c686 is a weird stub of southbridge support: I found no use of it, and it seems to handle serial enable, only. My proposal? Unless it will actually be used, get rid of it.
Acked-by: Stefan Reinauer stepan@coresystems.de
Index: src/cpu/intel/model_1067x/Kconfig
--- src/cpu/intel/model_1067x/Kconfig (Revision 0) +++ src/cpu/intel/model_1067x/Kconfig (Revision 0) @@ -0,0 +1,5 @@ +config CPU_INTEL_CORE2
- bool
- default y
- select SMP
- select HAVE_MOVNTI
The syntax (i.e. using default y) means that all model_1067x are Core2? Is that correct?
I think so. If not, it should be renamed to CPU_INTEL_MODEL_1067X in my opinion.
Is that really the implication? I thought it means that if model_1067x/Kconfig is loaded, code that belongs to core2 is also selected. That's good, and it should be different from the assumption that all mode_1067x are core2, even though I think this is correct (some might be Atom, though, not 100% sure)
Stefan