What's the difference between CONFIG_COMPRESSED_ROM_STREAM and CONFIG_COMPRESS? Can we use lzma compression for both?
CONFIG_COMPRESSED_ROM_STREAM says: the payload is compressed. CONFIG_COMPRESS says: LinuxBIOS is compressed.
Perhaps we should rename those to something more indicative of what they do? Say:
CONFIG_COMPRESSED_ROM_STREAM -> CONFIG_COMPRESSED_PAYLOAD CONFIG_COMPRESS -> CONFIG_COMPRESSED_LINUXBIOS