Flashrom patched for compiling with libpayload while still being able to compile with libpciutil; uses coreboot styled pci function names found in libpayload.
Signed-off-by: Sean Nelson snelson@nmt.edu
---
I've converted flashrom to use coreboot's pci style function naming. flash.h holds majority of code to translate pci functions to use libpciutil, and add additional code/functions need in libpayload. I tried to make minimal structural changes. I'd suggest someone re-implement or structure this patch into something more beautiful, and put in additional work with the Makefile. Maybe move some of the libpayload functions found in flash.h into libpayload.
On Thu, Aug 07, 2008 at 09:38:11PM -0700, Sean Nelson wrote:
Flashrom patched for compiling with libpayload while still being able to compile with libpciutil; uses coreboot styled pci function names found in libpayload.
Signed-off-by: Sean Nelson snelson@nmt.edu
Nice, thanks.
Not much time now, will post a detailed review later this day, but one thing I've seen so far: please post an extra patch against flashrom proper to change "lb_" to "cb_", this issue is independent of any libpayload involvement and should be an extra patch.
More comments later.
Uwe.
On Thu, Aug 07, 2008 at 09:38:11PM -0700, Sean Nelson wrote:
I'd suggest someone re-implement or structure this patch into something more beautiful, and put in additional work with the Makefile.
Please don't commit this as is into trunk, but maybe starting a new branch is a good idea? (Not fork! svn branch)
//Peter