On Sun, Oct 3, 2010 at 10:03 PM, Peter Stuge peter@stuge.se wrote:
Warren Turkal wrote:
I am sure this it bike shedding, but here are a few other options for the name scheme:
- pci_bit_and8()
- pci_bitwise_and8()
- pci_bit_andb()
- pci_bitwise_andb()
Don't like _set and _clear at all?
What about _setbits_config8 and _clearbits_config8? That might be more readable.
I am waffling between preferring pci_bitwise_andb() or pci_bitwise_and8() for readability.
I think it's a good idea to be consistent with the other functions, which are all using the numeric size.
Good point.
Current list as I see it: * pci_{set,clear}bits_config8() * pci_{set,clear}8() * pci_bit_{or,and}8() * pci_bitwise_{or,and}8()
Did I miss any?
I currently prefer pci_{set,clear}bits_config8().
Thanks, wt