This sounds like a good idea to me.
I think that it might be a good idea to present the two things as seperate components. In my opinion it makes sense to leave the init framework as 'coreboot'. However the firmware glue framework should probably be called something diffierent, like 'core firmware framework' (or if someone has a shorter yet still descriptive name, that would be good).
While these two code bases could live in the same repository, distinguishing them on the front page would probably go a long way to helping people understand what the thing they are using provides. 'Coreboot' provides an auditable init system, while 'core firmware framework' provides an auditable framework for glueing firmware, typical vendor blobs, together.
Platforms that support the coreboot native init could be labled as having actual coreboot support, while those that use the glue logic only, and thus require vender blobs to do the actual init, would be labled as having core firmware framework support (or again, another name for the new umbrella term).