On Fri, 2008-01-18 at 03:13 +0100, Carl-Daniel Hailfinger wrote:
I was unclear. I mean stuff like this:
void spi_write_status_register(int status) { const unsigned char cmd[] = {0x01,(unsigned char)status};
would probably be more readable if it looked like this:
void spi_write_status_register(int status) { const unsigned char cmd[] = {JEDEC_WRSR,(unsigned char)status}; /* Send WRSR (Write Status Register) */ generic_spi_command(JEDEC_WRSR_OUTSIZE, JEDEC_WRSR_INSIZE, cmd, NULL); }
I think this is a matter of taste... But if the style is like this, I will comply. So I changed my patch again to do exactly the same, but with a few JEDEC_... defines.
Regards, Carl-Daniel
Regards, Ronald
Signed-off-by: Ronald Hoogenboom hoogenboom30@zonnet.nl
---