Very nice!
On 1/3/10 10:08 PM, Patrick Georgi wrote:
Hi,
batch of patches:
20100103-1-use-selected-udelay-function Kconfig used the TSC timer unconditionally.
Acked-by: Stefan Reinauer stepan@coresystems.de
20100103-2-include-forgotten-intel-socket An intel socket is still commented out - probably forgotten in the mass conversion effort
Acked-by: Stefan Reinauer stepan@coresystems.de
20100103-3-intel-cpus-have-movnti Set HAVE_MOVNTI per CPU for intels as defined in Config.lb files (only where Kconfig files for CPUs already exist)
Acked-by: Stefan Reinauer stepan@coresystems.de
20100103-4-tinybootblock-for-intel-cpus Add tinybootblock handling to Intel's CAR code:
- avoid the normal/fallback decision (we don't have __normal_image, and
we'd use CBFS for loading anyway)
- use CONFIG_XIP_ROM_BASE as external symbol, filled in by the linker.
Necessary to match the XIP region with the place where the romstage ends up in (see next patch)
+#if defined(CONFIG_TINY_BOOTBLOCK) && CONFIG_TINY_BOOTBLOCK +#undef CONFIG_XIP_ROM_BASE + movl $CONFIG_XIP_ROM_BASE, %eax + orl $MTRR_TYPE_WRBACK, %eax +#else movl $(CONFIG_XIP_ROM_BASE | MTRR_TYPE_WRBACK), %eax +#endif
This looks very odd... I'd see why you'd do the undef, given the next patch, but why produce the register value at runtime? Since this is not a CONFIG variable in tinybootblock, maybe it would make sense to call it differently instead of undef'ing it? I.e. AUTO_CALCULATED_XIP_ROM_BASE (or something better ;)
20100103-5-retarget-xip-base-for-romstage
- Add proper CONFIG_XIP_ROM_BASE to location.ld (used when linking the
romstage)
I guess this is needed for the patch above?
20100103-6-clean-up-kontron-config (might not apply cleanly due to manual dissection into patches -6 and -7)
- HAVE_ACPI_SLIC is not a Kconfig variable (no CONFIG_ prefix, for starters)
- HAVE_MOVNTI is defined per-CPU, not per-board (and with -3 it actually is)
Acked-by: Stefan Reinauer stepan@coresystems.de
20100103-7-tinybootblock-for-kontron-986lcd-m
- changes necessary to make Kontron use tinybootblock
Acked-by: Stefan Reinauer stepan@coresystems.de
Signed-off-by: Patrick Georgi patrick.georgi@coresystems.de