On 10.07.2008 14:01, Peter Stuge wrote:
On Sat, Jul 05, 2008 at 04:35:29PM +0200, Carl-Daniel Hailfinger wrote:
mainboard-vendor = "Emulation"; mainboard-name = "QEMU x86";
- mainboard_pci_subsystem_vendor = "0x15ad";
- mainboard_pci_subsystem_device = "0x1976"; device_operations = "qemuvga_pci_ops_dev";
The dts syntax is somewhat inconsistent, sometimes - sometimes _. Is there a rule?
My goal was to have the same name in the dts which is also used as variable name in C code. The existing code has a somewhat peculiar mapping from organic growth over time: mainboard-vendor -> const char *mainboard_vendor mainboard-name -> const char *mainboard_part_number If we can agree on whether the variable should be called "mainboard_name" or "mainboard_part_number", I'd be willing to prepare a patch.
And why are hex numbers specified as strings? That is silly.
Honestly, this is one of my first interactions with the device tree code and I just adapted existing code. I tried specifying them as numbers, but I got a syntax error back from dtc. You may have noticed that all numbers in all dts files are specified as strings if they are values of properties. Someone more familiar with the DTS spec may want to comment on that.