On Mon, Jan 28, 2008 at 10:51:19AM -0700, Myles Watson wrote:
It works great for me. The only thing I would like better is if the target were added to the end of the customconfig file, so that you wouldn't accidentally pick up the wrong config. (i.e., customconfig-qemu or customconfig-s2891).
I've implemented that - the naming convention for the customconfig files is now
customconfig--$(PAYLOAD)--$(COREBOOT_VENDOR)--$(COREBOOT_BOARD)
and in the case of uclibc and the kernel, I've added the architecture in there as well:
customconfig--$(PAYLOAD)--$(UCLIBC_ARCH)--$(COREBOOT_VENDOR)-$(COREBOOT_BOARD) customconfig--$(PAYLOAD)--$(KERNEL_BUILD_ARCH)--$(COREBOOT_VENDOR)-$(COREBOOT_BOARD)
Custom config files will only be used if the payload, (architecture,) vendor and board match.
If a custom config file is used, buildrom will say so on stdout.
The *-config commands are a bit smarter now: they will copy an existing custom config file back to the source directory so that doing a subsequent make something-config will have the effect of editing the custom config, rather than overwriting it.
I think that could be considered a matter of taste. Maybe we should add the custom-config option for the kernel as well.
I've added the kernel.
Thanks, Ward.