On 4/8/10 8:09 AM, Joseph Smith wrote:
Signed-off-by: Joseph Smith joe@settoplinux.org
Nice! Thanks, Joseph!
Index: src/cpu/intel/Kconfig
--- src/cpu/intel/Kconfig (revision 5372) +++ src/cpu/intel/Kconfig (working copy)
+source src/cpu/intel/socket_mfcbga479/Kconfig source src/cpu/intel/socket_mFCPGA478/Kconfig source src/cpu/intel/socket_mPGA478/Kconfig source src/cpu/intel/socket_mPGA479M/Kconfig
I think you should keep the naming convention here: mFCBGA479
Index: src/cpu/intel/Makefile.inc
--- src/cpu/intel/Makefile.inc (revision 5372) +++ src/cpu/intel/Makefile.inc (working copy) @@ -6,6 +6,7 @@ subdirs-$(CONFIG_CPU_INTEL_SOCKET_441) += socket_441 subdirs-$(CONFIG_CPU_INTEL_SOCKET_BGA956) += bga956 subdirs-$(CONFIG_CPU_INTEL_EP80579) += ep80579 +subdirs-$(CONFIG_CPU_INTEL_SOCKET_MFCBGA479) += socket_mfcbga479
ditto
Index: src/cpu/intel/model_6bx/Kconfig
--- src/cpu/intel/model_6bx/Kconfig (revision 0) +++ src/cpu/intel/model_6bx/Kconfig (revision 0) @@ -0,0 +1,3 @@ +config CPU_INTEL_CORE
- bool
- select SMP
Now, this is definitely wrong.
Index: src/cpu/intel/socket_mfcbga479/Kconfig
--- src/cpu/intel/socket_mfcbga479/Kconfig (revision 0) +++ src/cpu/intel/socket_mfcbga479/Kconfig (revision 0) @@ -0,0 +1,5 @@ +config CPU_INTEL_SOCKET_MFCBGA479
- bool
- select CPU_INTEL_MODEL_6BX
Where is CPU_INTEL_MODEL_6BX defined?
With above issues fixed this is Acked-by: Stefan Reinauer stepan@coresystems.de
Stefan