Hi,
since the Geode/CS553x platform emulates PCI headers for chipset/processor devices, we have the ability to switch off that emulation and hide those virtual PCI headers. Right now we do this in a fairly uncoordinated fashion: I counted at least three different open-coded code sequences with the same effect.
My current plan is: - encapsulate all those code sequences into calls of one or two functions - switch all calls from hide_vpci(some_value_calculated_by_hand) to hide_vpci_dev(struct device *) - replace the central array of hand-calculated values with a per-PCI-device "hidden" property.
This should result in an overall improvement of code readability and a reduction of code size. As a nice side benefit the dts is a lot easier to manipulate.
Questions? Comments?
Regards, Carl-Daniel