On Sat, Oct 27, 2007 at 05:21:17PM +0200, Rudolf Marek wrote:
- printk_info("%s IDE interface %s\n", "Primary",
sb->ide0_enable ? "enabled" : "disabled");
- printk_info("%s IDE interface %s\n", "Secondary",
sb->ide1_enable ? "enabled" : "disabled");
Looks like size-optimizing? Are you sure this is good? It's a little more difficult to read. (Might just be copypaste and not your idea?)
copypaste ;)
This code is ok IMO. It's from my 82371EB patch a while a ago I think, where I used two normal printk_info()s which made the code unnecessarily bigger, as spotted by Stefan. The above solution fixed that.
Maybe even "enabled" -> "on" and "disabled" -> "off"? Saveѕ some more bytes and we lose no information whatsoever.
- /* standard bios sets master bit. */
- enables = pci_read_config8(dev, PCI_COMMAND);
- enables |= PCI_COMMAND_MASTER | PCI_COMMAND_IO;
Discussion please? Try to find out why this is a good idea. Is this enabling bus mastering? Why would that be a bad idea?
Please try to not use factory BIOS as justification until we've run out of ideas completely.
Full ACK.
Well the older VIA driver in LB does it too. I think linux will switch bus master when needed. I think we can drop this.
Only if non-Linux payloads are tested/guaranteed to be able to cope with that, too.
Uwe.