Don't pull in VERSION from the build environment - there is too great a potential for a variable conflict.
Signed-off-by: Kevin O'Connor kevin@koconnor.net --- Makefile | 1 + 1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile index e287530..220a9f7 100644 --- a/Makefile +++ b/Makefile @@ -26,6 +26,7 @@ PYTHON=python CPP=cpp IASL:=iasl LD32BIT_FLAG:=-melf_i386 +VERSION:=
# Source files SRCBOTH=misc.c stacks.c output.c string.c block.c cdrom.c disk.c mouse.c kbd.c \
Am Mittwoch, den 12.08.2015, 18:32 -0400 schrieb Kevin O'Connor:
Don't pull in VERSION from the build environment - there is too great a potential for a variable conflict.
Signed-off-by: Kevin O'Connor kevin@koconnor.net
Makefile | 1 + 1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile index e287530..220a9f7 100644 --- a/Makefile +++ b/Makefile @@ -26,6 +26,7 @@ PYTHON=python CPP=cpp IASL:=iasl LD32BIT_FLAG:=-melf_i386 +VERSION:=
What about changing the name to `SEABIOS_VERSION` instead to avoid possible conflicts?
Thanks,
Paul
On Thu, Aug 13, 2015 at 07:59:42AM +0200, Paul Menzel wrote:
Am Mittwoch, den 12.08.2015, 18:32 -0400 schrieb Kevin O'Connor:
Don't pull in VERSION from the build environment - there is too great a potential for a variable conflict.
Signed-off-by: Kevin O'Connor kevin@koconnor.net
Makefile | 1 + 1 file changed, 1 insertion(+)
diff --git a/Makefile b/Makefile index e287530..220a9f7 100644 --- a/Makefile +++ b/Makefile @@ -26,6 +26,7 @@ PYTHON=python CPP=cpp IASL:=iasl LD32BIT_FLAG:=-melf_i386 +VERSION:=
What about changing the name to `SEABIOS_VERSION` instead to avoid possible conflicts?
Thanks for reviewing.
I prefer to avoid pulling in settings from the environment because I find the extra complexity confusing.
That said, I don't plan to commit this patch. After further thought, I think the 'make VERSION=x' support was a mistake and should be reverted.
-Kevin