On Thu, Apr 10, 2014 at 04:29:40PM +0300, Marcel Apfelbaum wrote: [...]
- for (i = 0, cap = pci_config_readb(pci->bdf, PCI_CAPABILITY_LIST);
(i <= 0xff) && cap;
i++, cap = pci_config_readb(pci->bdf, cap + PCI_CAP_LIST_NEXT))
if (pci_config_readb(pci->bdf, cap + PCI_CAP_LIST_ID) == cap_id)
return cap;
I hate to nitpick, but I find that for-loop hard to read. What about something like:
int i; u8 cap = pci_config_readb(pci->bdf, PCI_CAPABILITY_LIST); for (i = 0, cap && i <= 0xff; i++) { if (pci_config_readb(pci->bdf, cap + PCI_CAP_LIST_ID) == cap_id) return cap; cap = pci_config_readb(pci->bdf, cap + PCI_CAP_LIST_NEXT)) }
Otherwise, your patches look fine to me.
-Kevin