This patch series improves the accuracy of the internal timers. It also refactors a bit of the code and makes it a little cleaner.
-Kevin
Kevin O'Connor (10): Move internal timer code from clock.c to a new file timer.c. Don't pass khz to pmtimer_setup - it's always PM_TIMER_FREQUENCY. Add helper functions to convert timer irqs to milliseconds. Improve accuracy of internal timers. Rename cpu_khz to TimerKHz. Shift CPU TSC down to reduce need for 64bit variables. Rename check_timer() function (and similar) to irqtimer_check(). Rename check_tsc() (and similar) to timer_check() and use u32. Separate out timer setup code. Unify pmtimer_read() and pittimer_read() code.
Makefile | 2 +- src/acpi.c | 2 +- src/ahci.c | 19 ++--- src/ata.c | 18 ++--- src/biosvar.h | 3 + src/blockcmd.c | 6 +- src/boot.c | 4 +- src/clock.c | 249 ++------------------------------------------------------- src/csm.c | 1 + src/floppy.c | 8 +- src/megasas.c | 10 +-- src/pciinit.c | 7 +- src/pit.h | 29 +++++++ src/post.c | 1 + src/ps2port.c | 8 +- src/serial.c | 12 +-- src/timer.c | 244 +++++++++++++++++++++++++++++++++++++++++++++++++++++++ src/usb-ehci.c | 16 ++-- src/usb-hub.c | 8 +- src/usb-ohci.c | 18 ++--- src/usb-uhci.c | 14 ++-- src/util.c | 4 +- src/util.h | 29 ++++--- 23 files changed, 374 insertions(+), 338 deletions(-) create mode 100644 src/pit.h create mode 100644 src/timer.c