On Mon, Jul 31, 2017 at 09:40:41PM +0300, Alexander Bezzubikov wrote:
+typedef struct PCIEPCIBridge {
- /*< private >*/
- PCIBridge parent_obj;
- bool msi_enable;
Please rename the msi_enable property to "msi" in order to be aligned with the existent PCIBridgeDev and consider making it OnOffAuto for the same reason. (I am not sure about the last part though, we have no meaning for "auto" here)
Agreed about "msi", but OnOffAuto looks weird to me as we always want MSI to be enabled.
Why even have a property then? Can't you enable it unconditionally?