On Wed, Jun 19, 2019 at 12:23:51PM +0300, Sam Eiderman wrote:
Adding the following utility functions:
* boot_lchs_find_pci_device * boot_lchs_find_scsi_device * boot_lchs_find_ata_device
FWIW, this leads to a bit of code duplication. I think it would be preferable to refactor the bootprio_find_XYZ() calls. Instead of returning an 'int prio' they could return a znprintf'd 'char *devpath' instead. Then the boot_add_XYZ() calls could directly call find_prio(devpath). The boot_add_hd() could then directly populate drive->lchs or call setup_translation().
-Kevin