More cleanups and enhancements. This series simplifies pci_next() so that it no longer needs to check for pci bridges.
The vgahook changes in the first patch were compile tested only.
-Kevin
Kevin O'Connor (4): Calculate vgahook responses during setup instead of in 16bit code. Convert pci_find_device/class to use 'struct pci_device'. Convert remaining callers of foreachbdf to foreachbdf_in_bus. Rename foreachbdf_in_bus to foreachbdf and simplify it.
src/acpi.c | 2 +- src/coreboot.c | 9 +- src/floppy.c | 4 +- src/optionroms.c | 3 +- src/pci.c | 173 ++++++++++++++++------------------ src/pci.h | 21 ++--- src/pcibios.c | 55 ++++++----- src/pciinit.c | 6 +- src/shadow.c | 4 +- src/smm.c | 10 +- src/usb-ehci.c | 3 +- src/util.h | 5 +- src/vgahooks.c | 274 ++++++++++++++++++++++-------------------------------- 13 files changed, 255 insertions(+), 314 deletions(-)