The first six patches in this series make the internal usb naming convention a little more standard. (Use a "usb_" prefix on all exported functions and don't use camel case on exported functions.)
The remaining five patches convert the USB controller drivers to a single pipe "realloc" function for managing pipe allocations and freeing. This should make it easier for xhci to implement pipe freeing (not implemented in this series).
-Kevin
Kevin O'Connor (11): usb: Rename ?hci_control() to ?hci_send_control() usb: Rename usb_getFrameExp() to usb_get_period() usb: Rename findEndPointDesc() to usb_find_desc() usb: Rename send_default_control() to usb_send_default_control() usb: Rename free_pipe() to usb_free_pipe() usb: Clarify usb freelist manipulations xhci: Change xhci_update_pipe() to xhci_realloc_pipe() and use for alloc too uhci: Export uhci_realloc_pipe() instead of uhci_alloc_pipe() ohci: Export ohci_realloc_pipe() instead of ohci_alloc_pipe() ehci: Export ehci_realloc_pipe() instead of ehci_alloc_pipe() usb: Use usb_realloc_pipe for pipe alloc, update, and free.
src/hw/usb-ehci.c | 17 +++++---- src/hw/usb-ehci.h | 9 +++-- src/hw/usb-hid.c | 6 +-- src/hw/usb-hub.c | 8 ++-- src/hw/usb-msc.c | 10 ++--- src/hw/usb-ohci.c | 17 +++++---- src/hw/usb-ohci.h | 9 +++-- src/hw/usb-uas.c | 8 ++-- src/hw/usb-uhci.c | 17 +++++---- src/hw/usb-uhci.h | 9 +++-- src/hw/usb-xhci.c | 18 ++++++--- src/hw/usb-xhci.h | 12 +++--- src/hw/usb.c | 109 +++++++++++++++++++++++++++++------------------------- src/hw/usb.h | 22 ++++++----- 14 files changed, 149 insertions(+), 122 deletions(-)