On Thu, Oct 16, 2014 at 04:22:52PM -0400, Kevin O'Connor wrote:
The first six patches in this series make the internal usb naming convention a little more standard. (Use a "usb_" prefix on all exported functions and don't use camel case on exported functions.)
The remaining five patches convert the USB controller drivers to a single pipe "realloc" function for managing pipe allocations and freeing. This should make it easier for xhci to implement pipe freeing (not implemented in this series).
FYI, I have pushed this series to the master branch.