Jérémy Compostella has submitted this change. ( https://review.coreboot.org/c/coreboot/+/86237?usp=email )
Change subject: vc/google/chromeos: Refactor Makefile to use a macro for CBFS logo
......................................................................
vc/google/chromeos: Refactor Makefile to use a macro for CBFS logo
This commit introduces a new macro, cbfs_add_bmp_file, to the ChromeOS
vendor code Makefile. The macro simplifies the process of adding BMP
files to the CBFS (coreboot Filesystem) by encapsulating the
repetitive tasks of specifying file attributes such as file path,
type, and compression flag.
TEST:Both 'cb_logo.bmp' and 'cb_plus_logo.bmp' files are included with
the same properties, within the coreboot firmware image.
Change-Id: I827451da79931c09768965c3ad071ecdd918d367
Signed-off-by: Jeremy Compostella <jeremy.compostella(a)intel.com>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/86237
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Subrata Banik <subratabanik(a)google.com>
---
M src/vendorcode/google/chromeos/Makefile.mk
1 file changed, 10 insertions(+), 8 deletions(-)
Approvals:
build bot (Jenkins): Verified
Subrata Banik: Looks good to me, approved
diff --git a/src/vendorcode/google/chromeos/Makefile.mk b/src/vendorcode/google/chromeos/Makefile.mk
index 44d4d2b..67b50f6b 100644
--- a/src/vendorcode/google/chromeos/Makefile.mk
+++ b/src/vendorcode/google/chromeos/Makefile.mk
@@ -30,12 +30,14 @@
BMP_LOGO_COMPRESS_FLAG := LZ4
endif
-cbfs-files-$(CONFIG_CHROMEOS_FW_SPLASH_SCREEN) += cb_logo.bmp
-cb_logo.bmp-file := $(call strip_quotes,$(CONFIG_CHROMEOS_LOGO_PATH))
-cb_logo.bmp-type := raw
-cb_logo.bmp-compression := $(BMP_LOGO_COMPRESS_FLAG)
+define add_bmp_logo_file_to_cbfs
+cbfs-files-$$($(1)) += $(2)
+$(2)-file := $$(call strip_quotes,$$($(3)))
+$(2)-type := raw
+$(2)-compression := $$(BMP_LOGO_COMPRESS_FLAG)
+endef
-cbfs-files-$(CONFIG_CHROMEOS_FW_SPLASH_SCREEN) += cb_plus_logo.bmp
-cb_plus_logo.bmp-file := $(call strip_quotes,$(CONFIG_CHROMEBOOK_PLUS_LOGO_PATH))
-cb_plus_logo.bmp-type := raw
-cb_plus_logo.bmp-compression := $(BMP_LOGO_COMPRESS_FLAG)
+$(eval $(call add_bmp_logo_file_to_cbfs,CONFIG_CHROMEOS_FW_SPLASH_SCREEN, \
+ cb_logo.bmp,CONFIG_CHROMEOS_LOGO_PATH))
+$(eval $(call add_bmp_logo_file_to_cbfs,CONFIG_CHROMEOS_FW_SPLASH_SCREEN, \
+ cb_plus_logo.bmp,CONFIG_CHROMEBOOK_PLUS_LOGO_PATH))
--
To view, visit https://review.coreboot.org/c/coreboot/+/86237?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: merged
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I827451da79931c09768965c3ad071ecdd918d367
Gerrit-Change-Number: 86237
Gerrit-PatchSet: 3
Gerrit-Owner: Jérémy Compostella <jeremy.compostella(a)intel.com>
Gerrit-Reviewer: Jérémy Compostella <jeremy.compostella(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Attention is currently required from: Felix Held, Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Varshit Pandya.
Nick Kochlowski has posted comments on this change by Nick Kochlowski. ( https://review.coreboot.org/c/coreboot/+/85634?usp=email )
Change subject: drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
......................................................................
Patch Set 20:
(1 comment)
File src/vendorcode/amd/opensil/genoa_poc/memmap.c:
https://review.coreboot.org/c/coreboot/+/85634/comment/49757531_078617a5?us… :
PS19, Line 16:
> i'd add a check to make sure that the size of the type field is what we expect: […]
The first alternative works well!
--
To view, visit https://review.coreboot.org/c/coreboot/+/85634?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Gerrit-Change-Number: 85634
Gerrit-PatchSet: 20
Gerrit-Owner: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 03 Feb 2025 16:42:48 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
Attention is currently required from: Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Nick Kochlowski, Varshit Pandya.
Hello Felix Held, Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Varshit Pandya, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/85634?usp=email
to look at the new patch set (#20).
The following approvals got outdated and were removed:
Verified+1 by build bot (Jenkins)
Change subject: drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
......................................................................
drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
Refactor the vendercode openSIL memory map code and move all common
calls that do not require any openSIL headers to the driver. Improve
the legibility of the logic to return memory hole type string.
Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Signed-off-by: Nicolas Kochlowski <nickkochlowski(a)gmail.com>
---
M src/drivers/amd/opensil/Makefile.mk
A src/drivers/amd/opensil/memmap.c
M src/drivers/amd/opensil/opensil.h
M src/soc/amd/genoa_poc/domain.c
M src/soc/amd/phoenix/memmap.c
M src/vendorcode/amd/opensil/genoa_poc/memmap.c
M src/vendorcode/amd/opensil/opensil.h
M src/vendorcode/amd/opensil/stub/ramstage.c
8 files changed, 124 insertions(+), 90 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/34/85634/20
--
To view, visit https://review.coreboot.org/c/coreboot/+/85634?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Gerrit-Change-Number: 85634
Gerrit-PatchSet: 20
Gerrit-Owner: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Attention is currently required from: Martin L Roth.
Hello Martin L Roth,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/86254?usp=email
to look at the new patch set (#2).
Change subject: [wip]crossgcc: upgrade binutils version to 2.44
......................................................................
[wip]crossgcc: upgrade binutils version to 2.44
Change-Id: Ic78053f55c59de7af16fca0265d0d23fadfb20f6
Signed-off-by: Elyes Haouas <ehaouas(a)noos.fr>
---
M util/crossgcc/buildgcc
D util/crossgcc/patches/binutils-2.43.1_no-makeinfo.patch
R util/crossgcc/patches/binutils-2.44_as-ipxe.patch
A util/crossgcc/patches/binutils-2.44_no-makeinfo.patch
D util/crossgcc/sum/binutils-2.43.1.tar.xz.cksum
A util/crossgcc/sum/binutils-2.44.tar.xz.cksum
6 files changed, 219 insertions(+), 243 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/54/86254/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/86254?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ic78053f55c59de7af16fca0265d0d23fadfb20f6
Gerrit-Change-Number: 86254
Gerrit-PatchSet: 2
Gerrit-Owner: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Ana Carolina Cabral has posted comments on this change by Ana Carolina Cabral. ( https://review.coreboot.org/c/coreboot/+/86084?usp=email )
Change subject: mb/amd/birman_plus/ec: Rectify ECRAM register bits
......................................................................
Patch Set 15:
(1 comment)
File src/mainboard/amd/birman_plus/ec.c:
https://review.coreboot.org/c/coreboot/+/86084/comment/b605a8c8_a9630580?us… :
PS13, Line 36: _N
> no, this should be EC7_WL_RADIO_DIS
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/86084?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I1a13d99a55a4aa02a5cb0e67ffa4ed555f91a471
Gerrit-Change-Number: 86084
Gerrit-PatchSet: 15
Gerrit-Owner: Ana Carolina Cabral <ana.cpmelo95(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Comment-Date: Mon, 03 Feb 2025 14:03:32 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Ana Carolina Cabral <ana.cpmelo95(a)gmail.com>
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
Attention is currently required from: Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Nick Kochlowski, Varshit Pandya.
Felix Held has posted comments on this change by Nick Kochlowski. ( https://review.coreboot.org/c/coreboot/+/85634?usp=email )
Change subject: drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
......................................................................
Patch Set 19:
(1 comment)
File src/vendorcode/amd/opensil/genoa_poc/memmap.c:
https://review.coreboot.org/c/coreboot/+/85634/comment/be44d3dd_3e43ae93?us… :
PS16, Line 37: for (i = 0; i < ARRAY_SIZE(types); i++)
: if (enum_type == types[i].type)
: break;
: if (i == ARRAY_SIZE(types))
: return "Unknown type";
: return types[i].string;
> i'm fine with also doing that in the same patch
please mention that in the commit message though
--
To view, visit https://review.coreboot.org/c/coreboot/+/85634?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Gerrit-Change-Number: 85634
Gerrit-PatchSet: 19
Gerrit-Owner: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Comment-Date: Mon, 03 Feb 2025 13:55:41 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nick Kochlowski <nickkochlowski(a)gmail.com>
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
Attention is currently required from: Fred Reitberger, Jason Glenesk, Martin L Roth, Matt DeVillier, Nick Kochlowski, Varshit Pandya.
Felix Held has posted comments on this change by Nick Kochlowski. ( https://review.coreboot.org/c/coreboot/+/85634?usp=email )
Change subject: drivers/amd/opensil/memmap.c: Factor out common memmap code to driver
......................................................................
Patch Set 19:
(2 comments)
File src/vendorcode/amd/opensil/genoa_poc/memmap.c:
https://review.coreboot.org/c/coreboot/+/85634/comment/379f72ad_3f8657f5?us… :
PS16, Line 37: for (i = 0; i < ARRAY_SIZE(types); i++)
: if (enum_type == types[i].type)
: break;
: if (i == ARRAY_SIZE(types))
: return "Unknown type";
: return types[i].string;
> Agreed, it's much easier to read this way. I added this change to the new patchset. […]
i'm fine with also doing that in the same patch
File src/vendorcode/amd/opensil/genoa_poc/memmap.c:
https://review.coreboot.org/c/coreboot/+/85634/comment/311a8f8c_d00a1443?us… :
PS19, Line 16:
i'd add a check to make sure that the size of the type field is what we expect:
_Static_assert(sizeof(uint32_t) == sizeof(((MEMORY_HOLE_DESCRIPTOR){0}).Type), "Unexpected size of MEMORY_HOLE_TYPES in the MEMORY_HOLE_DESCRIPTOR struct which doesn't match the code in drivers/amd/opensil/memmap.c");
if that doesn't work the next best thing would be
_Static_assert(sizeof(uint32_t) == sizeof(MEMORY_HOLE_TYPES), "Unexpected size of MEMORY_HOLE_TYPES which doesn't match the code in drivers/amd/opensil/memmap.c");
This check needs to be in this file, since only this file has the definitions of MEMORY_HOLE_DESCRIPTOR and MEMORY_HOLE_TYPES
--
To view, visit https://review.coreboot.org/c/coreboot/+/85634?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I80b9bdd7fd633c7b12d695ced5d4b9b518570d80
Gerrit-Change-Number: 85634
Gerrit-PatchSet: 19
Gerrit-Owner: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Nick Kochlowski <nickkochlowski(a)gmail.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Comment-Date: Mon, 03 Feb 2025 13:55:24 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nick Kochlowski <nickkochlowski(a)gmail.com>
Comment-In-Reply-To: Felix Held <felix-coreboot(a)felixheld.de>
Attention is currently required from: Gavin Liu, Hung-Te Lin.
Yu-Ping Wu has posted comments on this change by Gavin Liu. ( https://review.coreboot.org/c/coreboot/+/86252?usp=email )
Change subject: soc/mediatek/mt8196: Add TF-A static library path
......................................................................
Patch Set 2:
(1 comment)
File src/soc/mediatek/mt8196/Makefile.mk:
https://review.coreboot.org/c/coreboot/+/86252/comment/8520f132_1632afcb?us… :
PS1, Line 96: libmtk.a
> We only need `lib` prefix. We can rename it to `libbl31.a` or `libtf-a. […]
I like libbl31, as it's more consistent with BL31_MAKEARGS. libmtk is a too general name.
Regarding the tf-a patch, the chromiumos ebuild can rename the file, if you don't want to modify the patch.
--
To view, visit https://review.coreboot.org/c/coreboot/+/86252?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I858686ede3730fb70f71565ca3593e7eb4c460d2
Gerrit-Change-Number: 86252
Gerrit-PatchSet: 2
Gerrit-Owner: Gavin Liu <gavin.liu(a)mediatek.corp-partner.google.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Gavin Liu <gavin.liu(a)mediatek.corp-partner.google.com>
Gerrit-Comment-Date: Mon, 03 Feb 2025 13:42:12 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Gavin Liu <gavin.liu(a)mediatek.corp-partner.google.com>
Comment-In-Reply-To: Yidi Lin <yidilin(a)google.com>
Comment-In-Reply-To: Yu-Ping Wu <yupingso(a)google.com>