Attention is currently required from: Subrata Banik, Tim Wawrzynczak, Angel Pons, Andrey Petrov, Patrick Rudolph.
Felix Singer has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/60638 )
Change subject: drivers/intel/fsp2_0/notify.c: Clean up some cosmetics
......................................................................
Patch Set 1: Code-Review+2
(1 comment)
File src/drivers/intel/fsp2_0/notify.c:
https://review.coreboot.org/c/coreboot/+/60638/comment/1b7c1706_21b70270
PS1, Line 76: {
: }
nit: I would move these into the line before.
--
To view, visit https://review.coreboot.org/c/coreboot/+/60638
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I2dafd677abbdd892745fea1bf4414f6e0d5549bb
Gerrit-Change-Number: 60638
Gerrit-PatchSet: 1
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Comment-Date: Sat, 01 Jan 2022 16:45:45 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Subrata Banik, Tim Wawrzynczak, Nick Vaccaro, Andrey Petrov, Patrick Rudolph, EricR Lai.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/60402 )
Change subject: drivers/intel/fsp2_0: Make FSP Notify Phase APIs optional
......................................................................
Patch Set 7:
(1 comment)
File src/drivers/intel/fsp2_0/notify.c:
https://review.coreboot.org/c/coreboot/+/60402/comment/b094effd_c95d1a68
PS6, Line 41: timestamp_add_now(TS_FSP_BEFORE_ENUMERATE);
: post_code(POST_FSP_NOTIFY_BEFORE_ENUMERATE);
> Yes, something like this, but using the right types, with the "after" timestamps and postcodes, and […]
CB:60639 implements my idea. Note that it is part of a patch train, preceded by CB:60637 and CB:60638
--
To view, visit https://review.coreboot.org/c/coreboot/+/60402
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ia95e9ec25ae797f2ac8e1c74145cf21e59867d64
Gerrit-Change-Number: 60402
Gerrit-PatchSet: 7
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: EricR Lai <ericr_lai(a)compal.corp-partner.google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Attention: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Attention: EricR Lai <ericr_lai(a)compal.corp-partner.google.com>
Gerrit-Comment-Date: Sat, 01 Jan 2022 16:27:02 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Subrata Banik <subratabanik(a)google.com>
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Angel Pons has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/60637 )
Change subject: drivers/intel/fsp2_0: Print return value when dying
......................................................................
drivers/intel/fsp2_0: Print return value when dying
When coreboot goes to die because FSP returned an error, log the return
value in the message printed by `die()` or `die_with_post_code()`.
Change-Id: I6b9ea60534a20429f15132007c1f5770760481af
Signed-off-by: Angel Pons <th3fanbus(a)gmail.com>
---
M src/drivers/intel/fsp2_0/memory_init.c
M src/drivers/intel/fsp2_0/notify.c
M src/drivers/intel/fsp2_0/temp_ram_exit.c
3 files changed, 5 insertions(+), 10 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/37/60637/1
diff --git a/src/drivers/intel/fsp2_0/memory_init.c b/src/drivers/intel/fsp2_0/memory_init.c
index c1a7377..3c1a088 100644
--- a/src/drivers/intel/fsp2_0/memory_init.c
+++ b/src/drivers/intel/fsp2_0/memory_init.c
@@ -309,9 +309,8 @@
/* Handle any errors returned by FspMemoryInit */
fsp_handle_reset(status);
if (status != FSP_SUCCESS) {
- printk(BIOS_CRIT, "FspMemoryInit returned 0x%08x\n", status);
die_with_post_code(POST_RAM_FAILURE,
- "FspMemoryInit returned an error!\n");
+ "FspMemoryInit returned with error 0x%08x!\n", status);
}
do_fsp_post_memory_init(s3wake, fsp_version);
diff --git a/src/drivers/intel/fsp2_0/notify.c b/src/drivers/intel/fsp2_0/notify.c
index 311ce46..9a0f23a 100644
--- a/src/drivers/intel/fsp2_0/notify.c
+++ b/src/drivers/intel/fsp2_0/notify.c
@@ -50,10 +50,8 @@
/* Handle any errors returned by FspNotify */
fsp_handle_reset(ret);
- if (ret != FSP_SUCCESS) {
- printk(BIOS_SPEW, "FspNotify returned 0x%08x\n", ret);
- die("FspNotify returned an error!\n");
- }
+ if (ret != FSP_SUCCESS)
+ die("FspNotify returned with error 0x%08x!\n", ret);
/* Allow the platform to run something after FspNotify */
platform_fsp_notify_status(phase);
diff --git a/src/drivers/intel/fsp2_0/temp_ram_exit.c b/src/drivers/intel/fsp2_0/temp_ram_exit.c
index 5d7cbd4..2192543 100644
--- a/src/drivers/intel/fsp2_0/temp_ram_exit.c
+++ b/src/drivers/intel/fsp2_0/temp_ram_exit.c
@@ -29,10 +29,8 @@
printk(BIOS_DEBUG, "Calling TempRamExit: %p\n", temp_ram_exit);
status = temp_ram_exit(NULL);
- if (status != FSP_SUCCESS) {
- printk(BIOS_CRIT, "TempRamExit returned 0x%08x\n", status);
- die("TempRamExit returned an error!\n");
- }
+ if (status != FSP_SUCCESS)
+ die("TempRamExit returned with error 0x%08x!\n", status);
cbfs_unmap(mapping);
}
--
To view, visit https://review.coreboot.org/c/coreboot/+/60637
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6b9ea60534a20429f15132007c1f5770760481af
Gerrit-Change-Number: 60637
Gerrit-PatchSet: 1
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: newchange
Attention is currently required from: Felix Singer, Patrick Rudolph.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/60600 )
Change subject: nb/intel/{sandybridge,haswell}: Rename PCIe driver
......................................................................
Patch Set 1:
(1 comment)
File src/northbridge/intel/sandybridge/pcie.c:
https://review.coreboot.org/c/coreboot/+/60600/comment/0a3e44f5_3981c625
PS1, Line 66: sa_pcie
> Just an idea: How about naming it "nb_pcie"? So it reflects the file path (src/northbridge/intel/... […]
I don't think it would help clarify the naming conundrum. Haswell code refers to these PCIe ports as PEG (PCI Express Graphics), and so does Sandy Bridge in ACPI (see `pcie_acpi_name()` function and ASL). Also, we don't have a `src/pch/intel/...` folder structure, yet the `pch_pcie` name is still there, even in i82801{i,j}x which are not PCHs! 😄
I'll leave it as-is for now, but I'll happily rename it if you want.
--
To view, visit https://review.coreboot.org/c/coreboot/+/60600
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I019088fcaa7866d8002e6884c25e1acd1d149093
Gerrit-Change-Number: 60600
Gerrit-PatchSet: 1
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Comment-Date: Sat, 01 Jan 2022 15:52:34 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Felix Singer <felixsinger(a)posteo.net>
Gerrit-MessageType: comment
Attention is currently required from: Felix Singer, Subrata Banik, Tim Wawrzynczak, Nick Vaccaro, Andrey Petrov, Patrick Rudolph, EricR Lai.
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/60402 )
Change subject: drivers/intel/fsp2_0: Make FSP Notify Phase APIs optional
......................................................................
Patch Set 7: Code-Review+1
(1 comment)
File src/drivers/intel/fsp2_0/notify.c:
https://review.coreboot.org/c/coreboot/+/60402/comment/053ad639_f83662c5
PS6, Line 41: timestamp_add_now(TS_FSP_BEFORE_ENUMERATE);
: post_code(POST_FSP_NOTIFY_BEFORE_ENUMERATE);
> this is good idea and then you can pass the structure variable to the below function call as below? […]
Yes, something like this, but using the right types, with the "after" timestamps and postcodes, and doing the array search only once. I'll make a patch to show what I am thinking of.
The idea is that this patch would simply add a `bool skip;` struct member, and initialize it for each phase with the corresponding Kconfig option. With this approach, I prefer storing `skip` over `allowed` to take advantage of uninitialised struct members defaulting to 0: if not specified, `skip` defaults to false.
--
To view, visit https://review.coreboot.org/c/coreboot/+/60402
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ia95e9ec25ae797f2ac8e1c74145cf21e59867d64
Gerrit-Change-Number: 60402
Gerrit-PatchSet: 7
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: EricR Lai <ericr_lai(a)compal.corp-partner.google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Nick Vaccaro <nvaccaro(a)google.com>
Gerrit-Attention: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Attention: EricR Lai <ericr_lai(a)compal.corp-partner.google.com>
Gerrit-Comment-Date: Sat, 01 Jan 2022 15:15:34 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Subrata Banik <subratabanik(a)google.com>
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Michał Żygowski, Patrick Rudolph, Jonathan Zhang, Johnny Lin, Christian Walter, Tim Wawrzynczak, Arthur Heymans, HAOUAS Elyes, Piotr Król, Tim Chu.
Felix Singer has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/60551 )
Change subject: src/mb: Remove unused <string.h>
......................................................................
Patch Set 3: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/60551
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I5f2710b2034882a24a041d99e37ec364193d85e6
Gerrit-Change-Number: 60551
Gerrit-PatchSet: 3
Gerrit-Owner: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Reviewer: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Piotr Król <piotr.krol(a)3mdeb.com>
Gerrit-Reviewer: Tim Chu <Tim.Chu(a)quantatw.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Attention: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Attention: Johnny Lin <Johnny_Lin(a)wiwynn.com>
Gerrit-Attention: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Attention: Piotr Król <piotr.krol(a)3mdeb.com>
Gerrit-Attention: Tim Chu <Tim.Chu(a)quantatw.com>
Gerrit-Comment-Date: Sat, 01 Jan 2022 15:13:54 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: HAOUAS Elyes.
Felix Singer has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/60550 )
Change subject: security/memory/memory.c: Include 'stdbool' instead of 'stdint'
......................................................................
Patch Set 2: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/60550
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I4eac157c8b48c1c10178bb84822b6462c245deca
Gerrit-Change-Number: 60550
Gerrit-PatchSet: 2
Gerrit-Owner: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: HAOUAS Elyes <ehaouas(a)noos.fr>
Gerrit-Comment-Date: Sat, 01 Jan 2022 15:12:32 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment