Patrick Georgi has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/47453 )
Change subject: util/futility: Don't refresh the binary all the time
......................................................................
util/futility: Don't refresh the binary all the time
Due to the phony dependency to check for openssl, vboot-futility
was always rebuilt, and because it was newer than coreboot-futility,
it was always copied over.
Do that in parallel often enough and you run into race conditions,
as we did on our builders. Mark check-openssl-presence as order-only
dependency so that it's executed (and can bail out) but doesn't force
regeneration of vboot-futility.
Change-Id: Ib7fb798096d423d6b6cba5d199e12fe5917c3b41
Signed-off-by: Patrick Georgi <pgeorgi(a)google.com>
---
M util/futility/Makefile.inc
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/53/47453/1
diff --git a/util/futility/Makefile.inc b/util/futility/Makefile.inc
index ed185ce..9890339 100644
--- a/util/futility/Makefile.inc
+++ b/util/futility/Makefile.inc
@@ -4,7 +4,7 @@
HOSTPKGCONFIG ?= pkg-config
-$(VBOOT_FUTILITY): check-openssl-presence
+$(VBOOT_FUTILITY): | check-openssl-presence
@printf " MAKE $(subst $(objutil)/,,$(@))\n"
unset CFLAGS LDFLAGS; $(MAKE) -C $(VBOOT_SOURCE) \
BUILD=$(VBOOT_HOST_BUILD) \
--
To view, visit https://review.coreboot.org/c/coreboot/+/47453
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ib7fb798096d423d6b6cba5d199e12fe5917c3b41
Gerrit-Change-Number: 47453
Gerrit-PatchSet: 1
Gerrit-Owner: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-MessageType: newchange
Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/25437 )
Change subject: FSP 2.0: Add fsp_relax_security
......................................................................
Patch Set 20:
(1 comment)
https://review.coreboot.org/c/coreboot/+/25437/18/src/drivers/intel/fsp2_0/…
File src/drivers/intel/fsp2_0/notify.c:
https://review.coreboot.org/c/coreboot/+/25437/18/src/drivers/intel/fsp2_0/…
PS18, Line 70: __attribute__((weak)) bool fsp_relax_security(void)
> Huh? Tbh I'm not sure how that would be used, anyway. […]
Ah, I missed the bmcInfo patch and I don't know bmcInfo, yet \o/ Soo... just that I get that right... is the plan to set that mode via BMC?
--
To view, visit https://review.coreboot.org/c/coreboot/+/25437
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I972e7387c2612ee0053df21afb55b0b264961174
Gerrit-Change-Number: 25437
Gerrit-PatchSet: 20
Gerrit-Owner: Julien Viard de Galbert <coreboot-review-ju(a)vdg.name>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: David Guckian <d.guckian20(a)gmail.com>
Gerrit-Reviewer: Julien Viard de Galbert <coreboot-review-ju(a)vdg.name>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Vanessa Eusebio <vanessa.f.eusebio(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Lijian Zhao <lijian.zhao(a)intel.com>
Gerrit-CC: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-Comment-Date: Wed, 11 Nov 2020 17:09:03 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Julien Viard de Galbert <coreboot-review-ju(a)vdg.name>
Comment-In-Reply-To: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-MessageType: comment
Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/25437 )
Change subject: FSP 2.0: Add fsp_relax_security
......................................................................
Patch Set 20:
(1 comment)
https://review.coreboot.org/c/coreboot/+/25437/18/src/drivers/intel/fsp2_0/…
File src/drivers/intel/fsp2_0/notify.c:
https://review.coreboot.org/c/coreboot/+/25437/18/src/drivers/intel/fsp2_0/…
PS18, Line 70: __attribute__((weak)) bool fsp_relax_security(void)
> Well the purpose was to set it at runtime, not compile time ;)
Huh? Tbh I'm not sure how that would be used, anyway. However, I wonder if we want to always add debug/testing functionality, even in production images. "Relax security" doesn't sound like something that should be always there.
When using CHIPSET_LOCKDOWN_COREBOOT, wouldn't that be the same (setting it at build time)?
--
To view, visit https://review.coreboot.org/c/coreboot/+/25437
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I972e7387c2612ee0053df21afb55b0b264961174
Gerrit-Change-Number: 25437
Gerrit-PatchSet: 20
Gerrit-Owner: Julien Viard de Galbert <coreboot-review-ju(a)vdg.name>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: David Guckian <d.guckian20(a)gmail.com>
Gerrit-Reviewer: Julien Viard de Galbert <coreboot-review-ju(a)vdg.name>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Vanessa Eusebio <vanessa.f.eusebio(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Lijian Zhao <lijian.zhao(a)intel.com>
Gerrit-CC: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-Comment-Date: Wed, 11 Nov 2020 17:06:08 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Julien Viard de Galbert <coreboot-review-ju(a)vdg.name>
Comment-In-Reply-To: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-MessageType: comment
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/45025 )
Change subject: libpayload/usb: Add format string checking to usb_debug
......................................................................
Patch Set 2: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/45025
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic94ebcbafdde8a5f79278b5635111b99af40f892
Gerrit-Change-Number: 45025
Gerrit-PatchSet: 2
Gerrit-Owner: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Wed, 11 Nov 2020 16:28:15 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/45024 )
Change subject: libpayload/usb: Fix printf format string mismatches in debug messages
......................................................................
Patch Set 2:
(1 comment)
https://review.coreboot.org/c/coreboot/+/45024/2/payloads/libpayload/driver…
File payloads/libpayload/drivers/usb/usb.c:
PS2:
Does `#include <inttypes.h>` help? Maybe ARM isn't implicitly including it, but you should be adding the include anyway.
--
To view, visit https://review.coreboot.org/c/coreboot/+/45024
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I4dc70baefb3cd82fcc915cc2e7f68719cf6870cc
Gerrit-Change-Number: 45024
Gerrit-PatchSet: 2
Gerrit-Owner: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Wed, 11 Nov 2020 16:23:21 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/39104 )
Change subject: mb/asrock/h110m: add libgfxinit support
......................................................................
Patch Set 15:
(1 comment)
https://review.coreboot.org/c/coreboot/+/39104/10//COMMIT_MSG
Commit Message:
https://review.coreboot.org/c/coreboot/+/39104/10//COMMIT_MSG@7
PS10, Line 7: mb/asrock/h110m: add libgfxinit support
> Unfortunately VGA works on Windows only.
Uh, libgfxinit doesn't care about the OS (in fact, it never interacts with the OS). Does VGA light up with libgfxinit *before* an OS takes over?
Also, does VGA work on linux with vendor firmware?
--
To view, visit https://review.coreboot.org/c/coreboot/+/39104
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I4d87413f87d00986111ecb7b046423ff5eac1bf1
Gerrit-Change-Number: 39104
Gerrit-PatchSet: 15
Gerrit-Owner: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Nico Huber <nico.h(a)gmx.de>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Wed, 11 Nov 2020 16:21:23 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Comment-In-Reply-To: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-MessageType: comment
Julien Viard de Galbert has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/25437 )
Change subject: FSP 2.0: Add fsp_relax_security
......................................................................
Patch Set 20:
(2 comments)
Thanks for the hint, I'll use CHIPSET_LOCKDOWN_{FSP,COREBOOT} on the next update of this patch.
https://review.coreboot.org/c/coreboot/+/25437/18/src/drivers/intel/fsp2_0/…
File src/drivers/intel/fsp2_0/notify.c:
https://review.coreboot.org/c/coreboot/+/25437/18/src/drivers/intel/fsp2_0/…
PS18, Line 70: __attribute__((weak)) bool fsp_relax_security(void)
> instead of *another* callback, why not have a Kconfig?
Well the purpose was to set it at runtime, not compile time ;)
https://review.coreboot.org/c/coreboot/+/25437/18/src/drivers/intel/fsp2_0/…
PS18, Line 70: fsp_relax_security
> Maybe rename this to sound less like an action? E. g. […]
Right I missed the introduction of CHIPSET_LOCKDOWN_COREBOOT, I can certainly rewrite it using that.
Will do.
--
To view, visit https://review.coreboot.org/c/coreboot/+/25437
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I972e7387c2612ee0053df21afb55b0b264961174
Gerrit-Change-Number: 25437
Gerrit-PatchSet: 20
Gerrit-Owner: Julien Viard de Galbert <coreboot-review-ju(a)vdg.name>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: David Guckian <d.guckian20(a)gmail.com>
Gerrit-Reviewer: Julien Viard de Galbert <coreboot-review-ju(a)vdg.name>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Vanessa Eusebio <vanessa.f.eusebio(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Lijian Zhao <lijian.zhao(a)intel.com>
Gerrit-CC: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-Comment-Date: Wed, 11 Nov 2020 15:19:16 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Angel Pons <th3fanbus(a)gmail.com>
Comment-In-Reply-To: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-MessageType: comment