Furquan Shaikh has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/46037 )
Change subject: drivers/wifi/generic: Drop the dependency on HAVE_ACPI_TABLES
......................................................................
drivers/wifi/generic: Drop the dependency on HAVE_ACPI_TABLES
This change drops the dependency of DRIVERS_WIFI_GENERIC on
HAVE_ACPI_TABLES as the driver provides operations other than the ACPI
support for WiFi devices. Since the dependency is now dropped, ACPI
operations in generic.c are guarded by CONFIG(HAVE_ACPI_TABLES).
BUG=b:169802515
BRANCH=zork
Change-Id: I16444a9d842a6742e3c97ef04c4f18e93e6cdaa9
Signed-off-by: Furquan Shaikh <furquan(a)google.com>
---
M src/drivers/wifi/generic/Kconfig
M src/drivers/wifi/generic/generic.c
2 files changed, 4 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/37/46037/1
diff --git a/src/drivers/wifi/generic/Kconfig b/src/drivers/wifi/generic/Kconfig
index 049a952..ddd2be9 100644
--- a/src/drivers/wifi/generic/Kconfig
+++ b/src/drivers/wifi/generic/Kconfig
@@ -1,7 +1,6 @@
config DRIVERS_WIFI_GENERIC
bool
default n
- depends on HAVE_ACPI_TABLES
help
When enabled, add identifiers in ACPI tables that are common
to WiFi chipsets from multiple vendors.
diff --git a/src/drivers/wifi/generic/generic.c b/src/drivers/wifi/generic/generic.c
index b515f3c..97f5bda 100644
--- a/src/drivers/wifi/generic/generic.c
+++ b/src/drivers/wifi/generic/generic.c
@@ -37,6 +37,7 @@
*/
#define WIFI_ACPI_NAME_MAX_LEN 5
+#if CONFIG(HAVE_ACPI_TABLES)
__weak
int get_wifi_sar_limits(struct wifi_sar_limits *sar_limits)
{
@@ -239,6 +240,7 @@
{
wifi_generic_fill_ssdt(dev, dev->chip_info);
}
+#endif
static void wifi_pci_dev_init(struct device *dev)
{
@@ -287,8 +289,10 @@
.enable_resources = pci_dev_enable_resources,
.init = wifi_pci_dev_init,
.ops_pci = &pci_dev_ops_pci,
+#if CONFIG(HAVE_ACPI_TABLES)
.acpi_name = wifi_generic_acpi_name,
.acpi_fill_ssdt = wifi_generic_fill_ssdt_generator,
+#endif
#if CONFIG(GENERATE_SMBIOS_TABLES)
.get_smbios_data = smbios_write_wifi,
#endif
--
To view, visit https://review.coreboot.org/c/coreboot/+/46037
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I16444a9d842a6742e3c97ef04c4f18e93e6cdaa9
Gerrit-Change-Number: 46037
Gerrit-PatchSet: 1
Gerrit-Owner: Furquan Shaikh <furquan(a)google.com>
Gerrit-MessageType: newchange
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/45001 )
Change subject: soc/intel/skylake: Rename PcieRpAspm devicetree config
......................................................................
Patch Set 3: Code-Review+1
(1 comment)
https://review.coreboot.org/c/coreboot/+/45001/3/src/soc/intel/skylake/chip…
File src/soc/intel/skylake/chip.h:
https://review.coreboot.org/c/coreboot/+/45001/3/src/soc/intel/skylake/chip…
PS3, Line 265: } pcierp_aspm[CONFIG_MAX_ROOT_PORTS];
> The idea is to differ so it doesn't look like the plain UPD. Also, CamelCase […]
This should be named `pcie_rp_aspm`
--
To view, visit https://review.coreboot.org/c/coreboot/+/45001
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id74f043ecd549bde4501320bff1dc080bde64057
Gerrit-Change-Number: 45001
Gerrit-PatchSet: 3
Gerrit-Owner: Benjamin Doron <benjamin.doron00(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Frans Hendriks <fhendriks(a)eltan.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Wim Vervoorn <wvervoorn(a)eltan.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Tue, 13 Oct 2020 17:31:53 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Comment-In-Reply-To: Frans Hendriks <fhendriks(a)eltan.com>
Gerrit-MessageType: comment
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/45001 )
Change subject: soc/intel/skylake: Rename PcieRpAspm devicetree config
......................................................................
Patch Set 3:
(1 comment)
Btw. there is some work going on to have a "chipset devicetree"
that can declare devices and provide defaults. In theory, we
could then have non-zero defaults and wouldn't need these off-
by-one tricks anymore.
https://review.coreboot.org/c/coreboot/+/45001/3/src/soc/intel/skylake/chip…
File src/soc/intel/skylake/chip.h:
https://review.coreboot.org/c/coreboot/+/45001/3/src/soc/intel/skylake/chip…
PS3, Line 265: } pcierp_aspm[CONFIG_MAX_ROOT_PORTS];
> Would PcieRp_Aspem better match other element names?
The idea is to differ so it doesn't look like the plain UPD. Also, CamelCase
is usually not considered an option in coreboot.
--
To view, visit https://review.coreboot.org/c/coreboot/+/45001
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id74f043ecd549bde4501320bff1dc080bde64057
Gerrit-Change-Number: 45001
Gerrit-PatchSet: 3
Gerrit-Owner: Benjamin Doron <benjamin.doron00(a)gmail.com>
Gerrit-Reviewer: Frans Hendriks <fhendriks(a)eltan.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Wim Vervoorn <wvervoorn(a)eltan.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Tue, 13 Oct 2020 17:25:57 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Frans Hendriks <fhendriks(a)eltan.com>
Gerrit-MessageType: comment
Paul Menzel has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/45970 )
Change subject: superio/nuvoton/common: Collapse two if statements
......................................................................
superio/nuvoton/common: Collapse two if statements
There are more devices requiring this code, so avoid duplicating the if
block over and over.
Change-Id: Ib4f787e3c883b1fec941de77bc8e19ccf0d5224c
Signed-off-by: Paul Menzel <pmenzel(a)molgen.mpg.de>
---
M src/superio/nuvoton/common/early_serial.c
1 file changed, 2 insertions(+), 5 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/70/45970/1
diff --git a/src/superio/nuvoton/common/early_serial.c b/src/superio/nuvoton/common/early_serial.c
index 22d882e..cc21f40 100644
--- a/src/superio/nuvoton/common/early_serial.c
+++ b/src/superio/nuvoton/common/early_serial.c
@@ -52,11 +52,8 @@
nuvoton_pnp_enter_conf_state(dev);
- if (CONFIG(SUPERIO_NUVOTON_NCT5539D_COM_A))
- /* Route COM A to GPIO8 pin group */
- pnp_write_config(dev, 0x2a, 0x40);
-
- if (CONFIG(SUPERIO_NUVOTON_NCT6776_COM_A))
+ if (CONFIG(SUPERIO_NUVOTON_NCT5539D_COM_A) ||
+ CONFIG(SUPERIO_NUVOTON_NCT6776_COM_A))
/* Route COM A to GPIO8 pin group */
pnp_write_config(dev, 0x2a, 0x40);
--
To view, visit https://review.coreboot.org/c/coreboot/+/45970
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ib4f787e3c883b1fec941de77bc8e19ccf0d5224c
Gerrit-Change-Number: 45970
Gerrit-PatchSet: 1
Gerrit-Owner: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: newchange
Angel Pons has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/16519 )
Change subject: superio/nuvoton: Add back Nuvoton NCT6776 support
......................................................................
Patch Set 9:
(1 comment)
https://review.coreboot.org/c/coreboot/+/16519/9/src/superio/nuvoton/nct677…
File src/superio/nuvoton/nct6776/Kconfig:
https://review.coreboot.org/c/coreboot/+/16519/9/src/superio/nuvoton/nct677…
PS9, Line 23: default n
> It looks like this wasn’t just a revert after all. […]
Commit message says `with minor adaptations`
--
To view, visit https://review.coreboot.org/c/coreboot/+/16519
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I546879285ad8336e81798d0fbdf94f72e1fa61a2
Gerrit-Change-Number: 16519
Gerrit-PatchSet: 9
Gerrit-Owner: Teo Boon Tiong <boon.tiong.teo(a)intel.com>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Huang Jin <huang.jin(a)intel.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Teo Boon Tiong <boon.tiong.teo(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Tue, 13 Oct 2020 17:01:42 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: comment