Hello Andrey Petrov, Jingle Hsu, Morgan Jang, Patrick Rudolph, Jonathan Zhang, David Hendricks, build bot (Jenkins), Patrick Georgi, Martin Roth,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/37444
to look at the new patch set (#6).
Change subject: drivers/ipmi: Add IPMI Read FRU function
......................................................................
drivers/ipmi: Add IPMI Read FRU function
Implemented according to IPMI "Platform Management
FRU Information Storage Definition" specification
v1.0 for reading FRU data Product Info Area and
Board Info Area.
SMBIOS data can be updated with the FRU data.
Tested on OCP Mono Lake.
Change-Id: Id6353f5ce3f7ddd3bb161b91364b3cf276d020b8
Signed-off-by: Johnny Lin <johnny_lin(a)wiwynn.com>
---
M src/drivers/ipmi/Kconfig
M src/drivers/ipmi/Makefile.inc
A src/drivers/ipmi/ipmi_fru.c
M src/drivers/ipmi/ipmi_kcs.h
M src/drivers/ipmi/ipmi_ops.h
5 files changed, 491 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/44/37444/6
--
To view, visit https://review.coreboot.org/c/coreboot/+/37444
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: 4.11_branch
Gerrit-Change-Id: Id6353f5ce3f7ddd3bb161b91364b3cf276d020b8
Gerrit-Change-Number: 37444
Gerrit-PatchSet: 6
Gerrit-Owner: Johnny Lin
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Jingle Hsu
Gerrit-Reviewer: Johnny Lin
Gerrit-Reviewer: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Morgan Jang
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Hello Andrey Petrov, Jingle Hsu, Morgan Jang, Patrick Rudolph, Jonathan Zhang, David Hendricks,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/37445
to look at the new patch set (#6).
Change subject: mb/ocp/monolake: Override SMBIOS data with IPMI read FRU data
......................................................................
mb/ocp/monolake: Override SMBIOS data with IPMI read FRU data
SMBIOS type 1 data fields are overwritten by FRU product info
area data, SMBIOS type 2 fields are overwritten by FRU
board info area data.
Tested on OCP Mono Lake.
Change-Id: I58cbe95055dea053b115e99f354f40d5902c6a35
Signed-off-by: Johnny Lin <johnny_lin(a)wiwynn.com>
---
M src/mainboard/ocp/monolake/Kconfig
M src/mainboard/ocp/monolake/mainboard.c
2 files changed, 82 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/45/37445/6
--
To view, visit https://review.coreboot.org/c/coreboot/+/37445
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: 4.11_branch
Gerrit-Change-Id: I58cbe95055dea053b115e99f354f40d5902c6a35
Gerrit-Change-Number: 37445
Gerrit-PatchSet: 6
Gerrit-Owner: Johnny Lin
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Jingle Hsu
Gerrit-Reviewer: Johnny Lin
Gerrit-Reviewer: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Morgan Jang
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-MessageType: newpatchset
build bot (Jenkins) has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/37444 )
Change subject: drivers/ipmi: Add IPMI Read FRU function
......................................................................
Patch Set 5:
(1 comment)
https://review.coreboot.org/c/coreboot/+/37444/5/src/drivers/ipmi/ipmi_fru.c
File src/drivers/ipmi/ipmi_fru.c:
https://review.coreboot.org/c/coreboot/+/37444/5/src/drivers/ipmi/ipmi_fru.…
PS5, Line 63: } else
else is not generally useful after a break or return
--
To view, visit https://review.coreboot.org/c/coreboot/+/37444
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: 4.11_branch
Gerrit-Change-Id: Id6353f5ce3f7ddd3bb161b91364b3cf276d020b8
Gerrit-Change-Number: 37444
Gerrit-PatchSet: 5
Gerrit-Owner: Johnny Lin
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Jingle Hsu
Gerrit-Reviewer: Johnny Lin
Gerrit-Reviewer: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Morgan Jang
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Thu, 05 Dec 2019 01:39:38 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Hello Andrey Petrov, Jingle Hsu, Morgan Jang, Patrick Rudolph, Jonathan Zhang, David Hendricks, Patrick Georgi, Martin Roth,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/37444
to look at the new patch set (#5).
Change subject: drivers/ipmi: Add IPMI Read FRU function
......................................................................
drivers/ipmi: Add IPMI Read FRU function
Implemented according to IPMI "Platform Management
FRU Information Storage Definition" specification
v1.0 for reading FRU data Product Info Area and
Board Info Area.
SMBIOS data can be updated with the FRU data.
Tested on OCP Mono Lake.
Change-Id: Id6353f5ce3f7ddd3bb161b91364b3cf276d020b8
Signed-off-by: Johnny Lin <johnny_lin(a)wiwynn.com>
---
M src/drivers/ipmi/Kconfig
M src/drivers/ipmi/Makefile.inc
A src/drivers/ipmi/ipmi_fru.c
M src/drivers/ipmi/ipmi_kcs.h
M src/drivers/ipmi/ipmi_ops.h
5 files changed, 491 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/44/37444/5
--
To view, visit https://review.coreboot.org/c/coreboot/+/37444
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: 4.11_branch
Gerrit-Change-Id: Id6353f5ce3f7ddd3bb161b91364b3cf276d020b8
Gerrit-Change-Number: 37444
Gerrit-PatchSet: 5
Gerrit-Owner: Johnny Lin
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Jingle Hsu
Gerrit-Reviewer: Johnny Lin
Gerrit-Reviewer: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Morgan Jang
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-MessageType: newpatchset
Marshall Dawson has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/33759 )
Change subject: soc/amd/picasso: Support reset vector in romstage
......................................................................
Patch Set 17:
(5 comments)
https://review.coreboot.org/c/coreboot/+/33759/13//COMMIT_MSG
Commit Message:
https://review.coreboot.org/c/coreboot/+/33759/13//COMMIT_MSG@22
PS13, Line 22: Remove all postcar support.
> > At first appearance >50% of code line changes is about MTRRs and not about the entry to romstage l […]
Ack
https://review.coreboot.org/c/coreboot/+/33759/16/src/soc/amd/picasso/inclu…
File src/soc/amd/picasso/include/soc/romstage.h:
https://review.coreboot.org/c/coreboot/+/33759/16/src/soc/amd/picasso/inclu…
PS16, Line 21: #include <arch/cpu.h>
> Is this needed here for the function definitions?
Done. Looks like PS12 used asmlinkage but it's no longer necessary.
https://review.coreboot.org/c/coreboot/+/33759/16/src/soc/amd/picasso/romst…
File src/soc/amd/picasso/romstage.c:
https://review.coreboot.org/c/coreboot/+/33759/16/src/soc/amd/picasso/romst…
PS16, Line 53:
: static void romstage_soc_init(int s3_resume)
: {
: fch_early_init();
: }
> Call it directly? Is the intention to make the first_stage_entry() an architectural default with cal […]
Redone
https://review.coreboot.org/c/coreboot/+/33759/16/src/soc/amd/picasso/romst…
PS16, Line 100: BIT(23)
> 8 * MiB would be more readable
Done. It was primarily to reflect that only 47:23 are valid, and not a relevant size. 22:0 are supposed to be RAZ, but the align_down is simply to be safe about it.
https://review.coreboot.org/c/coreboot/+/33759/16/src/soc/amd/picasso/romst…
PS16, Line 101: backup_top_of_low_cacheable(top_of_mem);
> Is using this API really necessary if it's fetched from just one MSR? Note CB:36144 where you only n […]
This is only a temporary solution to demonstrate a somewhat simple romstage implementation. The real one relies on AGESA's reporting (due to UMA memory may fall below TOM), and is implemented in CB:34423.
--
To view, visit https://review.coreboot.org/c/coreboot/+/33759
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id8c6175de34a0728ad41085e9c7cd310bd280976
Gerrit-Change-Number: 33759
Gerrit-PatchSet: 17
Gerrit-Owner: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Richard Spiegel <richard.spiegel(a)silverbackltd.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-CC: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Thu, 05 Dec 2019 00:39:14 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Comment-In-Reply-To: Arthur Heymans <arthur(a)aheymans.xyz>
Comment-In-Reply-To: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-MessageType: comment
Hello Edward O'Callaghan, Julius Werner, Arthur Heymans, Richard Spiegel, build bot (Jenkins), Martin Roth, Furquan Shaikh, Patrick Georgi,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/33759
to look at the new patch set (#17).
Change subject: soc/amd/picasso: Support reset vector in romstage
......................................................................
soc/amd/picasso: Support reset vector in romstage
Given that:
* Picasso comes out of reset with DRAM already functioning
* The traditional requirements of bootblock and romstage are now
somewhat minimized
* The Google vboot solution will run on the PSP and not in a
separate verstage after bootblock
Add support for a hybrid romstage combining a handful of features
typically in bootblock with the memory discovery in romstage.
Change-Id: Id8c6175de34a0728ad41085e9c7cd310bd280976
Signed-off-by: Marshall Dawson <marshalldawson3rd(a)gmail.com>
---
M src/soc/amd/picasso/Kconfig
M src/soc/amd/picasso/Makefile.inc
M src/soc/amd/picasso/include/soc/romstage.h
M src/soc/amd/picasso/romstage.c
4 files changed, 48 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/59/33759/17
--
To view, visit https://review.coreboot.org/c/coreboot/+/33759
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id8c6175de34a0728ad41085e9c7cd310bd280976
Gerrit-Change-Number: 33759
Gerrit-PatchSet: 17
Gerrit-Owner: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Edward O'Callaghan <quasisec(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Richard Spiegel <richard.spiegel(a)silverbackltd.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-CC: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: newpatchset
Wonkyu Kim has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/36091 )
Change subject: mb/intel/tglrvp: Do initial mainboard commit
......................................................................
Patch Set 10:
(1 comment)
https://review.coreboot.org/c/coreboot/+/36091/10/src/mainboard/intel/tglrv…
File src/mainboard/intel/tglrvp/Kconfig.name:
https://review.coreboot.org/c/coreboot/+/36091/10/src/mainboard/intel/tglrv…
PS10, Line 3: BOARD_INTEL_TGLRVP
Can we have more specific board name for supporting other board?
It's better have UP3 in config name
--
To view, visit https://review.coreboot.org/c/coreboot/+/36091
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I79a05881d2ea50ff4113243bf5ae26207db63322
Gerrit-Change-Number: 36091
Gerrit-PatchSet: 10
Gerrit-Owner: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: John Zhao <john.zhao(a)intel.com>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: Raj Astekar <raj.astekar(a)intel.com>
Gerrit-Reviewer: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.com>
Gerrit-Reviewer: Shaunak Saha <shaunak.saha(a)intel.com>
Gerrit-Reviewer: Srinidhi N Kaushik <srinidhi.n.kaushik(a)intel.com>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Wonkyu Kim <wonkyu.kim(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-CC: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Wed, 04 Dec 2019 23:38:19 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Julius Werner has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/37475 )
Change subject: facebook/fbg1701: Increase bootblock size
......................................................................
facebook/fbg1701: Increase bootblock size
New vboot updates make the bootblock no longer fit on this board.
Increasing the size should fix the issue.
Change-Id: Ic18d682a8370ebf7e27e1e6bcfcf019643fc31f3
Signed-off-by: Julius Werner <jwerner(a)chromium.org>
---
M configs/config.facebook_fbg1701
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/75/37475/1
diff --git a/configs/config.facebook_fbg1701 b/configs/config.facebook_fbg1701
index b372bbe..e0a7271 100644
--- a/configs/config.facebook_fbg1701
+++ b/configs/config.facebook_fbg1701
@@ -1,5 +1,5 @@
CONFIG_VENDOR_FACEBOOK=y
-CONFIG_C_ENV_BOOTBLOCK_SIZE=0x6000
+CONFIG_C_ENV_BOOTBLOCK_SIZE=0x7000
CONFIG_ONBOARD_SAMSUNG_MEM=y
CONFIG_CPU_MICROCODE_CBFS_LOC=0xFFF8B000
CONFIG_CPU_MICROCODE_CBFS_EXTERNAL_BINS=y
--
To view, visit https://review.coreboot.org/c/coreboot/+/37475
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic18d682a8370ebf7e27e1e6bcfcf019643fc31f3
Gerrit-Change-Number: 37475
Gerrit-PatchSet: 1
Gerrit-Owner: Julius Werner <jwerner(a)chromium.org>
Gerrit-MessageType: newchange