Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/79794?usp=email )
Change subject: mb/google/byra/var/*: Set WLAN device type back to pci
......................................................................
mb/google/byra/var/*: Set WLAN device type back to pci
This partially reverts commit f493857c9bc1 ("mb/google/brya/var/*: Set
dGPU/LAN/WLAN device type to generic"). Setting the WLAN device type to
generic broke ACPI SSDT table definition, so set it back to pci.
BUG=b:318576073
TEST=build/boot google/nissa (pujjo), verify WLAN ACPI SSDT tables
contain the appropriate device entry.
Change-Id: If5dad9deb040c8cb0c507e11726f0ba44ccb2909
Signed-off-by: David Ruth <druth(a)chromium.org>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/79794
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Matt DeVillier <matt.devillier(a)gmail.com>
---
M src/mainboard/google/brya/variants/gothrax/overridetree.cb
M src/mainboard/google/brya/variants/joxer/overridetree.cb
M src/mainboard/google/brya/variants/kinox/overridetree.cb
M src/mainboard/google/brya/variants/marasov/overridetree.cb
M src/mainboard/google/brya/variants/nereid/overridetree.cb
M src/mainboard/google/brya/variants/pujjo/overridetree.cb
M src/mainboard/google/brya/variants/quandiso/overridetree.cb
M src/mainboard/google/brya/variants/xivu/overridetree.cb
M src/mainboard/google/brya/variants/yaviks/overridetree.cb
M src/mainboard/google/brya/variants/yavilla/overridetree.cb
10 files changed, 10 insertions(+), 10 deletions(-)
Approvals:
Matt DeVillier: Looks good to me, approved
build bot (Jenkins): Verified
diff --git a/src/mainboard/google/brya/variants/gothrax/overridetree.cb b/src/mainboard/google/brya/variants/gothrax/overridetree.cb
index 14d9215..bb333aa 100644
--- a/src/mainboard/google/brya/variants/gothrax/overridetree.cb
+++ b/src/mainboard/google/brya/variants/gothrax/overridetree.cb
@@ -337,7 +337,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
device ref pcie_rp7 on
diff --git a/src/mainboard/google/brya/variants/joxer/overridetree.cb b/src/mainboard/google/brya/variants/joxer/overridetree.cb
index e06b778..7b43f86 100644
--- a/src/mainboard/google/brya/variants/joxer/overridetree.cb
+++ b/src/mainboard/google/brya/variants/joxer/overridetree.cb
@@ -330,7 +330,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
device ref pcie_rp7 off end # PCIE7 no SD card
diff --git a/src/mainboard/google/brya/variants/kinox/overridetree.cb b/src/mainboard/google/brya/variants/kinox/overridetree.cb
index 567f878..fcca3d8 100644
--- a/src/mainboard/google/brya/variants/kinox/overridetree.cb
+++ b/src/mainboard/google/brya/variants/kinox/overridetree.cb
@@ -247,7 +247,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
chip soc/intel/common/block/pcie/rtd3
register "enable_gpio" = "ACPI_GPIO_OUTPUT_ACTIVE_HIGH(GPP_B11)"
diff --git a/src/mainboard/google/brya/variants/marasov/overridetree.cb b/src/mainboard/google/brya/variants/marasov/overridetree.cb
index 6c1f3f9..3ea7092 100644
--- a/src/mainboard/google/brya/variants/marasov/overridetree.cb
+++ b/src/mainboard/google/brya/variants/marasov/overridetree.cb
@@ -328,7 +328,7 @@
}"
chip drivers/wifi/generic
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
device ref pcie_rp8 off end
diff --git a/src/mainboard/google/brya/variants/nereid/overridetree.cb b/src/mainboard/google/brya/variants/nereid/overridetree.cb
index 5de5c1b..9d9b871 100644
--- a/src/mainboard/google/brya/variants/nereid/overridetree.cb
+++ b/src/mainboard/google/brya/variants/nereid/overridetree.cb
@@ -209,7 +209,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
device ref pch_espi on
diff --git a/src/mainboard/google/brya/variants/pujjo/overridetree.cb b/src/mainboard/google/brya/variants/pujjo/overridetree.cb
index 59ab871..51383e0 100644
--- a/src/mainboard/google/brya/variants/pujjo/overridetree.cb
+++ b/src/mainboard/google/brya/variants/pujjo/overridetree.cb
@@ -673,7 +673,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
device ref pcie_rp7 on
diff --git a/src/mainboard/google/brya/variants/quandiso/overridetree.cb b/src/mainboard/google/brya/variants/quandiso/overridetree.cb
index de48f2d..c28cc0b 100644
--- a/src/mainboard/google/brya/variants/quandiso/overridetree.cb
+++ b/src/mainboard/google/brya/variants/quandiso/overridetree.cb
@@ -373,7 +373,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
device ref pcie_rp7 on
diff --git a/src/mainboard/google/brya/variants/xivu/overridetree.cb b/src/mainboard/google/brya/variants/xivu/overridetree.cb
index 2e781a2..be4d8df 100644
--- a/src/mainboard/google/brya/variants/xivu/overridetree.cb
+++ b/src/mainboard/google/brya/variants/xivu/overridetree.cb
@@ -376,7 +376,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
diff --git a/src/mainboard/google/brya/variants/yaviks/overridetree.cb b/src/mainboard/google/brya/variants/yaviks/overridetree.cb
index 580181c..308ed10 100644
--- a/src/mainboard/google/brya/variants/yaviks/overridetree.cb
+++ b/src/mainboard/google/brya/variants/yaviks/overridetree.cb
@@ -450,7 +450,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
device ref pcie_rp7 on
diff --git a/src/mainboard/google/brya/variants/yavilla/overridetree.cb b/src/mainboard/google/brya/variants/yavilla/overridetree.cb
index 4a96742..ee5a3b6 100644
--- a/src/mainboard/google/brya/variants/yavilla/overridetree.cb
+++ b/src/mainboard/google/brya/variants/yavilla/overridetree.cb
@@ -496,7 +496,7 @@
chip drivers/wifi/generic
register "wake" = "GPE0_DW1_03"
register "add_acpi_dma_property" = "true"
- device generic 0 on end
+ device pci 00.0 on end
end
end
device ref pcie_rp7 off end #PCIE7 no SD card
--
To view, visit https://review.coreboot.org/c/coreboot/+/79794?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If5dad9deb040c8cb0c507e11726f0ba44ccb2909
Gerrit-Change-Number: 79794
Gerrit-PatchSet: 2
Gerrit-Owner: David Ruth <druth(a)chromium.org>
Gerrit-Reviewer: Eric Lai <ericllai(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: merged
Sean Rhodes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79876?usp=email )
Change subject: soc/intel/common/tcss: Guard disconnect_tcss_display with CHROMEOS
......................................................................
Set Ready For Review
--
To view, visit https://review.coreboot.org/c/coreboot/+/79876?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I4685344224f321211944505b666d0d643affef2e
Gerrit-Change-Number: 79876
Gerrit-PatchSet: 1
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Comment-Date: Wed, 10 Jan 2024 16:12:23 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Sean Rhodes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79875?usp=email )
Change subject: soc/intel/common/tcss: Fix Kconfig dependency
......................................................................
Set Ready For Review
--
To view, visit https://review.coreboot.org/c/coreboot/+/79875?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I46cab8b385b2aefe1fc106bf5a2dcfe8f15dbe10
Gerrit-Change-Number: 79875
Gerrit-PatchSet: 1
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Comment-Date: Wed, 10 Jan 2024 16:12:14 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Matt DeVillier.
Sean Rhodes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79874?usp=email )
Change subject: soc/intel/common/tcss: Rename tcss_mux_init
......................................................................
Patch Set 1:
This change is ready for review.
--
To view, visit https://review.coreboot.org/c/coreboot/+/79874?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I5e43f0cca9d49bc30fc189663490a306efd71584
Gerrit-Change-Number: 79874
Gerrit-PatchSet: 1
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Comment-Date: Wed, 10 Jan 2024 15:52:18 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Patrick Georgi.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79523?usp=email )
Change subject: libpayload: Remove shell for loops in install Makefile target
......................................................................
Patch Set 4:
(1 comment)
Patchset:
PS4:
> After this commit FILO fails to build: […]
Hmmm, using `{}` as part of an argument (not just `{}` alone) isn't portable. Maybe
that's the issue? Could you check if it creates a directory called `{}`? i.e.
`/dev/shm/coreboot/payloads/external/FILO/filo/build/libpayload/{}`.
--
To view, visit https://review.coreboot.org/c/coreboot/+/79523?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I9f9dddfe3f3ceceb6a0510d6dd862351e4b10210
Gerrit-Change-Number: 79523
Gerrit-PatchSet: 4
Gerrit-Owner: Patrick Georgi <patrick(a)coreboot.org>
Gerrit-Reviewer: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Gerrit-Reviewer: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Patrick Georgi <patrick(a)coreboot.org>
Gerrit-Comment-Date: Wed, 10 Jan 2024 15:32:11 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: comment
Attention is currently required from: Patrick Rudolph.
Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79146?usp=email )
Change subject: sb/intel/bd82x6x/sata: Enable SATA clock gating
......................................................................
Patch Set 3: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/79146?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I50970117ddcf8d39796426a19c1a6b57e5b1e690
Gerrit-Change-Number: 79146
Gerrit-PatchSet: 3
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Comment-Date: Wed, 10 Jan 2024 15:17:54 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Keith Hui, Patrick Rudolph, Paul Menzel.
Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/78829?usp=email )
Change subject: sb/intel/bd82x6x/early_usb: Add USB TX/RX gains
......................................................................
Patch Set 10: Code-Review+2
(1 comment)
File src/southbridge/intel/bd82x6x/early_usb.c:
https://review.coreboot.org/c/coreboot/+/78829/comment/456ad2e1_b57f0b8e :
PS10, Line 41: portmap[i].current
It would be nice to have a more meaningful name with an enum to use in devicetree.c similar to the ones you introduce. Could a be follow-up.
--
To view, visit https://review.coreboot.org/c/coreboot/+/78829?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I79d35ca16818daec03ee7f464349a4c8ee0f78e4
Gerrit-Change-Number: 78829
Gerrit-PatchSet: 10
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Keith Hui <buurin(a)gmail.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Keith Hui <buurin(a)gmail.com>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Comment-Date: Wed, 10 Jan 2024 15:17:30 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Angel Pons, Patrick Rudolph, Paul Menzel.
Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/78827?usp=email )
Change subject: sb/intel/bd82x6x/early_usb: Print error for invalid USB setting
......................................................................
Patch Set 10: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/78827?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If76e9126b4aba8e16c1c91dece725aac12e1a7e9
Gerrit-Change-Number: 78827
Gerrit-PatchSet: 10
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Wed, 10 Jan 2024 15:14:09 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Angel Pons, Maximilian Brune, Patrick Rudolph, Paul Menzel.
Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/78828?usp=email )
Change subject: util/autoport: Improve USB code
......................................................................
Patch Set 10: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/78828?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I48f4d636ce3401ba188f5519b5ff45fccf13f080
Gerrit-Change-Number: 78828
Gerrit-PatchSet: 10
Gerrit-Owner: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Reviewer: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Wed, 10 Jan 2024 15:12:46 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Felix Held, Matt DeVillier.
Arthur Heymans has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/79883?usp=email )
Change subject: soc/amd/stoneyridge/acpi: drop wrong comment in MADT code
......................................................................
Patch Set 3: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/79883?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I6eec02578f2b2e8b8c10dad7eeecff961ef45e76
Gerrit-Change-Number: 79883
Gerrit-PatchSet: 3
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Wed, 10 Jan 2024 15:03:55 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment