Maximilian Brune has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/79950?usp=email )
Change subject: payloads/Kconfig: Make flat-binary configurable
......................................................................
payloads/Kconfig: Make flat-binary configurable
This adds the ability to add a flat-binary using menuconfig.
Test: boot hifive-unmatched mainboard with the following config:
CONFIG_PAYLOAD_NONE=n
CONFIG_PAYLOAD_ELF=y
CONFIG_PAYLOAD_FILE="~/repos/linux-riscv/arch/riscv/boot/Image"
CONFIG_PAYLOAD_IS_FLAT_BINARY=y
CONFIG_PAYLOAD_OPTIONS="-l 0x82000000 -e 0x82000000"
CONFIG_COMPRESSED_PAYLOAD_LZMA=y
Signed-off-by: Maximilian Brune <maximilian.brune(a)9elements.com>
Change-Id: I48c6b53a0c9f5b173c89f1a294a0c37fa1a58f31
---
M payloads/Kconfig
1 file changed, 3 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/50/79950/1
diff --git a/payloads/Kconfig b/payloads/Kconfig
index 2a2773a..9304629 100644
--- a/payloads/Kconfig
+++ b/payloads/Kconfig
@@ -80,13 +80,14 @@
endchoice
config PAYLOAD_OPTIONS
- string
+ string "Additional cbfstool options"
default ""
help
Additional cbfstool options for the payload
config PAYLOAD_IS_FLAT_BINARY
- def_bool n
+ bool "Payload is a flat binary"
+ default n
help
Add the payload to cbfs as a flat binary type instead of as an
elf payload
--
To view, visit https://review.coreboot.org/c/coreboot/+/79950?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I48c6b53a0c9f5b173c89f1a294a0c37fa1a58f31
Gerrit-Change-Number: 79950
Gerrit-PatchSet: 1
Gerrit-Owner: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-MessageType: newchange
Attention is currently required from: Philipp Hug, ron minnich.
Maximilian Brune has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/79949?usp=email )
Change subject: arch/riscv/boot.c: Add comment for clarity
......................................................................
arch/riscv/boot.c: Add comment for clarity
It simply adds a comment to indicate to the reader that the
RISCV_PAYLOAD_MODE_S parameter causes OpenSBI to switch to Supervisor
mode. Otherwise it could be interpreted that coreboot switches to
Supervisor mode before starting OpenSBI (which is not the case)
Signed-off-by: Maximilian Brune <maximilian.brune(a)9elements.com>
Change-Id: Ib62be0c2ff59361200df4c65f9aca5f7456a0ada
---
M src/arch/riscv/boot.c
1 file changed, 4 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/49/79949/1
diff --git a/src/arch/riscv/boot.c b/src/arch/riscv/boot.c
index a59f9d1..6f744d3 100644
--- a/src/arch/riscv/boot.c
+++ b/src/arch/riscv/boot.c
@@ -31,10 +31,12 @@
fdt = prog_entry_arg(prog);
if (ENV_RAMSTAGE && prog_type(prog) == PROG_PAYLOAD) {
- if (CONFIG(RISCV_OPENSBI))
+ if (CONFIG(RISCV_OPENSBI)) {
+ // tell OpenSBI to switch to Supervisor mode before jumping to payload
run_payload_opensbi(prog, fdt, args->opensbi, RISCV_PAYLOAD_MODE_S);
- else
+ } else {
run_payload(prog, fdt, RISCV_PAYLOAD_MODE_S);
+ }
} else {
void (*doit)(int hart_id, void *fdt, void *arg) = prog_entry(prog);
doit(hart_id, fdt, prog_entry_arg(prog));
--
To view, visit https://review.coreboot.org/c/coreboot/+/79949?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ib62be0c2ff59361200df4c65f9aca5f7456a0ada
Gerrit-Change-Number: 79949
Gerrit-PatchSet: 1
Gerrit-Owner: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Reviewer: Philipp Hug <philipp(a)hug.cx>
Gerrit-Reviewer: ron minnich <rminnich(a)gmail.com>
Gerrit-Attention: Philipp Hug <philipp(a)hug.cx>
Gerrit-Attention: ron minnich <rminnich(a)gmail.com>
Gerrit-MessageType: newchange
Attention is currently required from: Philipp Hug, ron minnich.
Maximilian Brune has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/79948?usp=email )
Change subject: arch/riscv: Add OPENSBI_FW_DYNAMIC_BOOT_HART option
......................................................................
arch/riscv: Add OPENSBI_FW_DYNAMIC_BOOT_HART option
This adds another option to tell OpenSBI which hart to use for booting.
Test: Start hifive-unmatched board and see that Hart 1 (instead of 0) is
used for running OpenSBI.
Signed-off-by: Maximilian Brune <maximilian.brune(a)9elements.com>
Change-Id: Id58bd6ae3b55a5ef3f1a5c97dfa07c79aa4c78d0
---
M src/arch/riscv/Kconfig
M src/arch/riscv/opensbi.c
2 files changed, 12 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/48/79948/1
diff --git a/src/arch/riscv/Kconfig b/src/arch/riscv/Kconfig
index 2578b12..d3f27c7 100644
--- a/src/arch/riscv/Kconfig
+++ b/src/arch/riscv/Kconfig
@@ -66,6 +66,16 @@
help
The linking address used to build opensbi.
+config OPENSBI_FW_DYNAMIC_BOOT_HART
+ int
+ default RISCV_WORKING_HARTID
+ help
+ This specifies the hart that OpenSBI will use to boot the payload. If set to
+ value -1, OpenSBI will use a 'lottery' scheme to figure it out itself.
+ This hart must be able to execute in the Supervisor priviledged mode, since
+ that is the mode usually used for the payload. It is not OpenSBI will again
+ figure it out itself.
+
config ARCH_RISCV_U
# U (user) mode is for programs.
bool
diff --git a/src/arch/riscv/opensbi.c b/src/arch/riscv/opensbi.c
index 48f0f2a..bf26b22 100644
--- a/src/arch/riscv/opensbi.c
+++ b/src/arch/riscv/opensbi.c
@@ -20,6 +20,8 @@
.version = FW_DYNAMIC_INFO_VERSION_MAX,
.next_mode = payload_mode,
.next_addr = (uintptr_t)payload,
+ .options = 0,
+ .boot_hart = CONFIG_OPENSBI_FW_DYNAMIC_BOOT_HART,
};
csr_write(mepc, opensbi);
--
To view, visit https://review.coreboot.org/c/coreboot/+/79948?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Id58bd6ae3b55a5ef3f1a5c97dfa07c79aa4c78d0
Gerrit-Change-Number: 79948
Gerrit-PatchSet: 1
Gerrit-Owner: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Reviewer: Philipp Hug <philipp(a)hug.cx>
Gerrit-Reviewer: ron minnich <rminnich(a)gmail.com>
Gerrit-Attention: Philipp Hug <philipp(a)hug.cx>
Gerrit-Attention: ron minnich <rminnich(a)gmail.com>
Gerrit-MessageType: newchange
Attention is currently required from: Jakub Czapiga, Julius Werner, Nico Huber, Philipp Hug, ron minnich.
Hello Jakub Czapiga, Julius Werner, Philipp Hug, build bot (Jenkins), ron minnich,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/79907?usp=email
to look at the new patch set (#2).
The following approvals got outdated and were removed:
Verified-1 by build bot (Jenkins)
Change subject: [RFC] region: Hide struct region members
......................................................................
[RFC] region: Hide struct region members
We cannot make `struct region` opaque for several reasons (size needs
to be known for local objects, a lot of inline API functions, ...).
However, we still want to encourage using the high-level region API
instead of directly accessing and manipulating the struct members.
This patch tries to achieve this by renaming the struct members. Only
if REGION_INTERNAL_STRUCTURES is defined before including <region.h>,
the usual member names are used.
Change-Id: I713be9cf0bab4c2e21113b55e7229ab50f06c6cf
Signed-off-by: Nico Huber <nico.h(a)gmx.de>
---
M src/arch/arm/fit_payload.c
M src/arch/arm64/fit_payload.c
M src/arch/riscv/fit_payload.c
M src/commonlib/include/commonlib/region.h
M src/commonlib/region.c
M src/lib/fit_payload.c
M tests/commonlib/region-test.c
M tests/lib/cbfs-lookup-test.c
M tests/lib/fmap-test.c
9 files changed, 26 insertions(+), 7 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/07/79907/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/79907?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I713be9cf0bab4c2e21113b55e7229ab50f06c6cf
Gerrit-Change-Number: 79907
Gerrit-PatchSet: 2
Gerrit-Owner: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Jakub Czapiga <czapiga(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Philipp Hug <philipp(a)hug.cx>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Reviewer: ron minnich <rminnich(a)gmail.com>
Gerrit-CC: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Nico Huber <nico.h(a)gmx.de>
Gerrit-Attention: Philipp Hug <philipp(a)hug.cx>
Gerrit-Attention: Jakub Czapiga <czapiga(a)google.com>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: ron minnich <rminnich(a)gmail.com>
Gerrit-MessageType: newpatchset
Naresh Solanki has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/79526?usp=email )
Change subject: mb/arm/rdn2: Add ACPI support for GIC table
......................................................................
Abandoned
taken care in another patch.
--
To view, visit https://review.coreboot.org/c/coreboot/+/79526?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I55ba7c380e0986d9f146ef4c90c9034dd610f750
Gerrit-Change-Number: 79526
Gerrit-PatchSet: 2
Gerrit-Owner: Naresh Solanki <naresh.solanki(a)9elements.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: abandon