Attention is currently required from: Wonkyu Kim, Ravishankar Sarawadi, Raj Astekar.
Hello build bot (Jenkins), Wonkyu Kim, Raj Astekar,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/63363
to look at the new patch set (#3).
Change subject: soc/intel/mtl: Do initial Meteor Lake SoC commit till romstage
......................................................................
soc/intel/mtl: Do initial Meteor Lake SoC commit till romstage
List of changes:
1. Add required SoC programming till romstage
2. Include only required headers into include/soc
3. Fill required FSP-M UPD to call FSP-M API
TEST=Build using mtlrvp
Signed-off-by: Ravi Sarawadi <ravishankar.sarawadi(a)intel.com>
Change-Id: I3d5c6ceb7f97429ff903e7577186e8d8843c1f14
---
M src/soc/intel/meteorlake/Kconfig
M src/soc/intel/meteorlake/Makefile.inc
A src/soc/intel/meteorlake/chip.h
A src/soc/intel/meteorlake/espi.c
A src/soc/intel/meteorlake/include/soc/gpe.h
M src/soc/intel/meteorlake/include/soc/iomap.h
A src/soc/intel/meteorlake/include/soc/msr.h
M src/soc/intel/meteorlake/include/soc/p2sb.h
M src/soc/intel/meteorlake/include/soc/pci_devs.h
M src/soc/intel/meteorlake/include/soc/pcr_ids.h
A src/soc/intel/meteorlake/include/soc/pmc.h
A src/soc/intel/meteorlake/include/soc/romstage.h
A src/soc/intel/meteorlake/include/soc/soc_chip.h
A src/soc/intel/meteorlake/include/soc/systemagent.h
A src/soc/intel/meteorlake/meminit.c
A src/soc/intel/meteorlake/p2sb.c
A src/soc/intel/meteorlake/reset.c
A src/soc/intel/meteorlake/romstage/Makefile.inc
A src/soc/intel/meteorlake/romstage/fsp_params.c
A src/soc/intel/meteorlake/romstage/romstage.c
A src/soc/intel/meteorlake/romstage/systemagent.c
21 files changed, 1,469 insertions(+), 56 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/63/63363/3
--
To view, visit https://review.coreboot.org/c/coreboot/+/63363
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3d5c6ceb7f97429ff903e7577186e8d8843c1f14
Gerrit-Change-Number: 63363
Gerrit-PatchSet: 3
Gerrit-Owner: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.com>
Gerrit-Reviewer: Raj Astekar <raj.astekar(a)intel.com>
Gerrit-Reviewer: Wonkyu Kim <wonkyu.kim(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Wonkyu Kim <wonkyu.kim(a)intel.com>
Gerrit-Attention: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.com>
Gerrit-Attention: Raj Astekar <raj.astekar(a)intel.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Bao Zheng, Zheng Bao.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63344 )
Change subject: amdfwtool: Add a flag to record the second gen instead of romsig
......................................................................
Patch Set 2:
(1 comment)
Patchset:
PS2:
should cb_config.second_gen also be used to populate amd_romsig->efs_gen.gen and amd_romsig->efs_gen.reseved in set_efs_table?
--
To view, visit https://review.coreboot.org/c/coreboot/+/63344
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id50311034b46aa1791dcc10b107de4af6c86b927
Gerrit-Change-Number: 63344
Gerrit-PatchSet: 2
Gerrit-Owner: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Reviewer: Zheng Bao
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Attention: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Attention: Zheng Bao
Gerrit-Comment-Date: Mon, 04 Apr 2022 23:08:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Ravishankar Sarawadi has uploaded a new patch set (#2). ( https://review.coreboot.org/c/coreboot/+/63363 )
Change subject: soc/intel/meteorlake/romstage: Do initial SoC commit till romstage
......................................................................
soc/intel/meteorlake/romstage: Do initial SoC commit till romstage
List of changes:
1. Add required SoC programming till romstage
2. Include only required headers into include/soc
3. Fill required FSP-M UPD to call FSP-M API
TEST=Build using mtlrvp
Signed-off-by: Ravi Sarawadi <ravishankar.sarawadi(a)intel.com>
Change-Id: I3d5c6ceb7f97429ff903e7577186e8d8843c1f14
---
M src/soc/intel/meteorlake/Kconfig
M src/soc/intel/meteorlake/Makefile.inc
A src/soc/intel/meteorlake/chip.h
A src/soc/intel/meteorlake/espi.c
A src/soc/intel/meteorlake/include/soc/gpe.h
M src/soc/intel/meteorlake/include/soc/iomap.h
A src/soc/intel/meteorlake/include/soc/msr.h
M src/soc/intel/meteorlake/include/soc/p2sb.h
M src/soc/intel/meteorlake/include/soc/pci_devs.h
M src/soc/intel/meteorlake/include/soc/pcr_ids.h
A src/soc/intel/meteorlake/include/soc/pmc.h
A src/soc/intel/meteorlake/include/soc/romstage.h
A src/soc/intel/meteorlake/include/soc/soc_chip.h
A src/soc/intel/meteorlake/include/soc/systemagent.h
A src/soc/intel/meteorlake/meminit.c
A src/soc/intel/meteorlake/p2sb.c
A src/soc/intel/meteorlake/reset.c
A src/soc/intel/meteorlake/romstage/Makefile.inc
A src/soc/intel/meteorlake/romstage/fsp_params.c
A src/soc/intel/meteorlake/romstage/romstage.c
A src/soc/intel/meteorlake/romstage/systemagent.c
21 files changed, 1,469 insertions(+), 56 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/63/63363/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/63363
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3d5c6ceb7f97429ff903e7577186e8d8843c1f14
Gerrit-Change-Number: 63363
Gerrit-PatchSet: 2
Gerrit-Owner: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Attention is currently required from: Felix Singer, Jamie Ryu, Subrata Banik, Ethan Tsao, Ravishankar Sarawadi, Raj Astekar.
Hello build bot (Jenkins), Jamie Ryu, Wonkyu Kim, Ethan Tsao, Raj Astekar,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/62772
to look at the new patch set (#7).
Change subject: soc/intel/mtl: Do initial Meteor Lake SoC commit till bootblock
......................................................................
soc/intel/mtl: Do initial Meteor Lake SoC commit till bootblock
List of changes:
1. Add required Meteor Lake SoC programming till bootblock
2. Include only required headers into include/soc
3. Include MTL-P related DID, BDF
4. Ref: Processor EDS documents
vol1 #621483, vol2 #640858
TEST= Build using mtlrvp board.
Signed-off-by: Ravi Sarawadi <ravishankar.sarawadi(a)intel.com>
Change-Id: I26479fcc3a3f9c6f8ebf5f198ab0809f0b4a2cc4
---
A src/soc/intel/meteorlake/Kconfig
A src/soc/intel/meteorlake/Makefile.inc
A src/soc/intel/meteorlake/bootblock/bootblock.c
A src/soc/intel/meteorlake/bootblock/pch.c
A src/soc/intel/meteorlake/bootblock/report_platform.c
A src/soc/intel/meteorlake/include/soc/bootblock.h
A src/soc/intel/meteorlake/include/soc/espi.h
A src/soc/intel/meteorlake/include/soc/iomap.h
A src/soc/intel/meteorlake/include/soc/p2sb.h
A src/soc/intel/meteorlake/include/soc/pci_devs.h
A src/soc/intel/meteorlake/include/soc/pcr_ids.h
A src/soc/intel/meteorlake/include/soc/pm.h
A src/soc/intel/meteorlake/include/soc/smbus.h
13 files changed, 1,059 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/72/62772/7
--
To view, visit https://review.coreboot.org/c/coreboot/+/62772
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I26479fcc3a3f9c6f8ebf5f198ab0809f0b4a2cc4
Gerrit-Change-Number: 62772
Gerrit-PatchSet: 7
Gerrit-Owner: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.com>
Gerrit-Reviewer: Ethan Tsao <ethan.tsao(a)intel.com>
Gerrit-Reviewer: Jamie Ryu <jamie.m.ryu(a)intel.com>
Gerrit-Reviewer: Raj Astekar <raj.astekar(a)intel.com>
Gerrit-Reviewer: Wonkyu Kim <wonkyu.kim(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Singer <felixsinger(a)posteo.net>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.corp-partner.google.com>
Gerrit-CC: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Attention: Jamie Ryu <jamie.m.ryu(a)intel.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Ethan Tsao <ethan.tsao(a)intel.com>
Gerrit-Attention: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.com>
Gerrit-Attention: Raj Astekar <raj.astekar(a)intel.com>
Gerrit-Attention: Ravishankar Sarawadi <ravishankar.sarawadi(a)intel.corp-partner.google.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Bao Zheng, Zheng Bao.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63319 )
Change subject: amdfwtool: Add a macro to set explicitly second gen for old SOCs
......................................................................
Patch Set 2: Code-Review+2
(1 comment)
Patchset:
PS2:
timeless build for chausie results in identical binary and mandolin still boots with the patch applied
--
To view, visit https://review.coreboot.org/c/coreboot/+/63319
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I65caa11e835d2ff52bec4b8904057bbced434891
Gerrit-Change-Number: 63319
Gerrit-PatchSet: 2
Gerrit-Owner: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Zheng Bao
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Bao Zheng <fishbaozi(a)gmail.com>
Gerrit-Attention: Zheng Bao
Gerrit-Comment-Date: Mon, 04 Apr 2022 22:52:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Jes Klinke.
Julius Werner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/63285 )
Change subject: Factor TI50/CR50 config
......................................................................
Patch Set 2:
(2 comments)
Patchset:
PS2:
Hmmm... okay, let's step back for a moment and try to look at the big picture. Because I feel like we are really drowing in a mess of different configs now that the previous method of organizing things doesn't really scale to. We have several different dimensions of things we need to express here (I2C vs SPI, Cr50 vs Ti50, etc.) and if we make a separate config for each dot on the cartesian product of all of them, they're just going to be way too many to handle.
The things we want to express are:
* user-declared choice of which type of TPM to use
* -> this is `NO_TPM`, `TPM1` and `TPM2`, with `TPM` as the shorthand for the latter two
* mainboard-selected default for the above choice
* -> this is `MAINBOARD_HAS_TPM1` and `MAINBOARD_HAS_TPM2`. only exists to select the default for the above
* which transport layer the TPM is connected with on the mainboard
* -> I think we should go back to only having MAINBOARD_HAS_SPI_TPM and MAINBOARD_HAS_I2C_TPM here. I'm actually not sure if there's a useful difference between `I2C_TPM`/`SPI_TPM` and `MAINBOARD_HAS_I2C_TPM`/`MAINBOARD_HAS_SPI_TPM`... maybe we can cut one indirection layer out there and just use the former two
* whether we're using a GSC variant, and which one
* -> I think this should be a completely separate choice that's only based in the tss/vendor/cr50 (rename to tss/vendor/google?) directory.
So the way I'd imagine this, basically, a mainboard would select all of these separately:
select MAINBOARD_HAS_TPM2
select I2C_TPM
select TPM_GOOGLE_TI50
other Kconfig symbols that get automatically turned on by these are `TPM2`, `TPM` and `TPM_GOOGLE`. In the Makefiles, if say you want to decide whether to build the Ti50 I2C driver, you could do something like
ifeq ($(CONFIG_I2C_TPM),y)
all-$(CONFIG_TPM_GOOGLE) += cr50.c # now google.c?
endif
I hope that might cut down on a bunch of the Kconfig madness. What do you think?
File src/drivers/i2c/tpm/Kconfig:
https://review.coreboot.org/c/coreboot/+/63285/comment/1091a33f_93b3c720
PS2, Line 17: GSC
nit: This might be a good spot to write out what GSC stands for because most upstream coreboot developers are probably unfamiliar. Or should we just make it easier and call it "TPM_GOOGLE" instead?
--
To view, visit https://review.coreboot.org/c/coreboot/+/63285
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I037b1b717a16c468e2f97a912da99f125b61e1ce
Gerrit-Change-Number: 63285
Gerrit-PatchSet: 2
Gerrit-Owner: Jes Klinke <jbk(a)chromium.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jes Klinke <jbk(a)chromium.org>
Gerrit-Comment-Date: Mon, 04 Apr 2022 22:49:28 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment