Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/68940 )
(
6 is the latest approved patch-set.
No files were changed between the latest approved patch-set and the submitted one.
)Change subject: mb/google/skyrim: Disable SD ASPM
......................................................................
mb/google/skyrim: Disable SD ASPM
Disable ASPM on SD until b/245550573 is root-caused/fixed.
Logical_lane 1 on winterhold is EMMC device.
Disable ASPM for suspend issue.
BUG=b:249914847, b:245550573
TEST=emerge-skyrim coreboot chromeos-bootimage
and test on whiterun proto emmc sku with
suspend_stress_test -c 10
Change-Id: If080cdb517a3f22aa89c8053fb6bba9e931c6f76
Signed-off-by: EricKY Cheng <ericky_cheng(a)compal.corp-partner.google.com>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/68940
Reviewed-by: Fred Reitberger <reitbergerfred(a)gmail.com>
Reviewed-by: Tim Van Patten <timvp(a)google.com>
Reviewed-by: Angel Pons <th3fanbus(a)gmail.com>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
---
M src/mainboard/google/skyrim/port_descriptors.c
1 file changed, 25 insertions(+), 1 deletion(-)
Approvals:
build bot (Jenkins): Verified
Angel Pons: Looks good to me, but someone else must approve
Fred Reitberger: Looks good to me, approved
Tim Van Patten: Looks good to me, but someone else must approve
diff --git a/src/mainboard/google/skyrim/port_descriptors.c b/src/mainboard/google/skyrim/port_descriptors.c
index 91316b3..c7b1a8b 100644
--- a/src/mainboard/google/skyrim/port_descriptors.c
+++ b/src/mainboard/google/skyrim/port_descriptors.c
@@ -28,7 +28,7 @@
.function_number = PCI_FUNC(SD_DEVFN),
.link_speed_capability = GEN3,
.turn_off_unused_lanes = true,
- .link_aspm = ASPM_L1,
+ .link_aspm = ASPM_DISABLED, // TODO: switch to ASPM_L1 after b:245550573
.link_hotplug = 3,
.gpio_group_id = GPIO_27,
.clk_req = CLK_REQ1,
--
To view, visit https://review.coreboot.org/c/coreboot/+/68940
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If080cdb517a3f22aa89c8053fb6bba9e931c6f76
Gerrit-Change-Number: 68940
Gerrit-PatchSet: 9
Gerrit-Owner: EricKY Cheng <ericky_cheng(a)compal.corp-partner.google.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Eric Peers <epeers(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Isaac Lee <isaaclee(a)google.com>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Jon Murphy <jpmurphy(a)google.com>
Gerrit-Reviewer: Karthikeyan Ramasubramanian <kramasub(a)chromium.org>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Moises Garcia <moisesgarcia(a)google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Tim Van Patten <timvp(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Amanda Hwang <amanda_hwang(a)compal.corp-partner.google.com>
Gerrit-CC: Frank Wu <frank_wu(a)compal.corp-partner.google.com>
Gerrit-CC: Nelson Ye <nelson_ye(a)compal.corp-partner.google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: merged
Felix Held has submitted this change. ( https://review.coreboot.org/c/coreboot/+/67918 )
Change subject: tests: Add option for debug symbols & no optimization
......................................................................
tests: Add option for debug symbols & no optimization
To make it easier to build the tests with debug symbols, add a check for
the "GDB_DEBUG" environment variable. If set, build with -g and -Og to
enable the symbols and disable optimization.
Signed-off-by: Martin Roth <gaumless(a)gmail.com>
Change-Id: I3a644dcccb7e15473413b775da8f70617afaefce
Reviewed-on: https://review.coreboot.org/c/coreboot/+/67918
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Jakub Czapiga <jacz(a)semihalf.com>
---
M tests/Makefile.inc
1 file changed, 25 insertions(+), 1 deletion(-)
Approvals:
build bot (Jenkins): Verified
Jakub Czapiga: Looks good to me, approved
diff --git a/tests/Makefile.inc b/tests/Makefile.inc
index 2c1a30b..90f01d1 100644
--- a/tests/Makefile.inc
+++ b/tests/Makefile.inc
@@ -10,7 +10,13 @@
include $(top)/tests/Makefile.common
-# Enable code coverage if COV=1
+# Enable GDB debug build if requested
+GDB_DEBUG ?= 0
+ifneq ($(GDB_DEBUG),0)
+TEST_CFLAGS += -g -Og
+endif
+
+# Enable code coverage if requested
ifeq ($(COV),1)
TEST_CFLAGS += --coverage
TEST_LDFLAGS += --coverage
@@ -175,6 +181,7 @@
help-unit-tests help::
@echo '*** coreboot unit-tests targets ***'
@echo ' Use "COV=1 make [target]" to enable code coverage for unit tests'
+ @echo ' Use "GDB_DEBUG=1 make [target]" to build with debug symbols'
@echo ' unit-tests - Run all unit-tests from tests/'
@echo ' clean-unit-tests - Remove unit-tests build artifacts'
@echo ' list-unit-tests - List all unit-tests'
--
To view, visit https://review.coreboot.org/c/coreboot/+/67918
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3a644dcccb7e15473413b775da8f70617afaefce
Gerrit-Change-Number: 67918
Gerrit-PatchSet: 5
Gerrit-Owner: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-CC: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-MessageType: merged
Werner Zeh has uploaded a new patch set (#2). ( https://review.coreboot.org/c/coreboot/+/69185 )
Change subject: soc/intel/block/power_limit: Avoid MSR read if it is not needed
......................................................................
soc/intel/block/power_limit: Avoid MSR read if it is not needed
In function 'set_power_limits' there is a path to bail out early if the
Kconfig switch SOC_INTEL_DISABLE_POWER_LIMITS is selected. In this case
reading the MSR PLATFORM_INFO is useless and can be avoided. So read it
right before the value is needed.
This was found by the scanbuild.
In addition, fix an unnecessary line break to increase code readability.
Change-Id: Ibdededdfd56287fb9b9223e78033a3cd6425e1a2
Signed-off-by: Werner Zeh <werner.zeh(a)siemens.com>
---
M src/soc/intel/common/block/power_limit/power_limit.c
1 file changed, 22 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/85/69185/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/69185
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ibdededdfd56287fb9b9223e78033a3cd6425e1a2
Gerrit-Change-Number: 69185
Gerrit-PatchSet: 2
Gerrit-Owner: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
build bot (Jenkins) has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69185 )
Change subject: soc/intel/block/power_limit: Avoid MSR read if it is not needed
......................................................................
Patch Set 1:
(2 comments)
Commit Message:
Robot Comment from checkpatch (run ID jenkins-coreboot-checkpatch-162284):
https://review.coreboot.org/c/coreboot/+/69185/comment/5e49dab8_60404ae4
PS1, Line 16: Found-by: scanbuild
Non-standard signature: Found-by:
Robot Comment from checkpatch (run ID jenkins-coreboot-checkpatch-162284):
https://review.coreboot.org/c/coreboot/+/69185/comment/0b0a7e4e_33f853cf
PS1, Line 16: Found-by: scanbuild
Unrecognized email address: 'scanbuild'
--
To view, visit https://review.coreboot.org/c/coreboot/+/69185
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ibdededdfd56287fb9b9223e78033a3cd6425e1a2
Gerrit-Change-Number: 69185
Gerrit-PatchSet: 1
Gerrit-Owner: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Thu, 03 Nov 2022 12:30:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Werner Zeh has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/69185 )
Change subject: soc/intel/block/power_limit: Avoid MSR read if it is not needed
......................................................................
soc/intel/block/power_limit: Avoid MSR read if it is not needed
In function 'set_power_limits' there is a path to bail out early if the
Kconfig switch SOC_INTEL_DISABLE_POWER_LIMITS is selected. In this case
reading the MSR PLATFORM_INFO is useless and can be avoided. So read it
right before the value is needed.
In addition, fix an unnecessary line break to increase code readability.
Found-by: scanbuild
Change-Id: Ibdededdfd56287fb9b9223e78033a3cd6425e1a2
Signed-off-by: Werner Zeh <werner.zeh(a)siemens.com>
---
M src/soc/intel/common/block/power_limit/power_limit.c
1 file changed, 22 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/85/69185/1
diff --git a/src/soc/intel/common/block/power_limit/power_limit.c b/src/soc/intel/common/block/power_limit/power_limit.c
index dce174b..d7c9077 100644
--- a/src/soc/intel/common/block/power_limit/power_limit.c
+++ b/src/soc/intel/common/block/power_limit/power_limit.c
@@ -72,7 +72,7 @@
void set_power_limits(u8 power_limit_1_time,
struct soc_power_limits_config *conf)
{
- msr_t msr = rdmsr(MSR_PLATFORM_INFO);
+ msr_t msr;
msr_t limit;
unsigned int power_unit;
unsigned int tdp, min_power, max_power, max_time, tdp_pl2, tdp_pl1;
@@ -96,9 +96,9 @@
}
if (power_limit_1_time >= ARRAY_SIZE(power_limit_time_sec_to_msr))
- power_limit_1_time =
- ARRAY_SIZE(power_limit_time_sec_to_msr) - 1;
+ power_limit_1_time = ARRAY_SIZE(power_limit_time_sec_to_msr) - 1;
+ msr = rdmsr(MSR_PLATFORM_INFO);
if (!(msr.lo & PLATFORM_INFO_SET_TDP))
return;
--
To view, visit https://review.coreboot.org/c/coreboot/+/69185
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ibdededdfd56287fb9b9223e78033a3cd6425e1a2
Gerrit-Change-Number: 69185
Gerrit-PatchSet: 1
Gerrit-Owner: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-MessageType: newchange
Attention is currently required from: Patrick Georgi, Martin L Roth, ron minnich.
Maxim Polyakov has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/59958 )
Change subject: util/docker/coreboot.org-status: Rewrite parser
......................................................................
Patch Set 18: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/59958
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I4fab86d24088e4f9eff434c21ce9caa077f3f9e2
Gerrit-Change-Number: 59958
Gerrit-PatchSet: 18
Gerrit-Owner: Patrick Georgi <patrick(a)coreboot.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Maxim Polyakov <max.senia.poliak(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: ron minnich <rminnich(a)gmail.com>
Gerrit-Attention: Patrick Georgi <patrick(a)coreboot.org>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: ron minnich <rminnich(a)gmail.com>
Gerrit-Comment-Date: Thu, 03 Nov 2022 12:19:19 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment