Attention is currently required from: Jason Glenesk, Raul Rangel, Matt DeVillier, Fred Reitberger.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69073 )
Change subject: soc/amd/common/block/data_fabric: Use register bitslice structs
......................................................................
Patch Set 1: Code-Review+1
(2 comments)
File src/soc/amd/common/block/data_fabric/data_fabric_helper.c:
https://review.coreboot.org/c/coreboot/+/69073/comment/0e100555_3e5714e7
PS1, Line 17: ficaa.reg_num = reg >> 2;
not sure if this is obvious from the code, but maybe add a comment here that this is the number of the 32bit register?
https://review.coreboot.org/c/coreboot/+/69073/comment/9b7bea72_d32170b2
PS1, Line 119: ctrl.raw = data_fabric_broadcast_read32(0, NB_MMIO_CONTROL(i));
: if (!(ctrl.we || ctrl.re))
hm, this is basically is_mmio_reg_disabled, but since we need ctrl.raw in line 147, using that here would result in an additional pci config space access. i'dleave it as it is for now, but maybe look into this in a future patch
--
To view, visit https://review.coreboot.org/c/coreboot/+/69073
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ia5566f7af6cf5444fc8c627e004dd08185468c77
Gerrit-Change-Number: 69073
Gerrit-PatchSet: 1
Gerrit-Owner: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Comment-Date: Thu, 03 Nov 2022 14:04:23 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Shelley Chen, Taniya Das, Paul Menzel, Sudheer Amrabadi.
Venkat Thogaru has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68384 )
Change subject: soc/qualcomm/sc7280: Add API to differentialize PRO and NON_PRO SKUs
......................................................................
Patch Set 11:
(7 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/68384/comment/4ad4cbc9_3cd6219e
PS9, Line 7:
> Please use one space.
Done
https://review.coreboot.org/c/coreboot/+/68384/comment/566a11ce_a25e6508
PS9, Line 7: Add socinfo_pro_part() function in
: coreboot
> Maybe: Add function to differentiate between PRO and NON_PRO SKUs
Done
https://review.coreboot.org/c/coreboot/+/68384/comment/ab35e357_75b646b5
PS9, Line 8: coreboot
> Please just use one line for the summary [1]. […]
Done
https://review.coreboot.org/c/coreboot/+/68384/comment/a339731d_c67fdcf4
PS9, Line 10:
> Please use exactly one space.
Done
https://review.coreboot.org/c/coreboot/+/68384/comment/6db0aeed_ce6445a2
PS9, Line 10: The API socinfo_pro_part is added to help to differentiate
: between PRO and NON_PRO SKUs. Returns 1 for Pro
: and 0 for NON_PRO SKUs.
> Please reflow for 72 characters per line.
Done
https://review.coreboot.org/c/coreboot/+/68384/comment/6313a331_131f5337
PS9, Line 15: Validate boards are detected correctly on PRO
: and NON_PRO SKUs
> Ditto.
Done
Patchset:
PS9:
> The commit seems to do more changes than documented in the commit message.
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/68384
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id9f23696384a6c1a89000292eafebd8a16c273ca
Gerrit-Change-Number: 68384
Gerrit-PatchSet: 11
Gerrit-Owner: Sudheer Amrabadi <samrabad(a)codeaurora.org>
Gerrit-Reviewer: Shelley Chen <shchen(a)google.com>
Gerrit-Reviewer: Taniya Das <quic_tdas(a)quicinc.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Taniya Das <tdas(a)qualcomm.corp-partner.google.com>
Gerrit-CC: Venkat Thogaru <thogaru(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Shelley Chen <shchen(a)google.com>
Gerrit-Attention: Taniya Das <quic_tdas(a)quicinc.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Taniya Das <tdas(a)qualcomm.corp-partner.google.com>
Gerrit-Attention: Sudheer Amrabadi <samrabad(a)codeaurora.org>
Gerrit-Comment-Date: Thu, 03 Nov 2022 13:58:15 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: comment
Attention is currently required from: Frank Chu.
Tarun Tuli has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69180 )
Change subject: [test]mb/google/brya/marasov: Update gpio table
......................................................................
Patch Set 3:
(1 comment)
Patchset:
PS3:
Hi Frank.
For [test] or changes not ready to get submitted yet, could you please mark them as "Work In Progress"
--
To view, visit https://review.coreboot.org/c/coreboot/+/69180
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I03b443826d39182eaf23ad3e4e0ba8d6b8a93022
Gerrit-Change-Number: 69180
Gerrit-PatchSet: 3
Gerrit-Owner: Frank Chu <frank_chu(a)pegatron.corp-partner.google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Ken Lu <ken_lu(a)pegatron.corp-partner.google.com>
Gerrit-Attention: Frank Chu <frank_chu(a)pegatron.corp-partner.google.com>
Gerrit-Comment-Date: Thu, 03 Nov 2022 13:53:04 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Jason Glenesk, Matt DeVillier, Fred Reitberger.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69071 )
Change subject: soc/amd/morgana/data_fabric: Add register bitslice struct
......................................................................
Patch Set 1:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/69071/comment/49fc3a50_6141bb2f
PS1, Line 11:
please also mention that you update bot IOMS0_FABRIC_ID and DF_MMIO_NP in this patch in the commit message
--
To view, visit https://review.coreboot.org/c/coreboot/+/69071
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If64c875026b643c584975f7abffad9b35f1a7b44
Gerrit-Change-Number: 69071
Gerrit-PatchSet: 1
Gerrit-Owner: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Comment-Date: Thu, 03 Nov 2022 13:44:14 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Arthur Heymans.
Hung-Te Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69183 )
Change subject: lib/coreboot_table: Rename lb_fill_pcie
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/69183
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I046016b3898308bb56b4ad6a5834ab942fdd50f2
Gerrit-Change-Number: 69183
Gerrit-PatchSet: 1
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Thu, 03 Nov 2022 13:40:44 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Martin L Roth, Martin Roth.
Sean Rhodes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68595 )
Change subject: payloads: Make PAYLOAD_NONE a bool outside of the choice
......................................................................
Patch Set 3: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/68595
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I932c65630261a5b39809abf4dfbda5bf932c6684
Gerrit-Change-Number: 68595
Gerrit-PatchSet: 3
Gerrit-Owner: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Comment-Date: Thu, 03 Nov 2022 13:40:22 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Julius Werner, Arthur Heymans, ron minnich.
Hung-Te Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68768 )
Change subject: lib/coreboot_table: Simplify API to set up lb_serial
......................................................................
Patch Set 11: Code-Review+1
--
To view, visit https://review.coreboot.org/c/coreboot/+/68768
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6c08a88fb5fc035eb28d0becf19471c709c8043d
Gerrit-Change-Number: 68768
Gerrit-PatchSet: 11
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Reviewer: ron minnich <rminnich(a)gmail.com>
Gerrit-CC: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: ron minnich <rminnich(a)gmail.com>
Gerrit-Comment-Date: Thu, 03 Nov 2022 13:40:08 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Jason Glenesk, Raul Rangel, Martin L Roth, Matt DeVillier, Fred Reitberger, Felix Held.
Sean Rhodes has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68994 )
Change subject: soc/amd: Specify memory types supported by each chip
......................................................................
Patch Set 1: Code-Review+1
--
To view, visit https://review.coreboot.org/c/coreboot/+/68994
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I8c7f47b43d8d4a89630fbd645a725e61d74bc2a5
Gerrit-Change-Number: 68994
Gerrit-PatchSet: 1
Gerrit-Owner: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Thu, 03 Nov 2022 13:40:03 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Julius Werner, Arthur Heymans, ron minnich.
Hung-Te Lin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68768 )
Change subject: lib/coreboot_table: Simplify API to set up lb_serial
......................................................................
Patch Set 11:
(1 comment)
File src/lib/coreboot_table.c:
https://review.coreboot.org/c/coreboot/+/68768/comment/dc1a7999_5b517081
PS11, Line 498: lb_add_serial
if you look at all lb_XXX calls in this function, they don't have 'add' (except the lb_add_console and lb_add_acpi_rsdp). Maybe lb_serial is a better name? But I'm fine either way.
--
To view, visit https://review.coreboot.org/c/coreboot/+/68768
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I6c08a88fb5fc035eb28d0becf19471c709c8043d
Gerrit-Change-Number: 68768
Gerrit-PatchSet: 11
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Reviewer: ron minnich <rminnich(a)gmail.com>
Gerrit-CC: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: ron minnich <rminnich(a)gmail.com>
Gerrit-Comment-Date: Thu, 03 Nov 2022 13:40:00 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment