Martin Roth has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/51906 )
Change subject: src: Put __weak on same line as function
......................................................................
Abandoned
--
To view, visit https://review.coreboot.org/c/coreboot/+/51906
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I816f4afd497ec7bd6d660df2b7650c3ded289334
Gerrit-Change-Number: 51906
Gerrit-PatchSet: 1
Gerrit-Owner: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Andrey Petrov <andrey.petrov(a)gmail.com>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: abandon
Martin Roth has abandoned this change. ( https://review.coreboot.org/c/coreboot/+/51882 )
Change subject: Makefile.inc: Quiet "Skipping submodule" noise unless V=1
......................................................................
Abandoned
--
To view, visit https://review.coreboot.org/c/coreboot/+/51882
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I1ebc98f5e79a423a3a45c5fba9fa07cec617d2ed
Gerrit-Change-Number: 51882
Gerrit-PatchSet: 1
Gerrit-Owner: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Georgi <pgeorgi(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-MessageType: abandon
Martin Roth has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/48906 )
Change subject: Documentation: Add the osource keyword to kconfig.md
......................................................................
Documentation: Add the osource keyword to kconfig.md
The 'source' kconfig keyword will soon return an error if the file being
referenced does not exist. The 'osource' keyword has been added to
allow for sourcing files that may or may not exist.
Signed-off-by: Martin Roth <martin(a)coreboot.org>
Change-Id: If22b9012a3c512720fcd4b84f396cc2b5e668d3c
---
M Documentation/getting_started/kconfig.md
1 file changed, 41 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/06/48906/1
diff --git a/Documentation/getting_started/kconfig.md b/Documentation/getting_started/kconfig.md
index 037371b..71fed2c 100644
--- a/Documentation/getting_started/kconfig.md
+++ b/Documentation/getting_started/kconfig.md
@@ -699,6 +699,47 @@
--------------------------------------------------------------------------------
+### osource
+
+The 'osource' keyword functions similarly to an 'include' statement in c or
+the 'source' keyword in Kconfig, except that there is no error if the file
+being sourced is not present.
+This pulls one or more files into Kconfig at the location of the 'osource'
+command. This statement is always parsed - there is no way to conditionally
+source a file. coreboot's source and osource statements have been updated to
+accept directory globbing. The '*' character will match with any directory.
+
+
+
+##### Usage:
+osource <prompt>
+
+
+##### Example:
+# load site-local kconfig to allow user specific defaults and overrides
+osource "site-local/Kconfig"
+
+##### Notes:
+- As with all prompt values, the 'osource' prompt may be enclosed in single or
+ double quotes, or left without any quotes. Using quotes is highly recommended
+ however.
+- The 'osource' keyword loads files relative to the working directory where the
+ Kconfig command was run. For coreboot, this is the root coreboot directory, so
+ all osource commands in the src directory need to start with ‘src/’.
+- 'osource' pulls a file into the Kconfig tree at the location of the keyword.
+ This allows for files containing small bits of the Kconfig tree to be pulled
+ into a larger construct. A restriction on this is that the starting/ending
+ keyword pairs must be within the same file - ‘endif’ cannot appear in a
+ different file than the ‘if’ statement that it ends. The same is true of
+ menu/endmenu and choice/endchoice pairs.
+
+##### Restrictions:
+- 'osource' keywords always load in the specified file or files if they exist.
+ This does not optionally pull in a file, it just doesn't error out if the
+ file does not exist.
+
+--------------------------------------------------------------------------------
+
### prompt
The 'prompt' keyword sets the text displayed for a config symbol or choice in
--
To view, visit https://review.coreboot.org/c/coreboot/+/48906
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If22b9012a3c512720fcd4b84f396cc2b5e668d3c
Gerrit-Change-Number: 48906
Gerrit-PatchSet: 1
Gerrit-Owner: Martin Roth <martinroth(a)google.com>
Gerrit-MessageType: newchange
Attention is currently required from: Jason Glenesk, Raul Rangel, Furquan Shaikh, Felix Held.
Martin Roth has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/51747 )
Change subject: soc/amd/common: Add some ESPI register definitions
......................................................................
Patch Set 6:
(1 comment)
File src/soc/amd/common/block/include/amdblocks/espi.h:
https://review.coreboot.org/c/coreboot/+/51747/comment/d89ecc31_1fe27858
PS6, Line 20: #define ESPI_IO_BASE_OFFSET_REG1 0x48
> No, they're not required, but it seems useful to have them.
Ack.
--
To view, visit https://review.coreboot.org/c/coreboot/+/51747
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ieae53b12e5303641fb3f180c47468aaa6906e9af
Gerrit-Change-Number: 51747
Gerrit-PatchSet: 6
Gerrit-Owner: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Furquan Shaikh <furquan(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Furquan Shaikh <furquan(a)google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 05 Apr 2021 17:14:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Raul Rangel <rrangel(a)chromium.org>
Comment-In-Reply-To: Martin Roth <martinroth(a)google.com>
Gerrit-MessageType: comment
Attention is currently required from: Jason Glenesk, Raul Rangel, Furquan Shaikh, Felix Held.
Martin Roth has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/51747 )
Change subject: soc/amd/common: Add some ESPI register definitions
......................................................................
Patch Set 6:
(1 comment)
File src/soc/amd/common/block/include/amdblocks/espi.h:
https://review.coreboot.org/c/coreboot/+/51747/comment/799ceab0_4017ea51
PS6, Line 20: #define ESPI_IO_BASE_OFFSET_REG1 0x48
> Do we need the _REG1,_REG2,_REG3? I don't see them being used as long as we have the ESPI_IO_RANGE_B […]
No, they're not required, but it seems useful to have them.
--
To view, visit https://review.coreboot.org/c/coreboot/+/51747
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ieae53b12e5303641fb3f180c47468aaa6906e9af
Gerrit-Change-Number: 51747
Gerrit-PatchSet: 6
Gerrit-Owner: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Furquan Shaikh <furquan(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Furquan Shaikh <furquan(a)google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 05 Apr 2021 17:14:13 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Raul Rangel <rrangel(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Furquan Shaikh, Felix Held.
Martin Roth has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/51675 )
Change subject: mb/google/guybrush: Update GPIO configuration
......................................................................
Patch Set 11:
(3 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/51675/comment/5adfce04_17db3e65
PS10, Line 9: Init I2C3 early for GSC communication.
> This isn't done as part of this CL.
Done
File src/mainboard/google/guybrush/variants/baseboard/gpio.c:
https://review.coreboot.org/c/coreboot/+/51675/comment/cf09620e_733a7a04
PS10, Line 59: // PAD_NF(GPIO_26, PCIE_RST_L, PULL_NONE),
> I think it's best not to leave commented out code here. […]
Done
https://review.coreboot.org/c/coreboot/+/51675/comment/f084ea59_6f706890
PS10, Line 180: SPI_CLK2
> nit: Probably name this ESPI_SOC_CLK? That will make it clear that this is related to eSPI clock.
Done, here and above.
--
To view, visit https://review.coreboot.org/c/coreboot/+/51675
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I512cb8b435dc8412cd46189e741ad94e5a24699e
Gerrit-Change-Number: 51675
Gerrit-PatchSet: 11
Gerrit-Owner: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Marshall Dawson <marshalldawson3rd(a)gmail.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-CC: Mathew King <mathewk(a)chromium.org>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Attention: Furquan Shaikh <furquan(a)google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Mon, 05 Apr 2021 17:12:25 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Furquan Shaikh <furquan(a)google.com>
Gerrit-MessageType: comment