Werner Zeh has submitted this change. ( https://review.coreboot.org/c/coreboot/+/58095 )
Change subject: security/vboot: Remove vb2ex_hwcrypto stubs
......................................................................
security/vboot: Remove vb2ex_hwcrypto stubs
Now that the vb2ex_hwcrypto_* stub functions are included in vboot fwlib
(CL:2353775), we can remove the same stubs from coreboot.
BUG=none
TEST=emerge-brya coreboot
TEST=emerge-cherry coreboot
BRANCH=none
Change-Id: I62bdc647eb3e34c581cc1b8d15e7f271211e6156
Signed-off-by: Yu-Ping Wu <yupingso(a)chromium.org>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/58095
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Julius Werner <jwerner(a)chromium.org>
Reviewed-by: Werner Zeh <werner.zeh(a)siemens.com>
---
M src/security/vboot/vboot_logic.c
1 file changed, 0 insertions(+), 21 deletions(-)
Approvals:
build bot (Jenkins): Verified
Werner Zeh: Looks good to me, but someone else must approve
Julius Werner: Looks good to me, approved
diff --git a/src/security/vboot/vboot_logic.c b/src/security/vboot/vboot_logic.c
index ff93d0b..91d42b2 100644
--- a/src/security/vboot/vboot_logic.c
+++ b/src/security/vboot/vboot_logic.c
@@ -54,27 +54,6 @@
return VB2_SUCCESS;
}
-/* No-op stubs that can be overridden by SoCs with hardware crypto support. */
-__weak vb2_error_t vb2ex_hwcrypto_digest_init(enum vb2_hash_algorithm hash_alg,
- uint32_t data_size)
-{
- return VB2_ERROR_EX_HWCRYPTO_UNSUPPORTED;
-}
-
-__weak vb2_error_t vb2ex_hwcrypto_digest_extend(const uint8_t *buf,
- uint32_t size)
-{
- BUG(); /* Should never get called if init() returned an error. */
- return VB2_ERROR_UNKNOWN;
-}
-
-__weak vb2_error_t vb2ex_hwcrypto_digest_finalize(uint8_t *digest,
- uint32_t digest_size)
-{
- BUG(); /* Should never get called if init() returned an error. */
- return VB2_ERROR_UNKNOWN;
-}
-
static int handle_digest_result(void *slot_hash, size_t slot_hash_sz)
{
int is_resume;
--
To view, visit https://review.coreboot.org/c/coreboot/+/58095
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I62bdc647eb3e34c581cc1b8d15e7f271211e6156
Gerrit-Change-Number: 58095
Gerrit-PatchSet: 2
Gerrit-Owner: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: merged
Werner Zeh has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/58155 )
Change subject: drivers/pc80/tpm: Fix wrong debug message
......................................................................
drivers/pc80/tpm: Fix wrong debug message
There is the wrong register offset printed in the debug log when the
data register is written:
'lpc_tpm: Write reg 0x18 with 0xnn' should be
'lpc_tpm: Write reg 0x24 with 0xnn' for data FIFO access.
This can be confusing when searching for issues with the help of the
TPM debug messages since the code itself is correct. Fix this error.
Change-Id: Ic28ee5a07146e804574b887ea05c62e7e88e9078
Signed-off-by: Werner Zeh <werner.zeh(a)siemens.com>
---
M src/drivers/pc80/tpm/tis.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/55/58155/1
diff --git a/src/drivers/pc80/tpm/tis.c b/src/drivers/pc80/tpm/tis.c
index 526b574..2b29acf 100644
--- a/src/drivers/pc80/tpm/tis.c
+++ b/src/drivers/pc80/tpm/tis.c
@@ -172,7 +172,7 @@
static inline void tpm_write_data(u8 data, int locality)
{
- TPM_DEBUG_IO_WRITE(TIS_REG_STS, data);
+ TPM_DEBUG_IO_WRITE(TIS_REG_DATA_FIFO, data);
write8(TIS_REG(locality, TIS_REG_DATA_FIFO), data);
}
--
To view, visit https://review.coreboot.org/c/coreboot/+/58155
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ic28ee5a07146e804574b887ea05c62e7e88e9078
Gerrit-Change-Number: 58155
Gerrit-PatchSet: 1
Gerrit-Owner: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-MessageType: newchange
Attention is currently required from: Werner Zeh.
Yu-Ping Wu has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58095 )
Change subject: security/vboot: Remove vb2ex_hwcrypto stubs
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> Is there a need to update the vboot git hassh for coreboot submodules first to have it included?
No. The current vboot 13f601fbd4c1b128f333391e4552082594f0ff25 already contains CL:2353775.
--
To view, visit https://review.coreboot.org/c/coreboot/+/58095
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I62bdc647eb3e34c581cc1b8d15e7f271211e6156
Gerrit-Change-Number: 58095
Gerrit-PatchSet: 1
Gerrit-Owner: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-Comment-Date: Thu, 07 Oct 2021 05:16:32 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-MessageType: comment
Attention is currently required from: Yu-Ping Wu.
Werner Zeh has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/58095 )
Change subject: security/vboot: Remove vb2ex_hwcrypto stubs
......................................................................
Patch Set 1: Code-Review+1
(1 comment)
Patchset:
PS1:
Is there a need to update the vboot git hassh for coreboot submodules first to have it included?
--
To view, visit https://review.coreboot.org/c/coreboot/+/58095
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I62bdc647eb3e34c581cc1b8d15e7f271211e6156
Gerrit-Change-Number: 58095
Gerrit-PatchSet: 1
Gerrit-Owner: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Comment-Date: Thu, 07 Oct 2021 05:08:50 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Jakub Czapiga, Jan Dabros.
Werner Zeh has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/57555 )
Change subject: tests: Add lib/lzma-test test case
......................................................................
Patch Set 6: Code-Review+1
(3 comments)
File tests/lib/lzma-test.c:
https://review.coreboot.org/c/coreboot/+/57555/comment/99cc4885_608fdb9e
PS6, Line 48: /* 9 -> strlen(".lzma.bin") */
nit: Now that you have moved on to ARRAY_SIZE this '9' is a bit confusing.
https://review.coreboot.org/c/coreboot/+/57555/comment/614d88fb_58926cb9
PS6, Line 81: test_free(s->raw_filename);
: test_free(s->comp_filename);
: test_free(s)
How about calling teardown_ulzman_file() here?
https://review.coreboot.org/c/coreboot/+/57555/comment/8ac18415_480085ee
PS6, Line 120: assert_non_null(raw_buf);
: assert_non_null(comp_buf);
I guess this test is here for making sure that test_malloc was successful in getting some memory, right? Then why not add the same test her for dcomp_buf?
--
To view, visit https://review.coreboot.org/c/coreboot/+/57555
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id75e0b41991382d4c391b031862106de58eacdf7
Gerrit-Change-Number: 57555
Gerrit-PatchSet: 6
Gerrit-Owner: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: Jan Dabros <jsd(a)semihalf.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Paul Fagerburg <pfagerburg(a)chromium.org>
Gerrit-Reviewer: Werner Zeh <werner.zeh(a)siemens.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Attention: Jan Dabros <jsd(a)semihalf.com>
Gerrit-Comment-Date: Thu, 07 Oct 2021 05:06:10 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: vagdevi.p(a)intel.com.
vagdevi.p(a)intel.com has removed Paul Menzel from this change. ( https://review.coreboot.org/c/coreboot/+/57950 )
Change subject: Revert "mb/google/brya: Disable crashlog on brya"
......................................................................
Removed cc Paul Menzel.
--
To view, visit https://review.coreboot.org/c/coreboot/+/57950
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I5f257c67cb078a633eb860b3872a13d55778b69e
Gerrit-Change-Number: 57950
Gerrit-PatchSet: 1
Gerrit-Owner: vagdevi.p(a)intel.com
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: 9elements QA <hardwaretestrobot(a)gmail.com>
Gerrit-Attention: vagdevi.p(a)intel.com
Gerrit-MessageType: deleteReviewer
Attention is currently required from: vagdevi.p(a)intel.com.
vagdevi.p(a)intel.com has removed Tim Wawrzynczak from this change. ( https://review.coreboot.org/c/coreboot/+/57950 )
Change subject: Revert "mb/google/brya: Disable crashlog on brya"
......................................................................
Removed reviewer Tim Wawrzynczak.
--
To view, visit https://review.coreboot.org/c/coreboot/+/57950
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I5f257c67cb078a633eb860b3872a13d55778b69e
Gerrit-Change-Number: 57950
Gerrit-PatchSet: 1
Gerrit-Owner: vagdevi.p(a)intel.com
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: 9elements QA <hardwaretestrobot(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: vagdevi.p(a)intel.com
Gerrit-MessageType: deleteReviewer