Hello Felix Singer, build bot (Jenkins), Nico Huber, Furquan Shaikh, Matt DeVillier, Paul Menzel, Tim Wawrzynczak, Subrata Banik, Patrick Rudolph,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/46461
to look at the new patch set (#10).
Change subject: soc/intel/skl: replace conditional on dt option reading CPUID for CPPC
......................................................................
soc/intel/skl: replace conditional on dt option reading CPUID for CPPC
Check ISST (Intel SpeedShift) availability via CPUID.06H:EAX[7], instead
of relying on the devicetree option `speed_shift_enable`, that is going
to be dropped.
Test: GCPC and _CPC entries still get generated on Supermicro X11SSM-F
Change-Id: I5f9bf09385627fb6a1d8e566a80370f7ddd8605e
Signed-off-by: Michael Niewöhner <foss(a)mniewoehner.de>
---
M src/soc/intel/skylake/acpi.c
1 file changed, 4 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/61/46461/10
--
To view, visit https://review.coreboot.org/c/coreboot/+/46461
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I5f9bf09385627fb6a1d8e566a80370f7ddd8605e
Gerrit-Change-Number: 46461
Gerrit-PatchSet: 10
Gerrit-Owner: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Michael Niewöhner has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/46460 )
Change subject: soc/intel: drop unneeded ISST configuration code
......................................................................
Patch Set 7:
(3 comments)
https://review.coreboot.org/c/coreboot/+/46460/6//COMMIT_MSG
Commit Message:
https://review.coreboot.org/c/coreboot/+/46460/6//COMMIT_MSG@16
PS6, Line 16: OS to not enable HWP if that is desired.
> Please also mention the other bits that were set by the dropped […]
I confirmed this on CML-U (Clevo L141CU), KBL-H (Smc X11SSM-F) and SKL-U (Acer ES1-572) by printing the MSR in bootblock. In all three cases MSR 0x1aah is 0x1cc0
Cold boot from fresh flash without AC attached ofc.
where in all cases the bits were set after a cold boot (fresh flash without AC attached)
https://review.coreboot.org/c/coreboot/+/46460/6//COMMIT_MSG@19
PS6, Line 19: , as well as the devicetree option
> I don't see that.
Done
https://review.coreboot.org/c/coreboot/+/46460/6//COMMIT_MSG@21
PS6, Line 21: explicitly disabling
> Are there any?
neither the one or the other. I checked this but forgot to remove that paragraph
--
To view, visit https://review.coreboot.org/c/coreboot/+/46460
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I952720cf1de78b00b1bf749f10e9c0acd6ecb6b7
Gerrit-Change-Number: 46460
Gerrit-PatchSet: 7
Gerrit-Owner: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Wed, 21 Oct 2020 22:43:34 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Nico Huber <nico.h(a)gmx.de>
Gerrit-MessageType: comment
Hello Felix Singer, build bot (Jenkins), Nico Huber, Furquan Shaikh, Matt DeVillier, Tim Wawrzynczak, Paul Menzel, Subrata Banik, Patrick Rudolph, Karthik Ramasubramanian,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/46460
to look at the new patch set (#7).
Change subject: soc/intel: drop unneeded ISST configuration code
......................................................................
soc/intel: drop unneeded ISST configuration code
The code configuring ISST (Intel SpeedShift Technology) sets the ISST
capability bits in CPUID.06H:EAX. It does *not* activate HWP (Hardware
P-States), which shall be done by the OS only.
Since the capability is enabled by default (opt-out), there is nothing
to do for us in the enabled-case. Practically speaking, there is no
value at all in disabling the capability, since one can configure the
OS to not enable HWP if that is desired.
The two other bits for EPP and HWP interrupt that were set by the code
are not set anymore, too. It was tested, on three platforms so far
(CML-U, KBL-H, SKL-U), that these are set as well by default in the
MSRs reset value (0x1cc0).
To reduce complexity and duplicated code without actual benefit, this
code gets dropped. The remaining dt option will be dropped in CB:46462.
Test: Linux on Supermicro X11SSM-F detects and enables HWP:
[ 0.415017] intel_pstate: HWP enabled
Change-Id: I952720cf1de78b00b1bf749f10e9c0acd6ecb6b7
Signed-off-by: Michael Niewöhner <foss(a)mniewoehner.de>
---
M src/soc/intel/alderlake/cpu.c
M src/soc/intel/cannonlake/cpu.c
M src/soc/intel/elkhartlake/cpu.c
M src/soc/intel/icelake/cpu.c
M src/soc/intel/jasperlake/cpu.c
M src/soc/intel/skylake/cpu.c
M src/soc/intel/tigerlake/cpu.c
7 files changed, 0 insertions(+), 196 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/60/46460/7
--
To view, visit https://review.coreboot.org/c/coreboot/+/46460
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I952720cf1de78b00b1bf749f10e9c0acd6ecb6b7
Gerrit-Change-Number: 46460
Gerrit-PatchSet: 7
Gerrit-Owner: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-Reviewer: Felix Singer <felixsinger(a)posteo.net>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Tim Wawrzynczak has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/32350 )
Change subject: src/arch/x86:Add support for low power idle table
......................................................................
Patch Set 4:
(1 comment)
https://review.coreboot.org/c/coreboot/+/32350/4/src/arch/x86/acpi.c
File src/arch/x86/acpi.c:
https://review.coreboot.org/c/coreboot/+/32350/4/src/arch/x86/acpi.c@1253
PS4, Line 1253: __weak void soc_residency_counter(struct acpi_lpit_native *lpit_native)
> hmm, maybe I was wrong and we don't even need soc-specific LPIT tables but just set the addresses an […]
Yeah, for constant information like this, I think I'd rather just use #defines, but I like the tables idea
--
To view, visit https://review.coreboot.org/c/coreboot/+/32350
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ie76ab0d50f09c98762bc674c2758520d53789137
Gerrit-Change-Number: 32350
Gerrit-PatchSet: 4
Gerrit-Owner: Shaunak Saha <shaunak.saha(a)intel.com>
Gerrit-Reviewer: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Justin TerAvest <teravest(a)chromium.org>
Gerrit-Reviewer: Karthikeyan Ramasubramanian <kramasub(a)chromium.org>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Shaunak Saha <shaunak.saha(a)intel.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-CC: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Comment-Date: Wed, 21 Oct 2020 22:42:33 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Michael Niewöhner <foss(a)mniewoehner.de>
Gerrit-MessageType: comment
Duncan Laurie has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/46258 )
Change subject: acpigen: Make acpigen_write_opregion() argument const
......................................................................
acpigen: Make acpigen_write_opregion() argument const
This structure is not modified so it can be made const and allow
the calling function to also declare it as a const structure.
Signed-off-by: Duncan Laurie <dlaurie(a)google.com>
Change-Id: Id8cdfb4b3450a5ab2164ab048497324175b32269
---
M src/acpi/acpigen.c
M src/include/acpi/acpigen.h
2 files changed, 2 insertions(+), 2 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/58/46258/1
diff --git a/src/acpi/acpigen.c b/src/acpi/acpigen.c
index e2fe2cf..7b72584 100644
--- a/src/acpi/acpigen.c
+++ b/src/acpi/acpigen.c
@@ -408,7 +408,7 @@
* len is region length.
* OperationRegion(regionname, regionspace, regionoffset, regionlength)
*/
-void acpigen_write_opregion(struct opregion *opreg)
+void acpigen_write_opregion(const struct opregion *opreg)
{
/* OpregionOp */
acpigen_emit_ext_op(OPREGION_OP);
diff --git a/src/include/acpi/acpigen.h b/src/include/acpi/acpigen.h
index e0d95cd..d06d20c 100644
--- a/src/include/acpi/acpigen.h
+++ b/src/include/acpi/acpigen.h
@@ -429,7 +429,7 @@
* This function takes input region name, region space, region offset & region
* length.
*/
-void acpigen_write_opregion(struct opregion *opreg);
+void acpigen_write_opregion(const struct opregion *opreg);
/*
* Generate ACPI AML code for Mutex
* This function takes mutex name and initial value.
--
To view, visit https://review.coreboot.org/c/coreboot/+/46258
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id8cdfb4b3450a5ab2164ab048497324175b32269
Gerrit-Change-Number: 46258
Gerrit-PatchSet: 1
Gerrit-Owner: Duncan Laurie <dlaurie(a)chromium.org>
Gerrit-MessageType: newchange
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/libgfxinit/+/46625 )
Change subject: hw-gfx-gma: Use Broxton panel registers for CFL+
......................................................................
Patch Set 4:
(1 comment)
We just learned that Coffee Lake can be paired with a
200 series PCH. In this case, the current code would
match, but this change would break it.
So this asks for a more comprehensive solution. I'm
afraid, we'll have to add `PCH` type. Or maybe let's
call it `Chipset`? That would better apply to all
generations (also G45, and the small core SoCs). We
could have the chipset in Kconfig and derive the
generation from that internally.
https://review.coreboot.org/c/libgfxinit/+/46625/4/common/hw-gfx-gma.ads
File common/hw-gfx-gma.ads:
https://review.coreboot.org/c/libgfxinit/+/46625/4/common/hw-gfx-gma.ads@49
PS4, Line 49: Coffeelake);
Technically, the CPU works exactly the same as Kaby Lake.
--
To view, visit https://review.coreboot.org/c/libgfxinit/+/46625
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: libgfxinit
Gerrit-Branch: master
Gerrit-Change-Id: I389fa4fb81fab22ace2e75334184495134036ecb
Gerrit-Change-Number: 46625
Gerrit-PatchSet: 4
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-CC: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Comment-Date: Wed, 21 Oct 2020 22:13:58 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment