Philipp Deppenwiese has posted comments on this change. ( https://review.coreboot.org/27714 )
Change subject: security/vboot: Add failure safety configurations
......................................................................
Patch Set 4:
(4 comments)
https://review.coreboot.org/#/c/27714/1/src/security/vboot/Kconfig
File src/security/vboot/Kconfig:
https://review.coreboot.org/#/c/27714/1/src/security/vboot/Kconfig@53
PS1, Line 53: bool
> Can you outline your bigger plan with these MAINBOARD_... and USER_... […]
Easy peasy.
1) Users can decide for a Slot layout if not set by the board.
2) Slot layouts can be set by the board.
3) I will write an fmapgen tool for generating fmaps dynamically by kconfig input.
https://review.coreboot.org/#/c/27714/1/src/security/vboot/Kconfig@54
PS1, Line 54:
> nit: not sure I like calling this "safety", that seems a little far removed from what it actually co […]
Ack
https://review.coreboot.org/#/c/27714/1/src/security/vboot/Kconfig@57
PS1, Line 57:
> nit: I would avoid using the name "recovery" here since it means something specific and different in […]
Ack
https://review.coreboot.org/#/c/27714/1/src/security/vboot/Kconfig@71
PS1, Line 71: config USER_VBOOT_SLOTS_A
> Technically the "firmware" might consist of IFD and ME or other blobs, too. […]
Ack
--
To view, visit https://review.coreboot.org/27714
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I278fc060522b13048b00090b8e5261c14496f56e
Gerrit-Change-Number: 27714
Gerrit-PatchSet: 4
Gerrit-Owner: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Comment-Date: Sat, 11 Aug 2018 04:45:25 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: No
Philipp Deppenwiese has posted comments on this change. ( https://review.coreboot.org/28000 )
Change subject: src/mainboard/pcengines/apu2/Kconfig: select TPM2 option
......................................................................
Patch Set 2:
If you remove MAINBOARD_HAS_TPM1 then the user can decide which TPM is used via kconfig
--
To view, visit https://review.coreboot.org/28000
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ie9788c43d8b32b2f6329a072b88c962c34eca119
Gerrit-Change-Number: 28000
Gerrit-PatchSet: 2
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
Gerrit-Reviewer: Piotr Król <piotr.krol(a)3mdeb.com>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 11 Aug 2018 04:43:23 +0000
Gerrit-HasComments: No
Gerrit-HasLabels: No
Philipp Deppenwiese has posted comments on this change. ( https://review.coreboot.org/28000 )
Change subject: src/mainboard/pcengines/apu2/Kconfig: select TPM2 option
......................................................................
Patch Set 2:
Yo. That depends on the tpm module right?
--
To view, visit https://review.coreboot.org/28000
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ie9788c43d8b32b2f6329a072b88c962c34eca119
Gerrit-Change-Number: 28000
Gerrit-PatchSet: 2
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
Gerrit-Reviewer: Piotr Król <piotr.krol(a)3mdeb.com>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 11 Aug 2018 04:42:50 +0000
Gerrit-HasComments: No
Gerrit-HasLabels: No
Philipp Deppenwiese has submitted this change and it was merged. ( https://review.coreboot.org/21983 )
Change subject: drivers/pc80/tpm: add support for SLB9665 TPM2.0 module
......................................................................
drivers/pc80/tpm: add support for SLB9665 TPM2.0 module
SLB9665 are not initialized correctly. It looks like SLB9665 and SLB9660
return the same DEV ID. Initialize these devices according to TPM Kconfig
selections.
Tested on apu2 with following change:
https://review.coreboot.org/#/c/coreboot/+/28000/
Change-Id: Ic20b9a65ef6a4ee392a9352f7c9bf01b2496f482
Signed-off-by: Kamil Wcislo <kamil.wcislo(a)3mdeb.com>
Signed-off-by: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Reviewed-on: https://review.coreboot.org/21983
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Paul Menzel <paulepanter(a)users.sourceforge.net>
Reviewed-by: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
---
M src/drivers/pc80/tpm/tis.c
1 file changed, 2 insertions(+), 1 deletion(-)
Approvals:
build bot (Jenkins): Verified
Paul Menzel: Looks good to me, but someone else must approve
Philipp Deppenwiese: Looks good to me, approved
diff --git a/src/drivers/pc80/tpm/tis.c b/src/drivers/pc80/tpm/tis.c
index 67aff43..8c01ac3 100644
--- a/src/drivers/pc80/tpm/tis.c
+++ b/src/drivers/pc80/tpm/tis.c
@@ -125,10 +125,11 @@
static const struct device_name infineon_devices[] = {
{0x000b, "SLB9635 TT 1.2"},
- {0x001a, "SLB9660 TT 1.2"},
#if IS_ENABLED(CONFIG_TPM2)
+ {0x001a, "SLB9665 TT 2.0"},
{0x001b, "SLB9670 TT 2.0"},
#else
+ {0x001a, "SLB9660 TT 1.2"},
{0x001b, "SLB9670 TT 1.2"},
#endif
{0xffff}
--
To view, visit https://review.coreboot.org/21983
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: merged
Gerrit-Change-Id: Ic20b9a65ef6a4ee392a9352f7c9bf01b2496f482
Gerrit-Change-Number: 21983
Gerrit-PatchSet: 6
Gerrit-Owner: Kamil Wcisło <kamil.wcislo(a)3mdeb.com>
Gerrit-Reviewer: Kamil Wcisło <kamil.wcislo(a)3mdeb.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)users.sourceforge.net>
Gerrit-Reviewer: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
Gerrit-Reviewer: Piotr Król <piotr.krol(a)3mdeb.com>
Gerrit-Reviewer: Stefan Reinauer <stefan.reinauer(a)coreboot.org>
Gerrit-Reviewer: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Vadim Bendebury <vbendeb(a)chromium.org>
Gerrit-Reviewer: Vadim Bendebury <vbendeb(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Philipp Deppenwiese has posted comments on this change. ( https://review.coreboot.org/27672 )
Change subject: arch/x86/acpigen: refactor calls to acpigen_write_register
......................................................................
Patch Set 1: Code-Review+1
--
To view, visit https://review.coreboot.org/27672
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I10b336acf9f03c423bee9dc38955b1617e11c025
Gerrit-Change-Number: 27672
Gerrit-PatchSet: 1
Gerrit-Owner: Matt Delco <delco(a)chromium.org>
Gerrit-Reviewer: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 11 Aug 2018 04:36:45 +0000
Gerrit-HasComments: No
Gerrit-HasLabels: Yes
Philipp Deppenwiese has posted comments on this change. ( https://review.coreboot.org/28044 )
Change subject: .checkpatch.conf: Ignore a few more warnings
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://review.coreboot.org/28044
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I4b7fcfc0339b358a48e77188d85b47c022c7eb49
Gerrit-Change-Number: 28044
Gerrit-PatchSet: 1
Gerrit-Owner: Martin Roth <martinroth(a)google.com>
Gerrit-Reviewer: Philipp Deppenwiese <zaolin.daisuki(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Sat, 11 Aug 2018 04:28:39 +0000
Gerrit-HasComments: No
Gerrit-HasLabels: Yes