Attention is currently required from: Karthik Ramasubramanian, Subrata Banik.
Julius Werner has posted comments on this change by Subrata Banik. ( https://review.coreboot.org/c/coreboot/+/86225?usp=email )
Change subject: vc/google/chromeos: Add low battery indicator screen
......................................................................
Patch Set 6:
(1 comment)
File src/vendorcode/google/chromeos/Kconfig:
https://review.coreboot.org/c/coreboot/+/86225/comment/5ec94b6a_67942448?us… :
PS6, Line 105: config CHROMEOS_LOW_BATTERY_INDICATOR_SCREEN
I don't think these should be CHROMEOS options, since the code in the next patch is written like any platform can choose to implement these. I think these should probably go in `src/drivers/intel/fsp2_0/Kconfig` (maybe `PLATFORM_HAS_LOW_BATTERY_SHUTDOWN_INDICATOR` and `PLATFORM_HAS_LOW_BATTERY_SHUTDOWN_INDICATOR_EARLY`), and then the ChromeOS vendorcode will just add its logo and build in the platform callbacks if that option is selected.
--
To view, visit https://review.coreboot.org/c/coreboot/+/86225?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I711c53455639b449fe85903139bbc06cdab08d09
Gerrit-Change-Number: 86225
Gerrit-PatchSet: 6
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Julius Werner <jwerner(a)chromium.org>
Gerrit-CC: Jérémy Compostella <jeremy.compostella(a)intel.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Comment-Date: Fri, 07 Feb 2025 00:44:01 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Attention is currently required from: Dinesh Gehlot, Eran Mitrani, Intel coreboot Reviewers, Jakub "Kuba" Czapiga, Jayvik Desai, Kapil Porwal, Nick Vaccaro, Subrata Banik, Tarun.
Julius Werner has posted comments on this change by Subrata Banik. ( https://review.coreboot.org/c/coreboot/+/86283?usp=email )
Change subject: lib: Refactor ux_locales_get_text API
......................................................................
Patch Set 5:
(4 comments)
File src/include/ux_locales.h:
https://review.coreboot.org/c/coreboot/+/86283/comment/2e4b907e_cf83855e?us… :
PS5, Line 23: const char *ux_locales_get_text(const char *name, const char *fallback_text);
Why should we still keep this API around? I think we should switch everything to using IDs.
File src/lib/ux_locales.c:
https://review.coreboot.org/c/coreboot/+/86283/comment/5be5f0cc_6e3b221a?us… :
PS5, Line 28: "Please do not turn off your device."
nit: I don't think there's a point in `#define`ing these up here, rather than just putting them directly in the array initializer below (since they are only used once there).
https://review.coreboot.org/c/coreboot/+/86283/comment/6ae0184e_741be927?us… :
PS5, Line 32: enum ux_locale_msg locale_msg_id;
> Is locale_msg_id used ? […]
+1
https://review.coreboot.org/c/coreboot/+/86283/comment/cf66f950_f4a52db9?us… :
PS5, Line 213: switch (msg_id) {
> Could we have a `MAX_UX_LOCALE` to avoid having to add every single enum in this switch case stateme […]
+1
I'd call it `UX_LOCALE_MSG_NUM`, to retain the same prefix and since you probably want the number of entries (last ID + 1), rather than the maximum (last ID).
--
To view, visit https://review.coreboot.org/c/coreboot/+/86283?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I4952802396265b9ee8d164d6e43a7f2b3599d6c0
Gerrit-Change-Number: 86283
Gerrit-PatchSet: 5
Gerrit-Owner: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Dinesh Gehlot <digehlot(a)google.com>
Gerrit-Reviewer: Eran Mitrani <mitrani(a)google.com>
Gerrit-Reviewer: Intel coreboot Reviewers <intel_coreboot_reviewers(a)intel.com>
Gerrit-Reviewer: Jakub "Kuba" Czapiga <czapiga(a)google.com>
Gerrit-Reviewer: Jayvik Desai <jayvik(a)google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Reviewer: Tarun <tstuli(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Jérémy Compostella <jeremy.compostella(a)intel.com>
Gerrit-Attention: Jayvik Desai <jayvik(a)google.com>
Gerrit-Attention: Intel coreboot Reviewers <intel_coreboot_reviewers(a)intel.com>
Gerrit-Attention: Eran Mitrani <mitrani(a)google.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Jakub "Kuba" Czapiga <czapiga(a)google.com>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Attention: Dinesh Gehlot <digehlot(a)google.com>
Gerrit-Attention: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Attention: Tarun <tstuli(a)gmail.com>
Gerrit-Comment-Date: Fri, 07 Feb 2025 00:27:28 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Jérémy Compostella <jeremy.compostella(a)intel.com>
Attention is currently required from: Sean Rhodes.
Matt DeVillier has posted comments on this change by Sean Rhodes. ( https://review.coreboot.org/c/coreboot/+/86307?usp=email )
Change subject: mb/starlabs/starbook/mtl: Add rcomp configuration
......................................................................
Patch Set 2: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/86307?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If7a29bbd015d45eac178480ba6cae42912e25195
Gerrit-Change-Number: 86307
Gerrit-PatchSet: 2
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Comment-Date: Thu, 06 Feb 2025 22:42:19 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Attention is currently required from: Sean Rhodes.
Matt DeVillier has posted comments on this change by Sean Rhodes. ( https://review.coreboot.org/c/coreboot/+/86306?usp=email )
Change subject: mb/starlabs/starbook/mtl: Correct DIMM Speed Size
......................................................................
Patch Set 1: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/86306?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ic7b691104ff8b0061a485f01709a2f53046cc94a
Gerrit-Change-Number: 86306
Gerrit-PatchSet: 1
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Comment-Date: Thu, 06 Feb 2025 22:42:10 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Sean Rhodes has posted comments on this change by Sean Rhodes. ( https://review.coreboot.org/c/coreboot/+/86307?usp=email )
Change subject: mb/starlabs/starbook/mtl: Add rcomp configuration
......................................................................
Set Ready For Review
--
To view, visit https://review.coreboot.org/c/coreboot/+/86307?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If7a29bbd015d45eac178480ba6cae42912e25195
Gerrit-Change-Number: 86307
Gerrit-PatchSet: 2
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Thu, 06 Feb 2025 21:07:46 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Sean Rhodes has posted comments on this change by Sean Rhodes. ( https://review.coreboot.org/c/coreboot/+/86306?usp=email )
Change subject: mb/starlabs/starbook/mtl: Correct DIMM Speed Size
......................................................................
Set Ready For Review
--
To view, visit https://review.coreboot.org/c/coreboot/+/86306?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ic7b691104ff8b0061a485f01709a2f53046cc94a
Gerrit-Change-Number: 86306
Gerrit-PatchSet: 1
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Comment-Date: Thu, 06 Feb 2025 21:07:18 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No
Attention is currently required from: Jeremy Soller, Tim Crawford.
Sean Rhodes has posted comments on this change by Tim Crawford. ( https://review.coreboot.org/c/coreboot/+/50598?usp=email )
Change subject: intel/block/pcie/rtd3: Also implement _PR3
......................................................................
Patch Set 5: Code-Review+1
(1 comment)
Patchset:
PS5:
Maybe:
```
Previously, only _PR0 was specified, which allowed devices to enter D0.
Add _PR3 to allow the same devices to enter D3Cold, enabling proper runtime
power management for devices that support it.
```
--
To view, visit https://review.coreboot.org/c/coreboot/+/50598?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Id7f4373989dffe8c3bc68a034f59a94d2160dd15
Gerrit-Change-Number: 50598
Gerrit-PatchSet: 5
Gerrit-Owner: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Reviewer: Jeremy Soller <jeremy(a)system76.com>
Gerrit-Reviewer: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Attention: Jeremy Soller <jeremy(a)system76.com>
Gerrit-Comment-Date: Thu, 06 Feb 2025 20:50:54 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Attention is currently required from: Intel coreboot Reviewers, Patrick Rudolph, Vladimir Serbinenko.
Jérémy Compostella has posted comments on this change by Vladimir Serbinenko. ( https://review.coreboot.org/c/coreboot/+/86247?usp=email )
Change subject: intel/acpi: Put BSP as the first entry
......................................................................
Patch Set 6: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/86247?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I520a2e080c9f07a5866729ae2283990d20c0d691
Gerrit-Change-Number: 86247
Gerrit-PatchSet: 6
Gerrit-Owner: Vladimir Serbinenko <phcoder(a)gmail.com>
Gerrit-Reviewer: Intel coreboot Reviewers <intel_coreboot_reviewers(a)intel.com>
Gerrit-Reviewer: Jérémy Compostella <jeremy.compostella(a)intel.com>
Gerrit-Reviewer: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Jeremy Soller <jeremy(a)system76.com>
Gerrit-CC: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-CC: Tim Crawford <tcrawford(a)system76.com>
Gerrit-Attention: Intel coreboot Reviewers <intel_coreboot_reviewers(a)intel.com>
Gerrit-Attention: Patrick Rudolph <patrick.rudolph(a)9elements.com>
Gerrit-Attention: Vladimir Serbinenko <phcoder(a)gmail.com>
Gerrit-Comment-Date: Thu, 06 Feb 2025 20:42:12 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Sean Rhodes has posted comments on this change by Sean Rhodes. ( https://review.coreboot.org/c/coreboot/+/86305?usp=email )
Change subject: ec/starlabs/merlin: Add an option to disabled the lid switch
......................................................................
Set Ready For Review
--
To view, visit https://review.coreboot.org/c/coreboot/+/86305?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I1dd666a44b332ffbbef4420799eeffd746fd1664
Gerrit-Change-Number: 86305
Gerrit-PatchSet: 1
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Comment-Date: Thu, 06 Feb 2025 20:32:48 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No