Attention is currently required from: Hope Wang, Hung-Te Lin, Jarried Lin.
Yu-Ping Wu has posted comments on this change by Jarried Lin. ( https://review.coreboot.org/c/coreboot/+/85630?usp=email )
Change subject: soc/mediatek/mt8196: Add PMIC MT6316 driver
......................................................................
Patch Set 9:
(7 comments)
File src/soc/mediatek/common/mt6316.c:
https://review.coreboot.org/c/coreboot/+/85630/comment/cb23bbb9_39015139?us… :
PS3, Line 202: mt6316_wdt_enable(SPMI_SLAVE_6);
: mt6316_wdt_enable(SPMI_SLAVE_7);
: mt6316_wdt_enable(SPMI_SLAVE_8);
: mt6316_wdt_enable(SPMI_SLAVE_15);
:
> mt6316_init_setting not have only slave id, but also init_setting array, do we need to optimize thes […]
PS9 looks good to me!
File src/soc/mediatek/common/mt6316.c:
https://review.coreboot.org/c/coreboot/+/85630/comment/c23a591a_49d8d092?us… :
PS9, Line 20: read16
This should be `read` (which is for reading 1 byte). `read16` is for reading 2 bytes. Also see b/381782630 for future refactoring. For now, the data argument of `read()` is u32, so we should write:
```
u32 data = 0;
assert(...);
pmif_arb->read(..., &data);
return (u8)data;
```
https://review.coreboot.org/c/coreboot/+/85630/comment/1202dc64_b1298515?us… :
PS9, Line 114: vol * 5000 + vol_l * 2500
Use a local variable to to store this.
https://review.coreboot.org/c/coreboot/+/85630/comment/520c11b7_ae2f87a7?us… :
PS9, Line 118: mode
Does this mean enable/disable? Can we rename this to `enable`?
https://review.coreboot.org/c/coreboot/+/85630/comment/d8370d15_f63655f3?us… :
PS9, Line 161: mod = mt6316_read8(slvid, MT6316_BUCK_TOP_4PHASE_TOP_ANA_CON0);
: mod >>= mod_shift;
: mod &= 0x1;
Isn't this `mod = mt6316_read_field(slvid, MT6316_BUCK_TOP_4PHASE_TOP_ANA_CON0, 0x1, mod_shift)`?
https://review.coreboot.org/c/coreboot/+/85630/comment/721277e1_ab7ee4be?us… :
PS9, Line 165: mod ? true : false
`!!mod`
https://review.coreboot.org/c/coreboot/+/85630/comment/2ea5958e_28717afb?us… :
PS9, Line 186: mt6316_slave_id[i], mt6316_read_field(mt6316_slave_id[i],
: MT6316_PMIC_SWCID_H_ADDR, 0xFF, 0x0));
```
mt6316_slave_id[i],
mt6316_read_field(mt6316_slave_id[i], MT6316_PMIC_SWCID_H_ADDR,
0xFF, 0x0));
```
--
To view, visit https://review.coreboot.org/c/coreboot/+/85630?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I39e91d64e77cff03281845dfbea565e6ddf748f6
Gerrit-Change-Number: 85630
Gerrit-PatchSet: 9
Gerrit-Owner: Jarried Lin <jarried.lin(a)mediatek.com>
Gerrit-Reviewer: Hope Wang <hope.wang(a)mediatek.corp-partner.google.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Hope Wang <hope.wang(a)mediatek.corp-partner.google.com>
Gerrit-Attention: Jarried Lin <jarried.lin(a)mediatek.com>
Gerrit-Comment-Date: Mon, 23 Dec 2024 08:05:39 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Hope Wang <hope.wang(a)mediatek.corp-partner.google.com>
Comment-In-Reply-To: Yu-Ping Wu <yupingso(a)google.com>
Elyes Haouas has uploaded a new patch set (#2). ( https://review.coreboot.org/c/coreboot/+/85732?usp=email )
Change subject: [OpenSBI is a pain! ]Update opensbi submodule to upstream master
......................................................................
[OpenSBI is a pain! ]Update opensbi submodule to upstream master
Updating from commit id 5019fd124b4c:
2022-09-01 16:53:28 +0530 - (include: sbi: Reduce includes in sbi_pmu.h)
to commit id d539d64a23bb:
2024-12-21 21:38:50 +0530 - (include: sbi: Fix compiling with C23 enabled compilers)
This brings in 709 new commits.
Change-Id: Ic050c7b8dc2e202ee3b7fe07c749181c0845f0e7
Signed-off-by: Elyes Haouas <ehaouas(a)noos.fr>
---
M 3rdparty/opensbi
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/32/85732/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/85732?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Ic050c7b8dc2e202ee3b7fe07c749181c0845f0e7
Gerrit-Change-Number: 85732
Gerrit-PatchSet: 2
Gerrit-Owner: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Attention is currently required from: Felix Singer, Martin L Roth, Paul Menzel.
Elyes Haouas has posted comments on this change by Elyes Haouas. ( https://review.coreboot.org/c/coreboot/+/84074?usp=email )
Change subject: xcompile: Use Walloc-size GCC option
......................................................................
Patch Set 17:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/84074/comment/44365c60_2425b0dc?us… :
PS15, Line 11: introduced
> move into next line
Done
--
To view, visit https://review.coreboot.org/c/coreboot/+/84074?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If5d36b073bb5b4cccb0cf2b67b43edb3f97f168c
Gerrit-Change-Number: 84074
Gerrit-PatchSet: 17
Gerrit-Owner: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Comment-Date: Mon, 23 Dec 2024 07:54:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Attention is currently required from: Elyes Haouas, Martin L Roth, Paul Menzel.
Hello Martin L Roth, build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/84074?usp=email
to look at the new patch set (#17).
Change subject: xcompile: Use Walloc-size GCC option
......................................................................
xcompile: Use Walloc-size GCC option
Warn about allocation function calls with insufficient size for the
target type of the pointer.
commit 6ab188ee6c99 ("Makefile.mk: Use Walloc-size GCC option")
introduced this GCC option, then commit d05fe9fd3ce9 ("Revert
Makefile.mk:Use Localiser GCC option") reverted it because older GCC
versions did not support it.
This change re-enables it for modern GCC versions.
Change-Id: If5d36b073bb5b4cccb0cf2b67b43edb3f97f168c
Signed-off-by: Elyes Haouas <ehaouas(a)noos.fr>
---
M util/xcompile/xcompile
1 file changed, 3 insertions(+), 0 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/74/84074/17
--
To view, visit https://review.coreboot.org/c/coreboot/+/84074?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: newpatchset
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: If5d36b073bb5b4cccb0cf2b67b43edb3f97f168c
Gerrit-Change-Number: 84074
Gerrit-PatchSet: 17
Gerrit-Owner: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Elyes Haouas <ehaouas(a)noos.fr>
Attention is currently required from: Hung-Te Lin, Paul Menzel, Vince Liu, Yidi Lin.
Yu-Ping Wu has posted comments on this change by Vince Liu. ( https://review.coreboot.org/c/coreboot/+/85689?usp=email )
Change subject: soc/mediatek/mt8189: Enable timer compensation v2.5
......................................................................
Patch Set 4: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/85689?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I28c051c2e51481464f5dacb4c93f41e4f7e62501
Gerrit-Change-Number: 85689
Gerrit-PatchSet: 4
Gerrit-Owner: Vince Liu <vince-wl.liu(a)mediatek.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Vince Liu <vince-wl.liu(a)mediatek.com>
Gerrit-Attention: Yidi Lin <yidilin(a)google.com>
Gerrit-Comment-Date: Mon, 23 Dec 2024 07:37:46 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Yu-Ping Wu has submitted this change. ( https://review.coreboot.org/c/coreboot/+/85723?usp=email )
Change subject: soc/mediatek/mt8189: Replace SPDX identifiers to GPL-2.0-only OR MIT
......................................................................
soc/mediatek/mt8189: Replace SPDX identifiers to GPL-2.0-only OR MIT
These files were originally from MediaTek and follow coreboot's main
license: "GPL-2.0-only". Now MediaTek replaces this file to
"GPL-2.0-only OR MIT" license for better code re-use in other open
source software stack.
BUG=b:379008996
BRANCH=none
TEST=build pass
Change-Id: I2821a8c097b8d22e1aa91b316ae0fdce80f342de
Signed-off-by: Vince Liu <vince-wl.liu(a)mediatek.corp-partner.google.com>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/85723
Reviewed-by: Yidi Lin <yidilin(a)google.com>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Yu-Ping Wu <yupingso(a)google.com>
---
M src/soc/mediatek/mt8189/timer.c
1 file changed, 1 insertion(+), 1 deletion(-)
Approvals:
Yidi Lin: Looks good to me, approved
Yu-Ping Wu: Looks good to me, approved
build bot (Jenkins): Verified
diff --git a/src/soc/mediatek/mt8189/timer.c b/src/soc/mediatek/mt8189/timer.c
index 2f299ea..c010d58 100644
--- a/src/soc/mediatek/mt8189/timer.c
+++ b/src/soc/mediatek/mt8189/timer.c
@@ -1,4 +1,4 @@
-/* SPDX-License-Identifier: GPL-2.0-only */
+/* SPDX-License-Identifier: GPL-2.0-only OR MIT */
/*
* This file is created based on MT8189 Functional Specification
--
To view, visit https://review.coreboot.org/c/coreboot/+/85723?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: merged
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I2821a8c097b8d22e1aa91b316ae0fdce80f342de
Gerrit-Change-Number: 85723
Gerrit-PatchSet: 2
Gerrit-Owner: Vince Liu <vince-wl.liu(a)mediatek.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Attention is currently required from: Felix Singer, Hung-Te Lin, Vince Liu.
Yu-Ping Wu has posted comments on this change by Vince Liu. ( https://review.coreboot.org/c/coreboot/+/85723?usp=email )
Change subject: soc/mediatek/mt8189: Replace SPDX identifiers to GPL-2.0-only OR MIT
......................................................................
Patch Set 1: Code-Review+2
(1 comment)
File src/soc/mediatek/mt8189/timer.c:
https://review.coreboot.org/c/coreboot/+/85723/comment/4fdf64f2_9e857c3a?us… :
PS1, Line 1: OR MIT
> I think that is okay. Here is the example from [Linux kernel](https://docs.kernel. […]
The license compatibility doesn't matter here. The license owners are allowed to re-license the file to whatever license (if that conforms to coreboot's requirement). In this case, this file was created by Vince Liu and never touched by other people, so Vince Liu can definitely re-license it.
Also see a previous example of re-licensing old files: CB:66625.
--
To view, visit https://review.coreboot.org/c/coreboot/+/85723?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I2821a8c097b8d22e1aa91b316ae0fdce80f342de
Gerrit-Change-Number: 85723
Gerrit-PatchSet: 1
Gerrit-Owner: Vince Liu <vince-wl.liu(a)mediatek.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Gerrit-Attention: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Vince Liu <vince-wl.liu(a)mediatek.com>
Gerrit-Comment-Date: Mon, 23 Dec 2024 07:36:35 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Comment-In-Reply-To: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Comment-In-Reply-To: Vince Liu <vince-wl.liu(a)mediatek.com>
Attention is currently required from: Hung-Te Lin, Jarried Lin, Yidi Lin.
Yu-Ping Wu has posted comments on this change by Jarried Lin. ( https://review.coreboot.org/c/coreboot/+/85717?usp=email )
Change subject: mb/google/rauru: Add support for getting storage id
......................................................................
Patch Set 3:
(1 comment)
File src/mainboard/google/rauru/storage.h:
https://review.coreboot.org/c/coreboot/+/85717/comment/eae631fb_73abb725?us… :
PS1, Line 5:
> Can we add another function `storage_type()` to return that enum? I think the UFS driver in mtk-fsp […]
Update?
--
To view, visit https://review.coreboot.org/c/coreboot/+/85717?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I036df324cd6644ff69110c6247af29360b83225f
Gerrit-Change-Number: 85717
Gerrit-PatchSet: 3
Gerrit-Owner: Jarried Lin <jarried.lin(a)mediatek.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yidi Lin <yidilin(a)google.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Knox Chiou <knoxchiou(a)google.com>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Jarried Lin <jarried.lin(a)mediatek.com>
Gerrit-Attention: Yidi Lin <yidilin(a)google.com>
Gerrit-Comment-Date: Mon, 23 Dec 2024 07:30:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Yu-Ping Wu <yupingso(a)google.com>
Comment-In-Reply-To: Yidi Lin <yidilin(a)google.com>
Attention is currently required from: Dinesh Gehlot, Eric Lai, Jayvik Desai, Kapil Porwal, Nick Vaccaro, Subrata Banik.
Luca Lai has posted comments on this change by Luca Lai. ( https://review.coreboot.org/c/coreboot/+/85735?usp=email )
Change subject: mb/google/nissa/var/pujjo: Add new supported memory part
......................................................................
Patch Set 3:
This change is ready for review.
--
To view, visit https://review.coreboot.org/c/coreboot/+/85735?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings?usp=email
Gerrit-MessageType: comment
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Idb48e849424aac79ef9af29f21b84194455c813e
Gerrit-Change-Number: 85735
Gerrit-PatchSet: 3
Gerrit-Owner: Luca Lai <luca.lai(a)lcfc.corp-partner.google.com>
Gerrit-Reviewer: Dinesh Gehlot <digehlot(a)google.com>
Gerrit-Reviewer: Eric Lai <ericllai(a)google.com>
Gerrit-Reviewer: Jayvik Desai <jayvik(a)google.com>
Gerrit-Reviewer: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jayvik Desai <jayvik(a)google.com>
Gerrit-Attention: Eric Lai <ericllai(a)google.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Attention: Dinesh Gehlot <digehlot(a)google.com>
Gerrit-Attention: Nick Vaccaro <nvaccaro(a)chromium.org>
Gerrit-Comment-Date: Mon, 23 Dec 2024 07:21:30 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: No