Attention is currently required from: Matt DeVillier.
Felix Singer has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/80141?usp=email )
Change subject: mb/google/puff: Baseboard devicetree clean up #1
......................................................................
Patch Set 1: Code-Review+2
(1 comment)
File src/mainboard/google/puff/variants/baseboard/devicetree.cb:
https://review.coreboot.org/c/coreboot/+/80141/comment/01c1877f_29b8b266 :
PS1, Line 321: device ref p2sb on end
AFAIK P2SB is hidden by the FSP, that's why we set it in chipset.cb
--
To view, visit https://review.coreboot.org/c/coreboot/+/80141?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I3a515f13df1252ed2b769a535da22a523c95c359
Gerrit-Change-Number: 80141
Gerrit-PatchSet: 1
Gerrit-Owner: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Comment-Date: Fri, 26 Jan 2024 15:14:42 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Felix Singer has submitted this change. ( https://review.coreboot.org/c/coreboot/+/80182?usp=email )
(
1 is the latest approved patch-set.
No files were changed between the latest approved patch-set and the submitted one.
)Change subject: mb/purism/librem_cnl: Set edk2 boot timeout for Librem Mini
......................................................................
mb/purism/librem_cnl: Set edk2 boot timeout for Librem Mini
As with other devices with only an external display, the Librem mini/
mini-v2 need a few extra seconds (vs an internal panel) for display init in order for the edk2 boot splash to be visible before the
default boot target is booted.
TEST=build/boot Librem Mini v2 w/edk2 payload, verify splash screen
shown / user has time to enter setup menu.
Change-Id: I9d2d514719a9918ee58cc63969b3adae44ac1632
Signed-off-by: Matt DeVillier <matt.devillier(a)gmail.com>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/80182
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Jonathon Hall <jonathon.hall(a)puri.sm>
---
M src/mainboard/purism/librem_cnl/Kconfig
1 file changed, 4 insertions(+), 0 deletions(-)
Approvals:
Jonathon Hall: Looks good to me, approved
build bot (Jenkins): Verified
diff --git a/src/mainboard/purism/librem_cnl/Kconfig b/src/mainboard/purism/librem_cnl/Kconfig
index f75f316..1628ec6 100644
--- a/src/mainboard/purism/librem_cnl/Kconfig
+++ b/src/mainboard/purism/librem_cnl/Kconfig
@@ -112,3 +112,7 @@
U81 on the bottom of the board near the front edge; the IC is not
populated. TX is pin 14, RX is pin 19. The signals are 3.3V (do NOT
connect directly to an RS-232 serial port).
+
+config EDK2_BOOT_TIMEOUT
+ int
+ default 4 if BOARD_PURISM_LIBREM_MINI || BOARD_PURISM_LIBREM_MINI_V2
--
To view, visit https://review.coreboot.org/c/coreboot/+/80182?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I9d2d514719a9918ee58cc63969b3adae44ac1632
Gerrit-Change-Number: 80182
Gerrit-PatchSet: 3
Gerrit-Owner: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: Felix Singer <service+coreboot-gerrit(a)felixsinger.de>
Gerrit-Reviewer: Jonathon Hall <jonathon.hall(a)puri.sm>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: merged
Attention is currently required from: Fred Reitberger, Jason Glenesk, Matt DeVillier.
Hello Fred Reitberger, Jason Glenesk, Matt DeVillier,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/80218?usp=email
to look at the new patch set (#2).
Change subject: soc/amd: use expected function signature for soc_acpi_write_tables
......................................................................
soc/amd: use expected function signature for soc_acpi_write_tables
A pointer to soc_acpi_write_tables gets assigned to the
write_acpi_tables element of the device_operations struct, so make sure
that the function has the expected function signature which in this case
means using unsigned long as type for both the 'current' parameter and
the return value.
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
Change-Id: Iee45badb904fa20c6db146edbc00c40ca09361d1
---
M src/soc/amd/cezanne/agesa_acpi.c
M src/soc/amd/cezanne/include/soc/acpi.h
M src/soc/amd/glinda/agesa_acpi.c
M src/soc/amd/glinda/include/soc/acpi.h
M src/soc/amd/mendocino/agesa_acpi.c
M src/soc/amd/mendocino/include/soc/acpi.h
M src/soc/amd/phoenix/agesa_acpi.c
M src/soc/amd/phoenix/include/soc/acpi.h
M src/soc/amd/picasso/agesa_acpi.c
M src/soc/amd/picasso/include/soc/acpi.h
10 files changed, 20 insertions(+), 20 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/18/80218/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/80218?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: Iee45badb904fa20c6db146edbc00c40ca09361d1
Gerrit-Change-Number: 80218
Gerrit-PatchSet: 2
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Fred Reitberger, Jason Glenesk, Matt DeVillier.
Hello Fred Reitberger, Jason Glenesk, Matt DeVillier,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/80217?usp=email
to look at the new patch set (#2).
Change subject: soc/amd: rename agesa_write_acpi_tables to soc_acpi_write_tables
......................................................................
soc/amd: rename agesa_write_acpi_tables to soc_acpi_write_tables
It's not the AGESA code that generates most of the ACPI tables, so
rename the function. This also aligns the other SoCs more with Genoa.
Signed-off-by: Felix Held <felix-coreboot(a)felixheld.de>
Change-Id: I6b2e6c4cb7139c8bde01b4440ab2e923a1086827
---
M src/soc/amd/cezanne/agesa_acpi.c
M src/soc/amd/cezanne/chip.c
M src/soc/amd/cezanne/include/soc/acpi.h
M src/soc/amd/glinda/agesa_acpi.c
M src/soc/amd/glinda/chip.c
M src/soc/amd/glinda/include/soc/acpi.h
M src/soc/amd/mendocino/agesa_acpi.c
M src/soc/amd/mendocino/chip.c
M src/soc/amd/mendocino/include/soc/acpi.h
M src/soc/amd/phoenix/agesa_acpi.c
M src/soc/amd/phoenix/chip.c
M src/soc/amd/phoenix/include/soc/acpi.h
M src/soc/amd/picasso/agesa_acpi.c
M src/soc/amd/picasso/chip.c
M src/soc/amd/picasso/include/soc/acpi.h
M src/soc/amd/stoneyridge/northbridge.c
16 files changed, 29 insertions(+), 29 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/17/80217/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/80217?usp=email
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: main
Gerrit-Change-Id: I6b2e6c4cb7139c8bde01b4440ab2e923a1086827
Gerrit-Change-Number: 80217
Gerrit-PatchSet: 2
Gerrit-Owner: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-MessageType: newpatchset