Attention is currently required from: Konrad Adamczyk, Jason Glenesk, Raul Rangel, Jakub Czapiga, Matt DeVillier, Paul Menzel, Grzegorz Bernacki, Arthur Heymans, Fred Reitberger, Karthik Ramasubramanian, Felix Held.
Tim Van Patten has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/74777 )
Change subject: soc/amd/common/block/cpu: Add missing cbfs_unmap()
......................................................................
Patch Set 3:
(2 comments)
File src/soc/amd/common/block/cpu/update_microcode.c:
https://review.coreboot.org/c/coreboot/+/74777/comment/99ede524_92b71690
PS3, Line 102: goto end;
I don't think we need a `goto` here, and is hurting readability more than helping simplify the code. I prefer `cbfs_unmap()` with `return` instead, especially since it's branching into the middle of a conditional block.
https://review.coreboot.org/c/coreboot/+/74777/comment/57bb888c_8aa3c208
PS3, Line 113: cbfs_unmap((void *)ucode);
While the `>=` was added to make it more likely that this is called eventually, it also means it's possible for multiple CPUs to execute `cbfs_unmap()` at the same time, corrupting the CBFS cache data structures.
There are a few things here:
1. This should be reverted back to `==`, so it's performed exactly once.
2. We should crash if we see `> get_cpu_count()`, since that indicates we've hit a (likely) fatal error.
3. The access to `ucode` needs to be within an semaphore that's incremented by every reader, so it's only freed once all current readers have completed.
* The `== get_cpu_count()` will need to block until all readers are done, since it's the only one that can safely call `cbfs_unmap()`.
* Otherwise, if the `> get_cpu_count()` case occurs, it's possible for CPUs to be loading microcode while the cache is being freed (and the memory potentially reused, meaning the microcode binary being loaded isn't actually microcode, but "random" data).
* If we ignore the `> get_cpu_count()` case, then we can skip this step, since the atomic counter should be enough to prevent freeing the `ucode` memory until everyone is done with it.
I'm not sure how possible `> get_cpu_count()` is, though. Ideally, we could catch that when releasing the other CPUs (before getting here?), but I don't know the details well enough.
--
To view, visit https://review.coreboot.org/c/coreboot/+/74777
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I200d24df6157cc6d06bade34809faefea9f0090a
Gerrit-Change-Number: 74777
Gerrit-PatchSet: 3
Gerrit-Owner: Grzegorz Bernacki
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Konrad Adamczyk <konrada(a)google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: Tim Van Patten <timvp(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Konrad Adamczyk <konrada(a)google.com>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Grzegorz Bernacki
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Fri, 28 Apr 2023 16:05:14 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Sean Rhodes, Christian Walter, Angel Pons, Maximilian Brune, Lean Sheng Tan.
Benjamin Doron has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/74122 )
Change subject: [WIP] mb/prodrive/atlas: Put options in CFR cbtable
......................................................................
Patch Set 2:
(1 comment)
File src/mainboard/prodrive/atlas/cfr.c:
https://review.coreboot.org/c/coreboot/+/74122/comment/f2faf64e_f3f65c62
PS2, Line 123: .ui_helptext = "Specify what to do when power is re-applied "
: "after a power loss. This option has no effect "
: "on systems without a RTC battery.", /* TODO: check */
:
The help text is correct, to my knowledge. The RTC power well is the deepest (as in, lowest power), without a battery the PMC cannot preserve volatile registers.
Can we synchronise the default value with the Kconfig? Unfortunately, no actual Kconfig to use, so a ternary expression would do: `CONFIG(POWER_STATE_OFF_AFTER_FAILURE) ? MAINBOARD_POWER_STATE_OFF : MAINBOARD_POWER_STATE_ON`
--
To view, visit https://review.coreboot.org/c/coreboot/+/74122
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I47585a9a6f94ab5005f2ab63a0df267c0caef231
Gerrit-Change-Number: 74122
Gerrit-PatchSet: 2
Gerrit-Owner: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Benjamin Doron <benjamin.doron00(a)gmail.com>
Gerrit-Reviewer: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Reviewer: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Reviewer: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Attention: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Attention: Christian Walter <christian.walter(a)9elements.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Attention: Maximilian Brune <maximilian.brune(a)9elements.com>
Gerrit-Attention: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Comment-Date: Fri, 28 Apr 2023 16:01:35 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Jonathan Zhang, Arthur Heymans.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/67018 )
Change subject: device/allocator: Allow for multiple domain resources of a type
......................................................................
Patch Set 6:
(2 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/67018/comment/7390f543_0c0206d9
PS6, Line 11: bridge devices
Above it's domains, here bridge devices in general oO
So far I don't understand why we should change something for all
bridge resources and not only the domains. If it was only done to
keep the code for domain and bridge resources aligned, CB:65420
tries to detangle them anyway (it used to be next in the relation
chain right after the one we had to revert :-/).
File src/device/resource_allocator_v4.c:
https://review.coreboot.org/c/coreboot/+/67018/comment/3b140d4e_20e2164f
PS6, Line 178: update_bridge_resource(bridge, res, type_match, print_depth);
In there we'll filter child resources based on the type. If we had multiple bridge
resources of the same type, we'd account for every child resource multiple times?
--
To view, visit https://review.coreboot.org/c/coreboot/+/67018
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3d3a60c9a4438accdb06444e2b50cc9b0b2eb009
Gerrit-Change-Number: 67018
Gerrit-PatchSet: 6
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Jonathan Zhang <jon.zhixiong.zhang(a)gmail.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Varshit Pandya <pandyavarshit(a)gmail.com>
Gerrit-Attention: Jonathan Zhang <jon.zhixiong.zhang(a)gmail.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Fri, 28 Apr 2023 15:58:26 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Martin L Roth has submitted this change. ( https://review.coreboot.org/c/coreboot/+/74241 )
Change subject: mb/starlabs/starbook/adl: Correct the number of NID entries
......................................................................
mb/starlabs/starbook/adl: Correct the number of NID entries
The number of NID entries was too high for the Realtek
and Intel sound cards, preventing the verb table from
loading. Now the values are correct; it loads as intended.
Signed-off-by: Sean Rhodes <sean(a)starlabs.systems>
Change-Id: I79825313a4801c120a0a2a321cbabab7c728aa71
Reviewed-on: https://review.coreboot.org/c/coreboot/+/74241
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Matt DeVillier <matt.devillier(a)gmail.com>
---
M src/mainboard/starlabs/starbook/variants/adl/hda_verb.c
1 file changed, 19 insertions(+), 2 deletions(-)
Approvals:
build bot (Jenkins): Verified
Matt DeVillier: Looks good to me, approved
diff --git a/src/mainboard/starlabs/starbook/variants/adl/hda_verb.c b/src/mainboard/starlabs/starbook/variants/adl/hda_verb.c
index a234de1..c2d10ed 100644
--- a/src/mainboard/starlabs/starbook/variants/adl/hda_verb.c
+++ b/src/mainboard/starlabs/starbook/variants/adl/hda_verb.c
@@ -7,7 +7,7 @@
/* coreboot specific header */
0x10ec0269, /* Codec Vendor / Device ID: Realtek ALC269 */
0x1e507007, /* Subsystem ID */
- 36, /* Number of jacks (NID entries) */
+ 17, /* Number of jacks (NID entries) */
/* Reset Codec First */
AZALIA_RESET(0x1),
@@ -54,7 +54,7 @@
0x80862815, /* Codec Vendor / Device ID: Intel */
0x80860101, /* Subsystem ID */
- 9, /* Number of 4 dword sets */
+ 10, /* Number of 4 dword sets */
AZALIA_SUBVENDOR(2, 0x80860101),
--
To view, visit https://review.coreboot.org/c/coreboot/+/74241
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I79825313a4801c120a0a2a321cbabab7c728aa71
Gerrit-Change-Number: 74241
Gerrit-PatchSet: 4
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: merged
Martin L Roth has submitted this change. ( https://review.coreboot.org/c/coreboot/+/74744 )
Change subject: ec/starlabs/merlin: Change the fallback value for fn_ctrl_swap
......................................................................
ec/starlabs/merlin: Change the fallback value for fn_ctrl_swap
Change the fallback value of the `fn_ctrl_swap` option to 0, which
is disabled.
Signed-off-by: Sean Rhodes <sean(a)starlabs.systems>
Change-Id: I9fcbb497f14ed0c97ff05c6c01a3929522786781
Reviewed-on: https://review.coreboot.org/c/coreboot/+/74744
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Lean Sheng Tan <sheng.tan(a)9elements.com>
---
M src/ec/starlabs/merlin/ite.c
1 file changed, 17 insertions(+), 1 deletion(-)
Approvals:
build bot (Jenkins): Verified
Lean Sheng Tan: Looks good to me, approved
diff --git a/src/ec/starlabs/merlin/ite.c b/src/ec/starlabs/merlin/ite.c
index 9730647..0f807de 100644
--- a/src/ec/starlabs/merlin/ite.c
+++ b/src/ec/starlabs/merlin/ite.c
@@ -174,7 +174,7 @@
ec_write(ECRAM_FN_CTRL_REVERSE,
get_ec_value_from_option("fn_ctrl_swap",
- 1,
+ 0,
fn_ctrl_swap,
ARRAY_SIZE(fn_ctrl_swap)));
--
To view, visit https://review.coreboot.org/c/coreboot/+/74744
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I9fcbb497f14ed0c97ff05c6c01a3929522786781
Gerrit-Change-Number: 74744
Gerrit-PatchSet: 2
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: merged
Martin L Roth has submitted this change. ( https://review.coreboot.org/c/coreboot/+/74186 )
Change subject: ec/starlabs/merlin/acpi: Don't attempt to change EC values
......................................................................
ec/starlabs/merlin/acpi: Don't attempt to change EC values
The EC will constantly update the battery variables approximately
every 60 seconds; they should be used unmodified, rather than
trying to change them.
Signed-off-by: Sean Rhodes <sean(a)starlabs.systems>
Change-Id: I3cff0ac6a322018cbca33b5f90dd62b3475da25c
Reviewed-on: https://review.coreboot.org/c/coreboot/+/74186
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Lean Sheng Tan <sheng.tan(a)9elements.com>
---
M src/ec/starlabs/merlin/acpi/battery.asl
1 file changed, 17 insertions(+), 3 deletions(-)
Approvals:
build bot (Jenkins): Verified
Lean Sheng Tan: Looks good to me, approved
diff --git a/src/ec/starlabs/merlin/acpi/battery.asl b/src/ec/starlabs/merlin/acpi/battery.asl
index 12aaa74..abdcc5b 100644
--- a/src/ec/starlabs/merlin/acpi/battery.asl
+++ b/src/ec/starlabs/merlin/acpi/battery.asl
@@ -34,9 +34,6 @@
Method (_BIF, 0, Serialized)
{
BPKG[1] = B1DC
- If (B1FC >= B1DC) {
- B1FC = B1DC
- }
BPKG[2] = B1FC
BPKG[4] = B1DV
If (B1FC)
--
To view, visit https://review.coreboot.org/c/coreboot/+/74186
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3cff0ac6a322018cbca33b5f90dd62b3475da25c
Gerrit-Change-Number: 74186
Gerrit-PatchSet: 3
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: merged
Martin L Roth has submitted this change. ( https://review.coreboot.org/c/coreboot/+/74738 )
Change subject: mb/starlabs/starbook/adl: Correct port for Hot Plug
......................................................................
mb/starlabs/starbook/adl: Correct port for Hot Plug
Commit 5103b87a4d7b ("mb/starlabs/starbook/adl: Add an option to
enable Hot Plug") introduced an option to enable Hot Plug for the
SSD. The port was set to 4 (RP5) which is the wireless card. Change
this to 8 (RP9) which is the SSD.
Signed-off-by: Sean Rhodes <sean(a)starlabs.systems>
Change-Id: I884f4997d73e31bd422477952466f168afad66a1
Reviewed-on: https://review.coreboot.org/c/coreboot/+/74738
Reviewed-by: Paul Menzel <paulepanter(a)mailbox.org>
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Lean Sheng Tan <sheng.tan(a)9elements.com>
---
M src/mainboard/starlabs/starbook/variants/adl/ramstage.c
1 file changed, 20 insertions(+), 1 deletion(-)
Approvals:
build bot (Jenkins): Verified
Paul Menzel: Looks good to me, but someone else must approve
Lean Sheng Tan: Looks good to me, approved
diff --git a/src/mainboard/starlabs/starbook/variants/adl/ramstage.c b/src/mainboard/starlabs/starbook/variants/adl/ramstage.c
index 7accb1d..a2c3926 100644
--- a/src/mainboard/starlabs/starbook/variants/adl/ramstage.c
+++ b/src/mainboard/starlabs/starbook/variants/adl/ramstage.c
@@ -11,5 +11,5 @@
* third-party drives are detected.
*/
if (get_uint_option("pci_hot_plug", 0) == 1)
- supd->PcieRpHotPlug[4] = 1;
+ supd->PcieRpHotPlug[8] = 1;
}
--
To view, visit https://review.coreboot.org/c/coreboot/+/74738
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I884f4997d73e31bd422477952466f168afad66a1
Gerrit-Change-Number: 74738
Gerrit-PatchSet: 4
Gerrit-Owner: Sean Rhodes <sean(a)starlabs.systems>
Gerrit-Reviewer: Lean Sheng Tan <sheng.tan(a)9elements.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: merged