Attention is currently required from: Arthur Heymans, Kyösti Mälkki.
Jonathan Zhang has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/64341 )
Change subject: cpu/x86/mp_init.c: Use existing code to create cpu struct device
......................................................................
Patch Set 8: Code-Review+2
--
To view, visit https://review.coreboot.org/c/coreboot/+/64341
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I80baadd405b31d6be2fdbb894b0f4b7c775da6f8
Gerrit-Change-Number: 64341
Gerrit-PatchSet: 8
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Reviewer: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-CC: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Attention: Kyösti Mälkki <kyosti.malkki(a)gmail.com>
Gerrit-Comment-Date: Thu, 03 Nov 2022 22:01:23 +0000
Gerrit-HasComments: No
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Arthur Heymans.
Felix Held has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69109 )
Change subject: cpu/x86/mp_init.c: Handle failed init_bsp()
......................................................................
Patch Set 2: Code-Review+2
(1 comment)
Patchset:
PS2:
took me a while to figure out how the data that gets checked with info->index != 0 ends up being at the place where we look for it, but at least i learned a thing or two while doing that
--
To view, visit https://review.coreboot.org/c/coreboot/+/69109
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I7be5d6c32458ba98f4f8c5c9340790ff989c91e7
Gerrit-Change-Number: 69109
Gerrit-PatchSet: 2
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Elyes Haouas <ehaouas(a)noos.fr>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Arthur Heymans <arthur.heymans(a)9elements.com>
Gerrit-Attention: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Comment-Date: Thu, 03 Nov 2022 21:38:20 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: Yes
Gerrit-MessageType: comment
Attention is currently required from: Jason Nien, Martin Roth.
Matt DeVillier has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/69178 )
Change subject: mb/google/guybrush: Implement touchscreen power sequencing
......................................................................
mb/google/guybrush: Implement touchscreen power sequencing
As all variants have a touchscreen option, in baseboard table set the
enable GPIO high and hold in reset during romstage, then release reset
in ramstage. This will allow the touchscreen to make use of the runtime
I2C detect feature (enabled in a subsequent commit) so that an ACPI
device entry is created only for the touchscreen actually present.
Variants/SKUs which do not have a touchscreen (if any) can use the
romstage/ramstage GPIO override tables to set the associated enable/
reset GPIOs to NC.
This mirrors the change to skyrim in CB:67778.
BUG=b:121309055
TEST=build/boot guybrush with rest of patch series
Change-Id: I9b3356b8b3a0e68a307838a4b18775d25b32e548
Signed-off-by: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
---
M src/mainboard/google/guybrush/variants/baseboard/gpio.c
1 file changed, 31 insertions(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/78/69178/1
diff --git a/src/mainboard/google/guybrush/variants/baseboard/gpio.c b/src/mainboard/google/guybrush/variants/baseboard/gpio.c
index beb654f..595f680 100644
--- a/src/mainboard/google/guybrush/variants/baseboard/gpio.c
+++ b/src/mainboard/google/guybrush/variants/baseboard/gpio.c
@@ -135,7 +135,7 @@
/* TCHSCR_REPORT_EN */
PAD_GPO(GPIO_120, LOW),
/* TCHSCR_RESET_L */
- PAD_GPO(GPIO_121, LOW),
+ PAD_GPO(GPIO_121, HIGH),
/* GPIO_122 - GPIO_128: Not available */
/* SOC_DISABLE_DISP_BL */
PAD_GPO(GPIO_129, LOW),
@@ -284,6 +284,11 @@
PAD_NC(GPIO_70),
/* PCIE_RST0_L */
PAD_NFO(GPIO_26, PCIE_RST_L, HIGH),
+ /* Enable touchscreen, hold in reset */
+ /* EN_PP3300_TCHSCR */
+ PAD_GPO(GPIO_68, HIGH),
+ /* TCHSCR_RESET_L */
+ PAD_GPO(GPIO_121, LOW),
};
const struct soc_amd_gpio *baseboard_romstage_gpio_table(size_t *size)
--
To view, visit https://review.coreboot.org/c/coreboot/+/69178
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I9b3356b8b3a0e68a307838a4b18775d25b32e548
Gerrit-Change-Number: 69178
Gerrit-PatchSet: 1
Gerrit-Owner: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Attention: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-MessageType: newchange
Attention is currently required from: Jason Nien, Martin Roth.
Matt DeVillier has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/69176 )
Change subject: mb/google/guybrush: rename baseboard GPIO table getter for clarity
......................................................................
mb/google/guybrush: rename baseboard GPIO table getter for clarity
Rename variant_pcie_gpio_table() to baseboard_pcie_gpio_table(), since
the GPIO table comes from the baseboard and is overridden by a separate
table from the variant.
Drop the __weak qualifier as this function is not overridden.
This is similar to the change made for skyrim in CB:67809
Change-Id: I14c79fad04f18d874ce6ff7e572bb237445db8b1
Signed-off-by: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
---
M src/mainboard/google/guybrush/romstage.c
M src/mainboard/google/guybrush/variants/baseboard/gpio.c
M src/mainboard/google/guybrush/variants/baseboard/include/baseboard/variants.h
3 files changed, 21 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/76/69176/1
diff --git a/src/mainboard/google/guybrush/romstage.c b/src/mainboard/google/guybrush/romstage.c
index 23e7853..0b7649b 100644
--- a/src/mainboard/google/guybrush/romstage.c
+++ b/src/mainboard/google/guybrush/romstage.c
@@ -9,7 +9,7 @@
const struct soc_amd_gpio *base_gpios, *override_gpios;
/* Initialize PCIe reset. */
- base_gpios = variant_pcie_gpio_table(&base_num_gpios);
+ base_gpios = baseboard_pcie_gpio_table(&base_num_gpios);
override_gpios = variant_pcie_override_gpio_table(&override_num_gpios);
gpio_configure_pads_with_override(base_gpios, base_num_gpios,
diff --git a/src/mainboard/google/guybrush/variants/baseboard/gpio.c b/src/mainboard/google/guybrush/variants/baseboard/gpio.c
index 8554c4c..1ee70da 100644
--- a/src/mainboard/google/guybrush/variants/baseboard/gpio.c
+++ b/src/mainboard/google/guybrush/variants/baseboard/gpio.c
@@ -286,7 +286,7 @@
PAD_NFO(GPIO_26, PCIE_RST_L, HIGH),
};
-const struct soc_amd_gpio *__weak variant_pcie_gpio_table(size_t *size)
+const struct soc_amd_gpio *baseboard_pcie_gpio_table(size_t *size)
{
*size = ARRAY_SIZE(pcie_gpio_table);
return pcie_gpio_table;
diff --git a/src/mainboard/google/guybrush/variants/baseboard/include/baseboard/variants.h b/src/mainboard/google/guybrush/variants/baseboard/include/baseboard/variants.h
index bf69443..9a57c41 100644
--- a/src/mainboard/google/guybrush/variants/baseboard/include/baseboard/variants.h
+++ b/src/mainboard/google/guybrush/variants/baseboard/include/baseboard/variants.h
@@ -30,7 +30,7 @@
const struct soc_amd_gpio *variant_bootblock_gpio_table(size_t *size);
/* This function provides GPIO settings before PCIe enumeration. */
-const struct soc_amd_gpio *variant_pcie_gpio_table(size_t *size);
+const struct soc_amd_gpio *baseboard_pcie_gpio_table(size_t *size);
/* This function provides GPIO settings for eSPI bus. */
const struct soc_amd_gpio *variant_espi_gpio_table(size_t *size);
--
To view, visit https://review.coreboot.org/c/coreboot/+/69176
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I14c79fad04f18d874ce6ff7e572bb237445db8b1
Gerrit-Change-Number: 69176
Gerrit-PatchSet: 1
Gerrit-Owner: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Attention: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-MessageType: newchange
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/69175
to look at the new patch set (#2).
Change subject: Documentation/drivers: Update section on touchscreen runtime detection
......................................................................
Documentation/drivers: Update section on touchscreen runtime detection
Update section now that google/skyrim and google/guybrush implement
power sequencing and touchscreen runtime detection.
Change-Id: Ida63bebf18575d6856edfc65965ff82a4072df87
Signed-off-by: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
---
M Documentation/drivers/dt_entries.md
1 file changed, 17 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/75/69175/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/69175
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ida63bebf18575d6856edfc65965ff82a4072df87
Gerrit-Change-Number: 69175
Gerrit-PatchSet: 2
Gerrit-Owner: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-MessageType: newpatchset
Attention is currently required from: Jason Glenesk, Raul Rangel, Jason Nien, Matt DeVillier, Martin Roth, Fred Reitberger, Karthik Ramasubramanian, Felix Held.
Jon Murphy has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/68946 )
Change subject: soc/amd/common/block/spi: Mainboard to override SPI Read Mode
......................................................................
Patch Set 1:
(2 comments)
Commit Message:
https://review.coreboot.org/c/coreboot/+/68946/comment/74c6810b_38a575b7
PS1, Line 15: BUG=b:225213679
This bug was marked dupe, and the one that it's a dupe of was marked won't fix infeasible, is this really the right bug?
File src/mainboard/google/guybrush/spi_speeds.c:
https://review.coreboot.org/c/coreboot/+/68946/comment/03b02890_8dc48def
PS1, Line 7: void mainboard_spi_cfg_override(uint8_t *fast_speed, uint8_t *read_mode)
Rename variable speed? It's no longer solely the fast speed
--
To view, visit https://review.coreboot.org/c/coreboot/+/68946
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I160b56f6201a798ce59e977ca40301e23ab63805
Gerrit-Change-Number: 68946
Gerrit-PatchSet: 1
Gerrit-Owner: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Reviewer: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Reviewer: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Reviewer: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Reviewer: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Jon Murphy <jpmurphy(a)google.com>
Gerrit-Reviewer: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Reviewer: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jason Glenesk <jason.glenesk(a)gmail.com>
Gerrit-Attention: Raul Rangel <rrangel(a)chromium.org>
Gerrit-Attention: Jason Nien <jason.nien(a)amd.corp-partner.google.com>
Gerrit-Attention: Matt DeVillier <matt.devillier(a)amd.corp-partner.google.com>
Gerrit-Attention: Martin Roth <martin.roth(a)amd.corp-partner.google.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Karthik Ramasubramanian <kramasub(a)google.com>
Gerrit-Attention: Felix Held <felix-coreboot(a)felixheld.de>
Gerrit-Comment-Date: Thu, 03 Nov 2022 21:34:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment