Attention is currently required from: Caveh Jalali, Julius Werner, Yu-Ping Wu, Boris Mittelberg.
Jakub Czapiga has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69762 )
Change subject: vboot: Allow for comparison of hash without zero-padding
......................................................................
Patch Set 6:
(1 comment)
File src/security/vboot/vboot_logic.c:
https://review.coreboot.org/c/coreboot/+/69762/comment/716ed1e8_ae35b0a9
PS5, Line 99: if (slot_hash_sz < saved_hash_sz) {
> Not sure why we need to bother checking the extra zeroes?
Hmm. I was thinking about some potential attack strategy which could be used in case when we did not perform full comparison, but after talking to my colleagues about this I think it's pointless and would not make any difference at all.
--
To view, visit https://review.coreboot.org/c/coreboot/+/69762
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If6d46e0b58dbca86af56221b7ff2606ab2d1799a
Gerrit-Change-Number: 69762
Gerrit-PatchSet: 6
Gerrit-Owner: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: Boris Mittelberg <bmbm(a)google.com>
Gerrit-Reviewer: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Attention: Boris Mittelberg <bmbm(a)google.com>
Gerrit-Comment-Date: Wed, 23 Nov 2022 15:22:27 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Julius Werner.
Jakub Czapiga has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69761 )
Change subject: vboot/vboot_common: Fix vboot_save_data() code exclusion guard
......................................................................
Patch Set 5:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/69761/comment/a61d5839_4bed02c4
PS4, Line 12: reduction of undefined references.
> I find this hard to believe... […]
I didn't believe this was a cause either, but this patch really works. Without it I'm getting errors below. I'm building google/volteer/voxel variant.
```
coreboot-9999: /opt/coreboot-sdk/bin/i386-elf-ld.bfd: /build/volteer/tmp/portage/sys-boot/coreboot-9999/work/build/voxel/postcar/security/vboot/vboot_common.o: in function `vboot_save_data':
coreboot-9999: /build/volteer/tmp/portage/sys-boot/coreboot-9999/work/coreboot-9999/src/security/vboot/vboot_common.c:22: undefined reference to `antirollback_write_space_firmware'
coreboot-9999: /opt/coreboot-sdk/bin/i386-elf-ld.bfd: /build/volteer/tmp/portage/sys-boot/coreboot-9999/work/coreboot-9999/src/security/vboot/vboot_common.c:29: undefined reference to `antirollback_write_space_kernel'
```
--
To view, visit https://review.coreboot.org/c/coreboot/+/69761
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ia5330efeeb4cfd7477cf8f7f64c6abed68281e30
Gerrit-Change-Number: 69761
Gerrit-PatchSet: 5
Gerrit-Owner: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Julius Werner <jwerner(a)chromium.org>
Gerrit-Comment-Date: Wed, 23 Nov 2022 15:22:22 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Julius Werner <jwerner(a)chromium.org>
Gerrit-MessageType: comment
Attention is currently required from: Tarun Tuli, Kapil Porwal.
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69937 )
Change subject: drivers/wifi, mb/google: Rename is_untrusted to add_acpi_dma_property
......................................................................
Patch Set 1:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/69937/comment/fa74663b_5a536a2c
PS1, Line 7: drivers/wifi, mb/google
use curly braces before and after where there are more than one
--
To view, visit https://review.coreboot.org/c/coreboot/+/69937
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I4e0829a76a193b0a1e1e0f2b7ce2119bb00dd696
Gerrit-Change-Number: 69937
Gerrit-PatchSet: 1
Gerrit-Owner: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Comment-Date: Wed, 23 Nov 2022 15:08:52 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Tarun Tuli, Kapil Porwal.
Subrata Banik has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69937 )
Change subject: drivers/wifi, mb/google: Rename is_untrusted to add_acpi_dma_property
......................................................................
Patch Set 1:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/69937/comment/fced46f8_130b7f0f
PS1, Line 10:
may be why you are renaming is missing.
You could clarify that `is_untrusted` is eventually ended up by adding DMA property _DSD which any way for WWAN driver add_acpi_dma_property does, hence it make sense to have unified name across different device driver
--
To view, visit https://review.coreboot.org/c/coreboot/+/69937
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I4e0829a76a193b0a1e1e0f2b7ce2119bb00dd696
Gerrit-Change-Number: 69937
Gerrit-PatchSet: 1
Gerrit-Owner: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Kapil Porwal <kapilporwal(a)google.com>
Gerrit-Comment-Date: Wed, 23 Nov 2022 15:08:10 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Jakub Czapiga, Caveh Jalali, Yu-Ping Wu, Boris Mittelberg.
Hello build bot (Jenkins), Caveh Jalali, Julius Werner, Yu-Ping Wu, Boris Mittelberg,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/69762
to look at the new patch set (#6).
Change subject: vboot: Allow for comparison of hash without zero-padding
......................................................................
vboot: Allow for comparison of hash without zero-padding
Adjust asserts to allow to store and compare (at S3 resume) hashes
without padding to maximum hash length / slot size.
Signed-off-by: Jakub Czapiga <jacz(a)semihalf.com>
Change-Id: If6d46e0b58dbca86af56221b7ff2606ab2d1799a
---
M src/ec/google/chromeec/vboot_storage.c
M src/security/vboot/vboot_logic.c
2 files changed, 16 insertions(+), 3 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/62/69762/6
--
To view, visit https://review.coreboot.org/c/coreboot/+/69762
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: If6d46e0b58dbca86af56221b7ff2606ab2d1799a
Gerrit-Change-Number: 69762
Gerrit-PatchSet: 6
Gerrit-Owner: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: Boris Mittelberg <bmbm(a)google.com>
Gerrit-Reviewer: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Attention: Caveh Jalali <caveh(a)chromium.org>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Attention: Boris Mittelberg <bmbm(a)google.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Jakub Czapiga.
Hello build bot (Jenkins), Julius Werner, Eric Lai, Yu-Ping Wu,
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/69761
to look at the new patch set (#5).
Change subject: vboot/vboot_common: Fix vboot_save_data() code exclusion guard
......................................................................
vboot/vboot_common: Fix vboot_save_data() code exclusion guard
Compilers are not optimizing-out code correctly. This patch fixes
incorrect behavior by splitting if statement and extracting code to
another function, this allowing for better code size optimization and
reduction of undefined references.
Signed-off-by: Jakub Czapiga <jacz(a)semihalf.com>
Change-Id: Ia5330efeeb4cfd7477cf8f7f64c6abed68281e30
---
M src/security/vboot/vboot_common.c
1 file changed, 32 insertions(+), 10 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/61/69761/5
--
To view, visit https://review.coreboot.org/c/coreboot/+/69761
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Ia5330efeeb4cfd7477cf8f7f64c6abed68281e30
Gerrit-Change-Number: 69761
Gerrit-PatchSet: 5
Gerrit-Owner: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-Reviewer: Eric Lai <eric_lai(a)quanta.corp-partner.google.com>
Gerrit-Reviewer: Julius Werner <jwerner(a)chromium.org>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Jakub Czapiga <jacz(a)semihalf.com>
Gerrit-MessageType: newpatchset
Attention is currently required from: Tarun Tuli, Subrata Banik.
build bot (Jenkins) has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69949 )
Change subject: soc/intel/alderlake: Hook up P2SB PCI ops
......................................................................
Patch Set 2:
(1 comment)
Commit Message:
Robot Comment from checkpatch (run ID jenkins-coreboot-checkpatch-164386):
https://review.coreboot.org/c/coreboot/+/69949/comment/b7aefa43_b0458345
PS2, Line 12: soc_enable function so that the resources will be reported. The P2SB
'resouce' may be misspelled - perhaps 'resource'?
--
To view, visit https://review.coreboot.org/c/coreboot/+/69949
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I7c59441268676a8aab075abbc036e651b9426057
Gerrit-Change-Number: 69949
Gerrit-PatchSet: 2
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: Subrata Banik <subratabanik(a)google.com>
Gerrit-Reviewer: Tarun Tuli <taruntuli(a)google.com>
Gerrit-CC: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Tarun Tuli <taruntuli(a)google.com>
Gerrit-Attention: Subrata Banik <subratabanik(a)google.com>
Gerrit-Comment-Date: Wed, 23 Nov 2022 14:40:15 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Martin L Roth, Fred Reitberger.
Nicholas Chin has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69863 )
Change subject: util/kconfig: Fix patch to be compatible with quilt
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
> I think the comment added in your other patch does add value here and would recommend adding it (pos […]
I'm assuming you're referring to this comment? https://review.coreboot.org/c/coreboot/+/69450/1/util/kconfig/confdata.c#10…
--
To view, visit https://review.coreboot.org/c/coreboot/+/69863
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I95bfe6571e3a2cc2b38074b4338f1610a4c8a595
Gerrit-Change-Number: 69863
Gerrit-PatchSet: 1
Gerrit-Owner: Nicholas Chin <nic.c3.14(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Comment-Date: Wed, 23 Nov 2022 14:33:29 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-MessageType: comment
Attention is currently required from: Martin L Roth, Nicholas Chin.
Fred Reitberger has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/69863 )
Change subject: util/kconfig: Fix patch to be compatible with quilt
......................................................................
Patch Set 1:
(1 comment)
Patchset:
PS1:
I think the comment added in your other patch does add value here and would recommend adding it (possibly here or another patch) if possible
--
To view, visit https://review.coreboot.org/c/coreboot/+/69863
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I95bfe6571e3a2cc2b38074b4338f1610a4c8a595
Gerrit-Change-Number: 69863
Gerrit-PatchSet: 1
Gerrit-Owner: Nicholas Chin <nic.c3.14(a)gmail.com>
Gerrit-Reviewer: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Fred Reitberger <reitbergerfred(a)gmail.com>
Gerrit-Attention: Martin L Roth <gaumless(a)gmail.com>
Gerrit-Attention: Nicholas Chin <nic.c3.14(a)gmail.com>
Gerrit-Comment-Date: Wed, 23 Nov 2022 14:22:46 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment