Attention is currently required from: Patrick Rudolph.
Arthur Heymans has uploaded this change for review. ( https://review.coreboot.org/c/coreboot/+/52930 )
Change subject: sb/intel/common: Fix platform_is_resuming()
......................................................................
sb/intel/common: Fix platform_is_resuming()
platform_is_resuming() was using the wrong register (PM1_STS) to figure
out if the platform was resuming (PM1_CNT).
Change-Id: I1f69dca1da158aae15c6da6d4c898c71d9cdb51f
Signed-off-by: Arthur Heymans <arthur(a)aheymans.xyz>
---
M src/southbridge/intel/common/pmbase.c
1 file changed, 1 insertion(+), 1 deletion(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/30/52930/1
diff --git a/src/southbridge/intel/common/pmbase.c b/src/southbridge/intel/common/pmbase.c
index bbd2c25..a5b50a6 100644
--- a/src/southbridge/intel/common/pmbase.c
+++ b/src/southbridge/intel/common/pmbase.c
@@ -87,5 +87,5 @@
if (!(reg16 & WAK_STS))
return 0;
- return acpi_sleep_from_pm1(reg16) == ACPI_S3;
+ return acpi_get_sleep_type() == ACPI_S3;
}
--
To view, visit https://review.coreboot.org/c/coreboot/+/52930
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I1f69dca1da158aae15c6da6d4c898c71d9cdb51f
Gerrit-Change-Number: 52930
Gerrit-PatchSet: 1
Gerrit-Owner: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-Attention: Patrick Rudolph <siro(a)das-labor.org>
Gerrit-MessageType: newchange
Nico Huber has submitted this change. ( https://review.coreboot.org/c/coreboot/+/52518 )
Change subject: src/cpu/x86/smm: remove debug message; not thread safe
......................................................................
src/cpu/x86/smm: remove debug message; not thread safe
This patch removes a call to console_init() and debug print message since
the code is not thread safe. This prevents system hangs (soft hangs)
while in SMM if user drops in a new SOC with more cores or another
socket or as a result of bad configuration. Console is already
initialized after the lock has been acquired so this does not affect any
other functionality.
Tested on DeltaLake mainboard with SMM enabled and 52 CPU threads.
Change-Id: I7e8af35d1cde78b327144b6a9da528ae7870e874
Signed-off-by: Rocky Phagura <rphagura(a)fb.com>
Reviewed-on: https://review.coreboot.org/c/coreboot/+/52518
Tested-by: build bot (Jenkins) <no-reply(a)coreboot.org>
Reviewed-by: Nico Huber <nico.h(a)gmx.de>
Reviewed-by: Angel Pons <th3fanbus(a)gmail.com>
---
M src/cpu/x86/smm/smm_module_handler.c
1 file changed, 1 insertion(+), 3 deletions(-)
Approvals:
build bot (Jenkins): Verified
Nico Huber: Looks good to me, approved
Angel Pons: Looks good to me, but someone else must approve
diff --git a/src/cpu/x86/smm/smm_module_handler.c b/src/cpu/x86/smm/smm_module_handler.c
index f7cf928..0c0de78 100644
--- a/src/cpu/x86/smm/smm_module_handler.c
+++ b/src/cpu/x86/smm/smm_module_handler.c
@@ -132,9 +132,7 @@
gnvs = (void *)(uintptr_t)smm_runtime.gnvs_ptr;
if (cpu >= CONFIG_MAX_CPUS) {
- console_init();
- printk(BIOS_CRIT,
- "Invalid CPU number assigned in SMM stub: %d\n", cpu);
+ /* Do not log messages to console here, it is not thread safe */
return;
}
--
To view, visit https://review.coreboot.org/c/coreboot/+/52518
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I7e8af35d1cde78b327144b6a9da528ae7870e874
Gerrit-Change-Number: 52518
Gerrit-PatchSet: 6
Gerrit-Owner: Rocky Phagura
Gerrit-Reviewer: Aaron Durbin <adurbin(a)chromium.org>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Arthur Heymans <arthur(a)aheymans.xyz>
Gerrit-Reviewer: David Hendricks <david.hendricks(a)gmail.com>
Gerrit-Reviewer: Jonathan Zhang <jonzhang(a)fb.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Rocky Phagura <rphagura(a)fb.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-MessageType: merged
Attention is currently required from: Furquan Shaikh, Tim Wawrzynczak, Subrata Banik, Angel Pons.
Nico Huber has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/52895 )
Change subject: include/console: Fix duplicate entry of postcode 0x79
......................................................................
Patch Set 3:
(3 comments)
Patchset:
PS3:
I only use post codes about once every 3 years, so I don't mind
any changes. I didn't notice that the other definition is unused,
but agree to what Angel says.
I left two random thoughts anyway :)
File src/arch/x86/c_start.S:
https://review.coreboot.org/c/coreboot/+/52895/comment/e558fcb2_a5629a1a
PS3, Line 92: post_code(POST_PRE_HARDWAREMAIN) /* post 6e */
NB. I once worked on another project with similar defines for status
codes and comments with their values. This is generally hard to main-
tain and very confusing if updating a comment was missed. The solution
I came up with was to make the codes part of the identifier, e.g.
#define POST_PRE_HARDWAREMAIN_6e 0x6e
This way no comment is needed, and the compiler would notice if some
place isn't updated. What do you think?
File src/include/console/post_codes.h:
https://review.coreboot.org/c/coreboot/+/52895/comment/8508bd4e_644c0f43
PS3, Line 120: #define POST_ENTRY_RAMSTAGE 0x6f
When I first read the patch, I thought this is out of order. "entry
ramstage" made me think this is the real entry (in assembler). Maybe
it could be renamed to `POST_ENTRY_HARDWAREMAIN`?
--
To view, visit https://review.coreboot.org/c/coreboot/+/52895
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I50cc75cd3097fba3e7faff05188511bba69ef1e7
Gerrit-Change-Number: 52895
Gerrit-PatchSet: 3
Gerrit-Owner: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Reviewer: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Reviewer: Furquan Shaikh <furquan(a)google.com>
Gerrit-Reviewer: Nico Huber <nico.h(a)gmx.de>
Gerrit-Reviewer: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Furquan Shaikh <furquan(a)google.com>
Gerrit-Attention: Tim Wawrzynczak <twawrzynczak(a)chromium.org>
Gerrit-Attention: Subrata Banik <subrata.banik(a)intel.com>
Gerrit-Attention: Angel Pons <th3fanbus(a)gmail.com>
Gerrit-Comment-Date: Wed, 05 May 2021 09:20:40 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Hung-Te Lin, Rex-BC Chen, Yu-Ping Wu, Yidi Lin.
Paul Menzel has posted comments on this change. ( https://review.coreboot.org/c/coreboot/+/52924 )
Change subject: mb/google/cherry: configure GPIOs
......................................................................
Patch Set 1:
(1 comment)
Commit Message:
https://review.coreboot.org/c/coreboot/+/52924/comment/df8c13ef_3bfe1c9e
PS1, Line 8:
Please elaborate, what GPIOs are configured, and where you got this from.
--
To view, visit https://review.coreboot.org/c/coreboot/+/52924
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: Id553f632412af440d21a3b51e017cb74cc27fd22
Gerrit-Change-Number: 52924
Gerrit-PatchSet: 1
Gerrit-Owner: Rex-BC Chen <rex-bc.chen(a)mediatek.corp-partner.google.com>
Gerrit-Reviewer: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Reviewer: Yidi Lin <yidi.lin(a)mediatek.com>
Gerrit-Reviewer: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-CC: Paul Menzel <paulepanter(a)mailbox.org>
Gerrit-Attention: Hung-Te Lin <hungte(a)chromium.org>
Gerrit-Attention: Rex-BC Chen <rex-bc.chen(a)mediatek.corp-partner.google.com>
Gerrit-Attention: Yu-Ping Wu <yupingso(a)google.com>
Gerrit-Attention: Yidi Lin <yidi.lin(a)mediatek.com>
Gerrit-Comment-Date: Wed, 05 May 2021 09:20:05 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Gerrit-MessageType: comment
Attention is currently required from: Michał Żygowski.
Hello build bot (Jenkins),
I'd like you to reexamine a change. Please visit
https://review.coreboot.org/c/coreboot/+/52922
to look at the new patch set (#2).
Change subject: nb/amd/{agesa,pi}: Avoid overflows during DRAM calculation
......................................................................
nb/amd/{agesa,pi}: Avoid overflows during DRAM calculation
Do not use get_dram_base_mask to calculate system DRAM limits. Shift
operation around values operating on base and mask were causing
overflows and thus incorrect system DRAM limit. Another function
returning base and limit in KiB has been developed to avoid data loss.
TEST=boot PC Engines apu1 2GB, apu2 4GB and apu3 2GB and boot Debian
with Linux 4.14
Signed-off-by: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Change-Id: I3b5c1df96c308ff50c8de104e213219a98f25e10
---
M src/northbridge/amd/agesa/family14/northbridge.c
M src/northbridge/amd/agesa/family15tn/northbridge.c
M src/northbridge/amd/agesa/family16kb/northbridge.c
M src/northbridge/amd/pi/00730F01/northbridge.c
4 files changed, 136 insertions(+), 155 deletions(-)
git pull ssh://review.coreboot.org:29418/coreboot refs/changes/22/52922/2
--
To view, visit https://review.coreboot.org/c/coreboot/+/52922
To unsubscribe, or for help writing mail filters, visit https://review.coreboot.org/settings
Gerrit-Project: coreboot
Gerrit-Branch: master
Gerrit-Change-Id: I3b5c1df96c308ff50c8de104e213219a98f25e10
Gerrit-Change-Number: 52922
Gerrit-PatchSet: 2
Gerrit-Owner: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-Reviewer: build bot (Jenkins) <no-reply(a)coreboot.org>
Gerrit-Attention: Michał Żygowski <michal.zygowski(a)3mdeb.com>
Gerrit-MessageType: newpatchset